Support in other languages: 
Reply
Ctrl-Alt-Del
niklaas
Posts: 12
Registered: ‎11-29-2011
Location: Vienna
0
Accepted Solution

T420: sound buzzes sometimes when playing videos or music

[ Edited ]

Hi,

 

I got my new T420 just one month ago. I ordered it without any OS, so did a clean install of Windows 7 x64 later and everything worked fine.

 

Recently, I realised that the sound buzzes (like lagging for a fraction of a second) sometimes when watching a movie (doesn't matter whether in YouTube or Media Player Classic: Home Cinema) or listening to music (doesn't matter whether in iTunes or any other music player. I also checked whether it's got something to do with the AC mains power plugged in or not, but the problem appears with every setup.

 

I also ran System Updater and did a BIOS Update.

 

Does anybody have any idea about this or a hint on how analyzing the problem?

 

Thanks for your help, Niklaas 

Paper Tape
JonRL
Posts: 3
Registered: ‎11-29-2011
Location: NJ
0

Re: T420: sound buzzes sometimes when playing videos or music

I've never run into this issue before, but a couple of other things to check - check the driver for your sound card, and ensure there's no updates or known bugs.  You could also open up the laptop and check to see if the sound card is seated properly.

 

Question - what about other sounds? You mention videos and music.  What about talking, such as an eBook?  Any issues with system sounds?

802.11n
pleon
Posts: 283
Registered: ‎12-01-2009
Location: Czech Republic
0

Re: T420: sound buzzes sometimes when playing videos or music

[ Edited ]
I think i have the same issue with my new T420s. I used till now T400s and even if i listen same music, there is sometimes short buzzing now, have no idea why. I did not focus on this much, but if i am thinking about it, it really occurs during listening of anythink, music from MP3, internet radio, video, doesnt matter what. Strange. I have all up-to-date drivers.
----------------------------------------------------
Lenovo T430s, 2356LQG, Windows 8.1 Pro x64 UEFI, Intel 520 SSD 180 GB, 8 GB RAM
Lenovo T420s, 4171-6SG, Windows 8 Pro x64 UEFI, Intel 320 SSD 120 GB, 8 GB RAM
Lenovo T400s, 2808-CYG, Windows 7 Ultimate x64
Guru
ColonelONeill
Posts: 6,293
Registered: ‎12-26-2009
Location: Toronto
0

Re: T420: sound buzzes sometimes when playing videos or music

Can you run DPC Latency Checker?
http://www.thesycon.de/deu/latency_check.shtml
W520: i7-2720QM, Q2000M at 1099/688/1377, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Ctrl-Alt-Del
niklaas
Posts: 12
Registered: ‎11-29-2011
Location: Vienna
0

Re: T420: sound buzzes sometimes when playing videos or music

[ Edited ]

I ran DPC Latency Checker and it looks like I found the issue or at least a program also telling me that something's running wrong. Thanks to you, ColonelONeill!

 

If no program is running, every bar is green, but restarting my VMs in VirtualBox causes pictures like this one: http://imageshack.us/photo/my-images/840/dpclatency01.png/ . So I tried to figure out which driver is causing this behaviour and deactivated (one by one) every driver in the device manager except those in "system drivers" (I hope the translation is right, because I'm using a German system). But there was no change.

 

Running iTunes parallelly even causes extremly high latencies like 114451µs.

 

Does someone know anything about bugs on the T420? Or any other hints for solving the problem?

 

Thanks for your help! 

Ctrl-Alt-Del
niklaas
Posts: 12
Registered: ‎11-29-2011
Location: Vienna
0

Re: T420: sound buzzes sometimes when playing videos or music

JonRL, I never noticed the issue with system sounds, but I think because they are too short.

System Update says that every driver is up-to-date.
Ctrl-Alt-Del
niklaas
Posts: 12
Registered: ‎11-29-2011
Location: Vienna
0

Re: T420: sound buzzes sometimes when playing videos or music

Hi pleon,

 

I just found this thread http://forums.lenovo.com/t5/T400-T500-and-newer-T-series/DPC-latency-audio-mouse-skip-and-stutter-on... by mojojoj0 who's got a very similar issue; maybe his solution helps in your case.

 

Niklaas 

Guru
ColonelONeill
Posts: 6,293
Registered: ‎12-26-2009
Location: Toronto
0

Re: T420: sound buzzes sometimes when playing videos or music

[ Edited ]

lol iTunes. I'd avoid iTunes for a lot of reasons.

You can use LatencyMon to pinpoint the exact driver file, although it doesn't give you a time graph.

I'm not sure if restarting a VM should cause that sort of blip, although I'm not sure how deep VirtualBox hooks into the system.

 

EDIT: Booting and resuming two VMWare Workstation VMs don't produce those blips for me. (Guest 2000 and 8.)

W520: i7-2720QM, Q2000M at 1099/688/1377, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Ctrl-Alt-Del
niklaas
Posts: 12
Registered: ‎11-29-2011
Location: Vienna
0

Re: T420: sound buzzes sometimes when playing videos or music

Thanks for your help.

 

Yes, I don't like iTunes neither but if you get an iPod as a present you're kind of stuck to it.

 

So I installed LatencyMon and ran it; got this report:

 

_________________________________________________________________________________________________________
CONCLUSION
_________________________________________________________________________________________________________
Your system appears to be having trouble handling real-time audio and other tasks. You are likely to experience buffer underruns appearing as drop outs, clicks or pops. One or more DPC routines belonging to a driver running in your system appear to be executing for too long. At least one detected problem appears to be network related. You may have to disable wireless adapters to get better results. 
LatencyMon has been analyzing your system for 0:19:23 (h:mm:ss)


_________________________________________________________________________________________________________
System Information
_________________________________________________________________________________________________________
Computer name:                                        LEN-T420
OS version:                                           Windows 7 Service Pack 1, 6.1, build: 7601
CPU:                                                  GenuineIntel        Intel(R) Core(TM) i5-2540M CPU @ 2.60GHz
Logical processors:                                   4
RAM:                                                  8463273984 total
VM:                                                   2147352576, free: 1852497920


_________________________________________________________________________________________________________
CPU SPEED
_________________________________________________________________________________________________________
Reported CPU speed:                                   2591 MHz
Measured CPU speed:                                   1854 MHz

Note: reported execution times may be calculated based on a fixed reported CPU speed. Disable variable speed settings like Intel Speed Step and AMD Cool N Quiet in the BIOS setup for more accurate results.


_________________________________________________________________________________________________________
MEASURED KERNEL TIMER LATENCIES
_________________________________________________________________________________________________________
Highest measured kernel timer latency (µs):           76530.1606


_________________________________________________________________________________________________________
MEASURED SMIs AND CPU STALLS
_________________________________________________________________________________________________________
Highest measured SMI routine or CPU stall (µs)        20.5454


_________________________________________________________________________________________________________
REPORTED DPCs
_________________________________________________________________________________________________________
Highest DPC routine execution time (µs):              76675.9204
Driver with highest DPC routine execution time:       ndis.sys - NDIS 6.20-Treiber, Microsoft Corporation

Highest reported total DPC routine time (%):          0.2233
Driver with highest DPC total execution time:         rspLLL64.sys - Resplendence Latency Monitoring and Auxiliary Kernel Library, Resplendence Software Projects Sp.

Total time spent in DPCs (%)                          0.4000

DPC count (execution time <250 µs):                   3129405
DPC count (execution time 250-500 µs):                0
DPC count (execution time 500-999 µs):                0
DPC count (execution time 1000-1999 µs):              0
DPC count (execution time 2000-3999 µs):              0
DPC count (execution time >=4000 µs):                 0


_________________________________________________________________________________________________________
 REPORTED ISRs
_________________________________________________________________________________________________________
Highest ISR routine execution time (µs):              75.6067
Driver with highest ISR routine execution time:       i8042prt.sys - i8042-Anschlusstreiber, Microsoft Corporation

Highest reported total ISR routine time (%):          0.6570
Driver with highest ISR total time:                   hal.dll - Hardware Abstraction Layer DLL, Microsoft Corporation

Total time spent in ISRs (%)                          0.1483

ISR count (execution time <250 µs):                   1871258
ISR count (execution time 250-500 µs):                0
ISR count (execution time 500-999 µs):                0
ISR count (execution time 1000-1999 µs):              0
ISR count (execution time 2000-3999 µs):              0
ISR count (execution time >=4000 µs):                 0


_________________________________________________________________________________________________________
 REPORTED HARD PAGEFAULTS
_________________________________________________________________________________________________________
Process with highest pagefault count:                 none

Total number of hard pagefaults                       3946
Hard pagefault count of hardest hit process:          3596
Highest hard pagefault resolution time (µs):          591009.8830
Total time spent in hard pagefaults (%):              0.6802
TODO: Number of processes hit:                        0


_________________________________________________________________________________________________________
 PER CPU DATA
_________________________________________________________________________________________________________
CPU 0 ISR count:                                      1871258
CPU 0 ISR highest execution time:                     75.6067
CPU 0 ISR total execution time:                       6901017.9498
CPU 0 DPC count:                                      3010392
CPU 0 DPC highest execution time:                     76675.9204
CPU 0 DPC total execution time:                       18086551.3894
_________________________________________________________________________________________________________
CPU 1 ISR count:                                      0
CPU 1 ISR highest execution time:                     0.0000
CPU 1 ISR total execution time:                       0.0000
CPU 1 DPC count:                                      22017
CPU 1 DPC highest execution time:                     35013.8250
CPU 1 DPC total execution time:                       114896.4670
_________________________________________________________________________________________________________
CPU 2 ISR count:                                      0
CPU 2 ISR highest execution time:                     0.0000
CPU 2 ISR total execution time:                       0.0000
CPU 2 DPC count:                                      69512
CPU 2 DPC highest execution time:                     94.7228
CPU 2 DPC total execution time:                       328118.8016
_________________________________________________________________________________________________________
CPU 3 ISR count:                                      0
CPU 3 ISR highest execution time:                     0.0000
CPU 3 ISR total execution time:                       0.0000
CPU 3 DPC count:                                      27488
CPU 3 DPC highest execution time:                     121.4805
CPU 3 DPC total execution time:                       83244.8907
_________________________________________________________________________________________________________

 

There are also two screenshots I took: http://imageshack.us/photo/my-images/31/latmonscreen201111301.png/ and http://imageshack.us/photo/my-images/593/latmonscreen201111302.png/

 

So I think the drivers causing problems are ndis.sys, iaStore.sys and the first time I ran LatencyMon (unfortunately I don't have any sreens or reports anymore) it also said that tcpip.sys is causing problems.

 

What can I do now? Because I already did an update to the latest drivers with System Update.

 

(I get those high latencies by booting an Archlinux x64.)

 

I appreciate any help, thanks! 

 

 

802.11n
pleon
Posts: 283
Registered: ‎12-01-2009
Location: Czech Republic
0

Re: T420: sound buzzes sometimes when playing videos or music

[ Edited ]
I used DPC Latency Checker, i started the program and first i listened internet radio. After cca 15 minutes i had buzzing and in graph really red peak occurs to cca 32 000 microsec. Then i tried music from mp3 on local SSD and again, after cca 20 minutes of listening i had again buzzing several times and red peaks max came to 70 000 microsec. So it doesnt matter if i listen audio from internet or local disc, this buzzing occurs each time. I tried also latencyMon and after next buzz i checked and it tells that highest DPC comes from tcpip.sys, on another buzz i was ndis.sys. So what should i do now? I think tcpip.sys is not some particullar device driver itself, only driver of the service, or?
----------------------------------------------------
Lenovo T430s, 2356LQG, Windows 8.1 Pro x64 UEFI, Intel 520 SSD 180 GB, 8 GB RAM
Lenovo T420s, 4171-6SG, Windows 8 Pro x64 UEFI, Intel 320 SSD 120 GB, 8 GB RAM
Lenovo T400s, 2808-CYG, Windows 7 Ultimate x64