Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Blue Screen Again
Naukyo
Posts: 6
Registered: ‎02-19-2012
Location: Germany
0
Accepted Solution

T420s No power, blinking power Led - won't boot

[ Edited ]

My 2 months old T420s declines to boot since this morning.

After pressing the Power-Button it starts to alternatingly flash the Power-Button light and the fingerprint reader LED.

Nothing else happens, no fan starting to run or anything else.

I haven't changed anything since yesterday when it booted with no problems.

 

Does anyone know what this could be?

Blue Screen Again
Naukyo
Posts: 6
Registered: ‎02-19-2012
Location: Germany
0

Betreff: T420s not Booting

I just discovered something else, when the Power-Button flashes up the Battery LED is blinking green.

This also happens with just the external Power-Supply connected without any battery.

What's DOS?
Ytrewq
Posts: 1
Registered: ‎02-19-2012
Location: Switzerland
0

Betreff: T420s not Booting

I have exactly the same problem. If I find a solution I will let you know
Guru
ExJamJus
Posts: 1,035
Registered: ‎12-19-2011
Location: Malaysia
0

Re: T420s not Booting

Try removing battery and the AC. Then hold the power button for about 5 secs. then put the battery and AC back then try booting the PC.
*Non Lenovo employee*

I have a Y2P (i5) ... Feel free to ping me if you want me to test some applications with your Y2P if you have the same model. I don't mind keep doing recovery on it if needed .... =)
Guru
Mornsgrans
Posts: 2,473
Registered: ‎03-19-2009
Location: Idar-Oberstein, Germany
0

Re: T420s not Booting

Check the USB ports whether there is a short circuit caused by a missing plastic flap.

--------------------------------
My home-forum: http://www.thinkpad-forum.de
Wiki: Deutsches ThinkPad-Wiki English ThinkWiki
My ThinkPad-Collection
Blue Screen Again
Naukyo
Posts: 6
Registered: ‎02-19-2012
Location: Germany
0

Re: T420s not Booting

[ Edited ]

At least someone else has this problem, too! Thought I was the only one while scanning through different boards for help.

 

Removing Battery, AC and pressing the power button doesn't help. That was actually my first attempt to fix it :smileyhappy:

I've checked the USB ports and they all look ok, no missing plastic flaps, everything's solid and at it's place.

 

Guess I'll just call the support tomorrow and see if they can help me...

Guru
Mornsgrans
Posts: 2,473
Registered: ‎03-19-2009
Location: Idar-Oberstein, Germany
0

Re: T420s not Booting

... or call www.servion.de

--------------------------------
My home-forum: http://www.thinkpad-forum.de
Wiki: Deutsches ThinkPad-Wiki English ThinkWiki
My ThinkPad-Collection
Blue Screen Again
Naukyo
Posts: 6
Registered: ‎02-19-2012
Location: Germany
0

Re: T420s not Booting

@Ytrewq:
I just called servion and they told me that it's probably the mainboard causing the troubles.
Seems I have to mail it in for repairs.

Bit Torrent
ThorsHammer
Posts: 2,400
Registered: ‎04-08-2011
Location: USA
0

Re: T420s not Booting

Is your T420s under warranty and is that your warranty service provider?

Administrator
Mark_Lenovo
Posts: 7,999
Registered: ‎11-19-2007
Location: RTP, North Carolina
0

Re: T420s not Booting

All,

 

For this particular scenario, it is most likely the system board.   It is probably still a good practice to pull the battery and AC and try to reset by pressing and holding the power button several times, for several seconds each time, and then re-attaching AC and try to restart.

 

If the symptoms remain, please contact service for assistance.

 

Best regards,

 

Mark

____________________________________________

ThinkPads: S30, T43, X60t, X1, W700ds, IdeaPad Y710, IdeaCentre: A300, IdeaPad K1
Mark Hopkins
Program Manager, Lenovo Social Media (Services)
twitter @lenovoforums
English English Community   Deutsche Deutsche Community   Español Comunidad en Español   ru.gif Русскоязычное Сообщество