Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Blue Screen Again
huixingcmp
Posts: 5
Registered: ‎10-19-2011
Location: Buffalo, NY
0

T420s bad pixel problem

Hi everyone,

I am a long-time thinkpad fan. I just upgraded from T61 to a brand new T420s. However, my excitement is completely flushed by a bad pixel found only few hours afer I received the mechine. The pixel is not very obvious when the screen showed white colour, but is a very annoying red dot when the screen is in black colour.

I knew that lenovo has a two-bad-pixel policy, but that sounds really not fair. Does anyone know what I should do to get the LCD replaced? I am in New York state. Thanks a lot!

Guru
ColonelONeill
Posts: 7,075
Registered: ‎12-26-2009
Location: Toronto
0

Re: T420s bad pixel problem

It's actually a three dead pixel policy, so you're really out of luck there.

Have you tried some of the stuck pixel remover programs?

What about gently massaging the pixel?
W520: i7-2720QM, Q2000M at 1080/670/1340, 21GB RAM, 500GB HDD, FHD screen
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Blue Screen Again
huixingcmp
Posts: 5
Registered: ‎10-19-2011
Location: Buffalo, NY
0

Re: T420s bad pixel problem

I just contacted Lenovo technical support. After hearing my problem, they immediately created a case number and promise to send a mailbox for me to mail the laptop for replacing the display. It will take about six business days.

In total, I am very satisfied with their service, although it cost me a week more. I do hope they can mail the laptop back to me earlier, as I need to go to a conference next week.

 

What's DOS?
heff
Posts: 2
Registered: ‎10-20-2011
Location: san francisco
0

Re: T420s bad pixel problem

Let me warn you - I had my new T420 for about a week and noticed a thin line down the screen. They wanted it back with that promised 6 day policy.  After a few days there they said the LCD screen needed replacing - the part was on backorder - and now I have been waiting over a month - and no end in sight - they didn't even e-mail or contact me.

I just want my money back - or a new one...Not happy with Lenovo.

Blue Screen Again
huixingcmp
Posts: 5
Registered: ‎10-19-2011
Location: Buffalo, NY
0

Re: T420s bad pixel problem

Heff, did you contact Lenovo again and what is their response? It is definitely NOT acceptable if the replacement is delayed for one month!