Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
bbaros
Posts: 1
Registered: ‎03-05-2010
Location: Philadelphia
0

T510 Ethernet Network failing

Hi everyone.

 

Just wanted to drop you a note on an Ethernet issue that I encountered and how I resolved it.

 

Just got the T510 (win 7, 64-bit) and I was moving my files from my old laptop to my new machine.  While transferring files through iTunes (shared library, drag&drop), the transfer would process 5-10 files and I would lose all my network connectivity.  The only way to restore it was to use troubleshooting functionality in Windows and that would reset the adapter.

 

My network is 1G, and I tried the following first (on the Device Manager, select the Intel 82577LM, right-click, Properties, Advanced):

1. Disable auto-negotiation => No result

2. Set the network speed to 100mb => worked, but sloooow.

 

Finally, I changed bunch of settings and finally, it's working and it's fast.  It still crashes, but after ~1000 files into it.

 

Settings changed are:

1. Receive Buffers (doubled from 80 to 160)

2. Receive Side Scaling (Enabled)

3. Receive Side Scaling Queues (increased to 2 queues)

4. Transmit Buffers (increased from 80 to 120)

 

Not sure which one worked, but it's working great now!

Token Ring
Mutnat
Posts: 136
Registered: ‎02-09-2010
Location: Vancouver, BC, Canada
0

Re: T510 Ethernet Network failing

Thanks for the tip! So far I've just been on my WiFi, but at some point I will wire up to ethernet for some bigger file transfers.  It's good to know what to try if they prove unstable also.

_________________________________________________________________
ThinkPad T510 : i5-540M : 8GB PC-10600 : 500GB 7200rpm : 15.6" HD+ : Intel 6300 : Win7 Pro 64 : 9Cell
Ordered 2/Feb/2010 : Shipped 22/Feb/2010 : Received 3/Mar/2010
What's DOS?
sirfrogman
Posts: 1
Registered: ‎03-05-2010
Location: USA
0

try

Thanks for posting this. I'm having the same issue and will your solution.

Serial Port
macmovieman
Posts: 64
Registered: ‎12-01-2009
Location: Irvine
0

Re: T510 Ethernet Network failing

Thanks for sharing and I made the changes. I needed to do the same thing later this week so it sounds like you might have saved me lots of time.

Thinkpad T510-4313 CTO | Core i7 620M 2.66 GHz | 4 GB RAM | NVIDIA 3100m 512 MB | 15.6 inch LED HD Plus | Windows 7 Ultimate 64 | 1- TB (2-500 GB 7200rpm) Hard Drive |
What's DOS?
hanssonfredrik
Posts: 1
Registered: ‎04-22-2010
Location: Sweden
0

Re: T510 Ethernet Network failing

Thanks! This helped me alot! I have had no crashes since these changes.

Blue Screen Again
bromberg
Posts: 3
Registered: ‎08-02-2010
Location: Germany, Bremen
0

Re: T510 Ethernet Network failing

Helps us a little. (not every 5 minutes but once a day...)

 

T410 and two x201 with the same problem. (LAN and WLAN)

 

The Lenovo Tools reports no errors...

 

We have got an other T410 with no problem...

 

Hardware defect? Driver Problem?

 

Blue Screen Again
bromberg
Posts: 3
Registered: ‎08-02-2010
Location: Germany, Bremen
0

Re: T510 Ethernet Network failing

May be an VPN SW Problem...
Paper Tape
Hcohen003
Posts: 1
Registered: ‎01-03-2010
Location: howard.is@rogers.com
0

Re: T510 Ethernet Network slow

I have a T510, running Windows 7. I run Lenovo tools regularly and perform most of the suggested updates.

Glad to see the msg and made the 4 suggested changes to my Intel gigabit adapter.

 

However, I still have a non-trivially slower speed with my Ethernet connection than my wireless - seems illogical -- 

I am using www.speedtest.net to compare speeds and my ISP in Canada is ROGERS cable-->  My Ethernet speeds on about 6 tests ranged between .5MB and 1 MB  (download speed) and with wireless the speed (80211.n - new linksys router) it was between 12 and 15 MBS.   A factor of 10.

I have a  home LAN with other desktops with Ethernet and they get close to 12 MB/sec using the same test.

I am betting it is likely the Intel adapter properties. But do not know enough to identify what to change.

Can anyone point me towards finding a solution?

What's DOS?
mark410
Posts: 1
Registered: ‎06-19-2011
Location: france
0

Re: T510 Ethernet Network slow

Can you try pinging your router or some other PC on the network

 

e.g. ping -t 192.168.1.1

and see if you get any timeouts. Try 100mb/s half-duplex first, 100mb/s full-duplex and 1Gb and compare results. You should never get any timeouts on a local ethernet device. If you do then something is very wrong! Report back here pls.