Support in other languages: 
Reply
Fanfold Paper
dtw9872
Posts: 10
Registered: ‎06-15-2011
Location: Kentucky
0
Accepted Solution

T520/T420 UEFI BIOS Management - Changing Boot order

WIth the T410/T510 I could use the SetConfig.vbs to change the boot order in BIOS.  However with the newer laptops (T420, T520, X220) that have the UEFI BIOS the SetConfig.vbs doesn't seem to work.  Is there another way of scripting the boot order change?  I also tried running the ListAll.vbs and didn't see anything related to the boot order listed in WMI. Any suggestions would be greatly appreciated.

Lenovo Staff
someotherguy
Posts: 2,407
Registered: ‎10-29-2009
Location: NC
0

Re: T520/T420 UEFI BIOS Management - Changing Boot order

First, please make sure you are using the latest BIOS version for your system.  I know that a bug about changing BootOrder has been fixed in a recent update.

 

Also, while the scripts themselves have not changed, the list of available settings and values has (in some cases), so please refer to hrdeploy_en.pdf at the following website http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-68488

 

If you still have problems, please post back with your MTM, BIOS version, and exactly how you are calling setConfig.vbs and I'm sure we can get to the bottom of it.

 

What's DOS?
BCoats
Posts: 4
Registered: ‎06-23-2011
Location: Dallas, TX
0

Re: T520/T420 UEFI BIOS Management - Changing Boot order

I am having a problem with a boot loop after I changed the boot order on my T520. I want the computer to boot first from the lan card, then the CD and finally from the HDD.  I created a batch file so I would have to worry about spelling.  The batch file is in the same folder as the scripts and I run the batch fill at a elevated command prompt from the folder that holds the scripts.  It shows to complete correctly and when I list the bios settings it shows the order I wanted.  When I reboot it goes into a boot loop.  It tries to boot from the Lan, then when it times out, it should boot from the hard drive, but instead it restarts and tries to boot from the Lan card again.

 

Here is what the batch file reads: cscript.exe setconfig.vbs BootOrder USBCD:USBFDD:smileytongue:CILAN:ATAPICD0:USBHDD:HDD0:HDD1:HDD2:

 

The BIOS version is 8AET42WW (1.22) dated 2011-04-19

The MTM is 4240-4AU

 

I was able to reset to the defaults to get the computer to boot correctly.

Lenovo Staff
someotherguy
Posts: 2,407
Registered: ‎10-29-2009
Location: NC

Re: T520/T420 UEFI BIOS Management - Changing Boot order

Please update to BIOS version 1.27 (8AET47WW) which is available on support website:

http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/8auj08us.exe

 

Many issues related to BIOS settings scripts have been fixed since the version 1.22 (8AET42WW) that you are using.  I will be happy to help you if you are still having issues after updating to 1.27

What's DOS?
BCoats
Posts: 4
Registered: ‎06-23-2011
Location: Dallas, TX
0

Re: T520/T420 UEFI BIOS Management - Changing Boot order

I am still having the same issue.  If I use anything but the defaults, the computer goes into a continuous reboot loop.  I even tried this on a fresh from the box T520 after upgrading the BIOS to 1.27.  The same thing happened.

 

As a side question, why was the ability to change the boot order from within the BIOS screnn, like on our previous T510's, removed.

Lenovo Staff
someotherguy
Posts: 2,407
Registered: ‎10-29-2009
Location: NC

Re: T520/T420 UEFI BIOS Management - Changing Boot order

I tried your exact script on T520 with BIOS 1.27

 

1.  in the case where LAN cable is connected to network with PXE server  <-- system booted to LAN successfully

2.  in the case where LAN cable is not connected  <--  system booted to HDD after LAN boot failed to detect media

3.  in the case where LAN cable is connected to network without PXE server  <-- system booted to HDD after LAN boot timed out

 

So I could not repro any problem.  What am I missing?  Are you on a dock?  Are there any other peripherals connected?

 

As for your other question, I'm sorry that I'm not following it.  You can change the boot order in the Startup menu, the very first option is "Boot" where you can set any boot order you want just like previous systems.

What's DOS?
BCoats
Posts: 4
Registered: ‎06-23-2011
Location: Dallas, TX
0

Re: T520/T420 UEFI BIOS Management - Changing Boot order

OPPS, I missed where you could change the boot order in the BIOS screen.  Found it and changed it there.  Thanks.

 

I am using the FOG program as our server for capturing and deploying images.  When you boot normally, it contacts the FOG server to see if there is anything to be done.  If nothing needs to be deployed/captured it takes you to a screen where you can chose to boot from the hard drive or send information to the FOG server.

 

If I boot with the LAN card first and no cable attahced t defaults to the HDD as it should.  If I boot with the cable attached, it goes into the reboot loop after it leaves the screen FOG brings up.  Therefore, I believe that FOG is causing the looping problem.  I will go onto the FOG forums to see if they have seen this problem before.

 

Thanks for your help.

Community Moderator
zoltanthegypsy
Posts: 3,292
Registered: ‎01-13-2008
Location: Bainbridge Island, WA, USA
0

Re: T520/T420 UEFI BIOS Management - Changing Boot order