Support in other languages: 
Reply
Paper Tape
mirceapaun
Posts: 5
Registered: ‎07-03-2012
Location: Romania
0

T530 ultrabay adapter does't work

Hello, Who can explain me why not work an Ultrabay SATA hard drive adapter in a T530. Isn't from Lenovo but it works perfectly in any notebook and only the T530 does't work. It's like the device does not exist for T530. Is there any special configuration of the adapter ? A "device present" pinout conf ? Thanks
Guru
ColonelONeill
Posts: 6,548
Registered: ‎12-26-2009
Location: Toronto
0

Re: T530 ultrabay adapter does't work

So it works in another machine?

Try updating your SATA drivers using System Update.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
802.11n
CorkyG
Posts: 410
Registered: ‎08-13-2010
Location: Tucson, Arizona
0

Re: T530 ultrabay adapter does't work

The T530 should use the same UB Adapter (III) as the others in the T500 series.  It is distinguished by a  plastic stub protruding from the rear of the adapter.  This stub is what engages the push mechanism that ejects the adapter.

 

There was a recent new version of the adapter for the T500 series which is slightly thicker at the opening, and eliminates the air gap.

 

The Lenovo Ultrabay Adapter is unique to Lenovo, and is mated to the twp finger slide and push mechanism.  I can't imagine it working in other brand laptops.

Paper Tape
mirceapaun
Posts: 5
Registered: ‎07-03-2012
Location: Romania
0

Re: T530 ultrabay adapter does't work

Thanks,

I updated. I will try in a few hours to see if it has any effect.

Paper Tape
mirceapaun
Posts: 5
Registered: ‎07-03-2012
Location: Romania
0

Re: T530 ultrabay adapter does't work

"plastic stub protruding from the rear of the adapter. This stub is what engages the push mechanism that ejects the adapter" this is a simple plastic pieces that can be moved to any other adapter. I put both plastic pieces on the new adapter, but obviously, that's not the problem .
HDMI
-30-
Posts: 142
Registered: ‎12-07-2010
Location: TORONTO
0

Re: T530 ultrabay adapter does't work

"Isn't from Lenovo but it works perfectly in any notebook . . ."

QUOTE.

 

This is another reason that I buy my hardware only from Lenovo. (OEM)

 

-30-

I love my LENOVO.
T 410s, WIN 7, 128 SSD, 64 Ult.


I do not work for LENOVO.
Paper Tape
mirceapaun
Posts: 5
Registered: ‎07-03-2012
Location: Romania
0

Re: T530 ultrabay adapter does't work

Please, don't explain what it means to use a part of the same brand. I have nothing against use original part from lenovo but it take few weks until arrive...and maybe it is useful to know what other option should look at a drivebay that can work with lenovo equipment ...in my case T530. 

to conclude : didn't work after update !

somebody can explain what's the trick ?

802.11n
CorkyG
Posts: 410
Registered: ‎08-13-2010
Location: Tucson, Arizona
0

Re: T530 ultrabay adapter does't work

Just took a closer look at the Ultrabay II and III adapters.  In addition to the plastic stub (for ejection), the SATA connectors are different.  The UB II has pins.  The UBIII has the two separate subconnectors (power and data) with plastic divider rails.  They are not interchangeable.

 

BTW - have you tried it with a different HDD?

 

 

Paper Tape
mirceapaun
Posts: 5
Registered: ‎07-03-2012
Location: Romania
0

Re: T530 ultrabay adapter does't work

I don't see how it looks  "UB II"and "UB III"  but I hope you do not think that I confused a sata adapter with pata adapter. Obviously it is a SATA adapter with the same connector for all notebooks with sata option for dvd drive. I change hard drive and computer. I can confirm that other notebooks with Core2 and I7Q from sony work with him.  

Paper Tape
guillaume_u
Posts: 1
Registered: ‎07-25-2012
Location: France
0

Re: T530 ultrabay adapter does't work

Hello,

I have the same problem.

 

Did you solve it ?

 

Regards,

 

Guillaume.