Support in other languages: 
Reply
Paper Tape
antares
Posts: 4
Registered: ‎03-03-2011
Location: Switzerland
0
Accepted Solution

[Thinkpad T410s] - Problem with brightness control

Hi !

 

First of all, sorry if I make some mistakes, I'm a french speaker :smileyvery-happy:

 

I own a Lenovo for some month now, and I'm completly satisfied with this computer. In Januar, the mainboard burned for a reason that I can't explain. New problems appeared directly after the reparation. Two days ago, I decided tocompletly reinstall Windows 7, after deleting all the memory of the SSD. All functions very well, apart one small thing : the brightness control (fn+Home/End) does not work well. Actually, it does like this :

 

Increment : 0-4-7-9-10-11-12-13-14-15

Decrement : 15-14-13-12-11-10-9-8-6-3-0

 

It is not a real problem in itself, but it is quite annoying when you want to adjust the brightness confortably...

 

Thanks !

 

 

Maliha
Posts: 3,224
Registered: ‎07-31-2008
Location: Pakistan
0

Re: [Thinkpad T410s] - Problem with brightness control

[ Edited ]

Hi and welcome to the forum!


Did it use to work without irregular increments before? If so, then verify whether all drivers are installed from lenovo, for instance video, Power Manager/Management, Hotkey Features etc, and not through Windows Update:- http://www-307.ibm.com/pc/support/site.wss/migr-74582.html


Run TVSU alternatively:-http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-73695


I have seen it mentioned by another user in L series and Value line board, my guess is that lenovo has changed something for new systems because my T400's on-screen display works fine and doesn't have this behavior.


Hope this helps.

------------------------------------------------------------

Maliha (I don't work for lenovo)
ThinkPads:- T400[Win 7], T60[Win 7], IBM 240[Win XP]

IdeaPad: U350

Apple:- Macbook Air [Snow Leopard]
Did someone help you today? Compliment them with a
Kudos!
Was your question answered today? Mark it as an Accepted Solution
de.gif  Lenovo Deutsche Community   es.gif  Lenovo Comunidad en Español 
Visit my YouTube Channel

Paper Tape
antares
Posts: 4
Registered: ‎03-03-2011
Location: Switzerland
0

Re: [Thinkpad T410s] - Problem with brightness control

Hi !

 

Actually my computer worked better in all domains before the mainboard burned and its replacement. I saw that Lenovo made an update of all this things in Januar. That may explain this.

 

I can't say it is the technician that made a bad work. I think it is a problem of installation and/or drivers.

 

I did all what you said, but it changed nothing...

 

I wonder if the problem comes form Lenovo, because a friend's standart T410 doesn't have this problem. And he bought it last year too.

Maliha
Posts: 3,224
Registered: ‎07-31-2008
Location: Pakistan
0

Re: [Thinkpad T410s] - Problem with brightness control

[ Edited ]

The OSD on my T400 also works without irregular increments/decrements, as I said I've seen 2 people mention this recently, one in L series forum and other in Value line series forum (I can't find the thread...).

 

If you've all current drivers from lenovo, then I would guess that lenovo has changed something recently in the OSD that affects only some series.

------------------------------------------------------------

Maliha (I don't work for lenovo)
ThinkPads:- T400[Win 7], T60[Win 7], IBM 240[Win XP]

IdeaPad: U350

Apple:- Macbook Air [Snow Leopard]
Did someone help you today? Compliment them with a
Kudos!
Was your question answered today? Mark it as an Accepted Solution
de.gif  Lenovo Deutsche Community   es.gif  Lenovo Comunidad en Español 
Visit my YouTube Channel

Guru
ColonelONeill
Posts: 6,529
Registered: ‎12-26-2009
Location: Toronto
0

Re: [Thinkpad T410s] - Problem with brightness control

The brightness hotkeys on my T400 also work perfectly. As well as on the X100e (in both Windows 7 and Windows 2000). Might just be a weird interaction with newer drivers?

I'd think Lenovo's driver team is probably under a heavy workload dealing with the whole NVidia audio issue, the ATI/Intel switchable SP1 bugs, and the drivers for the whole new generation.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Blue Screen Again
masterllama
Posts: 62
Registered: ‎07-14-2010
Location: Los Angeles

Re: [Thinkpad T410s] - Problem with brightness control

I am seriously dishearted by Lenovo's response to this problem.

 

This is an easy problem to fix; the staff here as well as the technician you called should have easily been able to solve this problem...

 

Anyhow, I had also had this problem when I did a fresh install of Windows 7 (in an attempt to fix that **bleep** DPC latency problem...) and the solution is quite easy.

 

Run this .reg file and it will fix the registry for you.  Reboot your computer and everything should be working properly.

 

http://www.mediafire.com/?vwy4xgg30d3hawa

 

I posted it on mediafire because I don't think I can upload files here.

Guru
Mornsgrans
Posts: 2,438
Registered: ‎03-19-2009
Location: Idar-Oberstein, Germany

Re: [Thinkpad T410s] - Problem with brightness control

Please verify, that the Lenovo - graphics driver is installed and active. The OSD-brightness - issue appears in most cases caused by the driver from Windows update.

 

- remove driver - but do NOT reboot

- install Lenovo driver

- reboot

- be happy

--------------------------------
My home-forum: http://www.thinkpad-forum.de
Wiki: Deutsches ThinkPad-Wiki English ThinkWiki
My ThinkPad-Collection
Paper Tape
antares
Posts: 4
Registered: ‎03-03-2011
Location: Switzerland
0

Re: [Thinkpad T410s] - Problem with brightness control

Hi !

 

I'm coming a *bit* late but nevermind, I just solved my problem :smileyvery-happy:

 

The .reg files worked perfectly, the incrementation came back to normal, thanks a lot !

 

 

Paper Tape
Simonjs
Posts: 5
Registered: ‎11-20-2012
Location: Brazil
0

Re: [Thinkpad T410s] - Problem with brightness control

.reg files worked for me too!!

 

Thanks so much, a minor but considerebly annoying problem solved!