Support in other languages: 
Reply
Paper Tape
garyshilin
Posts: 1
Registered: ‎01-27-2012
Location: United States
0

urgent! T420 with N6205 keeps dropping wireless connection and cannot recover

[ Edited ]

Hello everyone, 

 

I bought my T420 model with N6205 network card last December, since then, the wireless connection never functions well. Here's the problem(it happens in my apartment):

 

Every once in a while (normally within four to five days), my wireless connection drops automatically. It would first appear as  no connection and it'll try to reconnect, then it appears as successful connected for 5 to 10 seconds(but definitely no internet access), and it'll drop the connection completely again, then automatically repeat :reconnect, drop,reconnect, drop ... never stops. Though I can still use cable to connect to my router to have internet access.

 

This problem occurs to none of my smartphones, ipad, ipod touch, my old laptop and my roomates' wireless devices under the same wirless environment. They always have solid wireless connection.

 

Of course, regular approaches have been taken trying to solve the problem:

1. manually disable wireless functionality on my T420, and enable it again

failed

2. reboot computer

failed

3.  go to power manager and turn PCI express off

failed

4. uncheck allow the wireless LAN radio to be turned off when inactive

failed

5.updated to the latest driver through lenovo

failed

6. restart router

successful 

 

So it may be that I've got a bad router? This is why I didn't post my problem in the first place, since I was hoping it may disappear with other routers. 

 

I changed to a new router, the problem persists.

 

There's no way I can restart the router every time when my laptop looses connection, it'll affect the other users.

Based on the description of my problem, I believe there's a great chance there's something wrong with my T420 rather than with my router.

 

Is there anybody who can help me with this?

Can lenovo staff see this post?

Any suggestion about who I should turn to?

 

Thanks a lot.

 

T420,

i7 2640M, N6205

Windows 7 professional, 64 bit

Guru
ColonelONeill
Posts: 6,641
Registered: ‎12-26-2009
Location: Toronto
0

Re: urgent! T420 with N6205 keeps dropping wireless connection and cannot recover

Try updating the driver to version 15.0.0.75 from here:
http://www.station-drivers.com/page/intel%20lan-wan.htm
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Token Ring
Kicker774
Posts: 261
Registered: ‎01-24-2011
Location: Columbus, OH
0

Re: urgent! T420 with N6205 keeps dropping wireless connection and cannot recover

Is this under access connections? Try letting Windows control your wireless and see if it makes a difference.
Guru
Mornsgrans
Posts: 2,450
Registered: ‎03-19-2009
Location: Idar-Oberstein, Germany
0

Re: urgent! T420 with N6205 keeps dropping wireless connection and cannot recover

Did you try your wireless connection in annother wireless netzwork sucessfully (office, neighbour/friend, hotspot...)

If your wireless works well in other networks the reason is either your wireless configuration or in the router. In some cases a firmware update in the router helps.

--------------------------------
My home-forum: http://www.thinkpad-forum.de
Wiki: Deutsches ThinkPad-Wiki English ThinkWiki
My ThinkPad-Collection
What's DOS?
zeitgeist
Posts: 1
Registered: ‎03-25-2012
Location: Hungary
0

Re: urgent! T420 with N6205 keeps dropping wireless connection and cannot recover

Same problem here with same config. Did you find the solution?

Bit Torrent
tripplec
Posts: 1,472
Registered: ‎03-08-2012
Location: Toronto, Ontario Canada
0

Re: urgent! T420 with N6205 keeps dropping wireless connection and cannot recover

What security mode are you using.

WPA or WPA2? You could change the router to WPA only and see if that helps. I have see some portable devices that don't negotiate the protcol properly but never a notebook. If you have Bluetooth turn it off. It seems to affect my 1x1.

 

I have the 1x1 card and it pretty bad connecting at 24 to 48 Mbps only with a good signal. I don't know why Realtek is used in a Business class notebook. Maybe some others can add what they have and is working 100%.

T520 Model 4239 Intel(R) Core(TM) i7-2860QM CPU @ 2.50GHz
Intel Sandy Bridge & Nvidia NVS 4200M graphics Intel N 6300 Wi-Fi adapter
Windows 7 Home Prem - 64bit w/8GB DDR3
Paper Tape
holysoul
Posts: 3
Registered: ‎07-16-2012
Location: Bromont, Canada
0

Re: urgent! T420 with N6205 keeps dropping wireless connection and cannot recover

I work for tech support and I have 2-3 T420 behaving pretty much the same way. Difference is that we are running under Windows XP SP3.

Did you ever found a solution to the problem?
We're not using Access Connection and I have tried the Intel Pro Wireless app for that Wirelees card model without success. The drivers have been updated to version 15.1.1.1 without a change to the problem...
Serial Port
michael56555
Posts: 19
Registered: ‎04-16-2008
Location: Cashiers, NC, USA
0

Re: urgent! T420 with N6205 keeps dropping wireless connection and cannot recover

I have the same problem with my T520, but only on my home network. I have never had the problem at work. It won't connect unless I restart the modem. Then sometimes it will just drop the carrier. Latest firmware, latest driver. Same settings that I had when I had my R61 that never had the problem. Sorry no solution here, just jumping on the bandwagon with the problem.....
Serial Port
michael56555
Posts: 19
Registered: ‎04-16-2008
Location: Cashiers, NC, USA
0

Re: urgent! T420 with N6205 keeps dropping wireless connection and cannot recover

P.S. Using windows to manage network, WEP security. Have unintalled/reinstalled drivers, disabled/enabled device, rebooted computer, all the things listed above. Surface logic would imply there is something in the modem/router setup, but I don't know what that is.
Paper Tape
JPXusked
Posts: 4
Registered: ‎07-31-2012
Location: United States
0

Re: urgent! T420 with N6205 keeps dropping wireless connection and cannot recover

Has anyone found the solution yet?  Lenovo please speak up.  I will add a bit more information:

1. T420 was originally running Win7-32.  It worked fine

2. Router hasn't changed and is running wireless g-n mode with WPA2

3. T420 was upgraded to Win7-64 with all the latest drivers (including Intel Pro1000).

4. Problem started happening.  

5. Able to connect to non-encrypted networks with no problems.

6. No other devices have ANY issues connecting (iPads, iPhones, Laptops, etc...)

 

Please help