Support in other languages: 
Reply
Punch Card
ChrisK15
Posts: 14
Registered: ‎01-05-2009
Location: Maryland
0

Depot service a letdown *update*

[ Edited ]

I have a T61 with NVIDIA graphics, and about two weeks ago it turned off while I was sleeping. When I got up to turn it back on, nothing happened. I eventually took the battery out and put it back in without the AC adapter plugged in, which I guess reset something on the motherboard allowing it to turn on. Once booted up, I noticed that Aero wasn't working, and the wireless card and SD card reader were dead as well. After that, the laptop would turn off seemingly randomly. I (or anybody else) have never spilled anything on the laptop before and this was definitely not caused by an impact. I had also had an unrelated problem with a line sometimes appearing through the center of the LCD.

 

I called Lenovo a couple days later to schedule a repair, and they received my laptop about a week ago. A few days afterward I called them to check my status and they said they had replaced the LCD and that they were still working on the rest of it. I called again earlier today and they said that the laptop could not be repaired under warranty because there was evidence of "spillage" on the right side of the motherboard, since apparently there was corrosion. My only options were to pay $950 (as quoted by the Lenovo rep) for the repairs, buy the extended warranty, or get it sent back.

 

As I said, I have never spilled anything on it, and it hasn't come into contact with moisture. The rep said he understood it might not have been caused by a spill, but maybe that it was "in the rain". This is ridiculous, and I know for a fact that it's never gotten wet. I take pretty good care of this laptop and I feel like I'm being ripped off. I paid the extra cost for a 2-year warranty, and something out of my control like this should be covered. I just told them to send it back since I don't have the money for the repairs, and who knows how much longer it's going to last in this state. I figured they might not be able to replace the LCD or something, but the motherboard? That's the most critical part and if that ends up dying completely then I have no computer. If any Lenovo rep/employee could help me out on this I'd really appreciate it.

 

Thanks

 

Christian Kilinski

Mark_Lenovo
Posts: 7,840
Topics: 410
Kudos: 1,309
Solutions: 283
Registered: ‎11-19-2007
Location: RTP, North Carolina
0

Re: Depot service a letdown

Chris,

 

Sorry to hear that you are having this trouble.  The depot technicians should take pictures of the board, so as a first step, I would ask them to provide you a copy of the pics via email.

 

If, after taking a look at the pics, you don't agree with the technician, you can dispute the billable charge and ask that it be escalated.  A Lenovo representative works with the depot and reviews billable disputes / escalations and provides an independent assesment and will take appropriate action.

 

Can you send me a private message with your depot case number?   I'll see if we can look into this proactively.

 

Thanks for letting us know.

 

Best regards,

 

Mark

____________________________________________

ThinkPads: S30, T43, X60t, X1, W700ds, IdeaPad Y710, IdeaCentre: A300, IdeaPad K1
Mark Hopkins
Program Manager, Lenovo Social Media (Services)
www.twitter.com/lenovoforums
www.facebook.com/lenovo

English English Community      Deutsche Deutsche Community      Español Comunidad en Español

Punch Card
ChrisK15
Posts: 14
Registered: ‎01-05-2009
Location: Maryland
0

Re: Depot service a letdown

Thanks, I sent you a PM a little while ago. They said they would ship it out within one business day, but if there's a way that someone could hold it there for longer so I could try to escalate the issue that would be a big help as well.

Punch Card
ChrisK15
Posts: 14
Registered: ‎01-05-2009
Location: Maryland
0

Re: Depot service a letdown

[ Edited ]

I just received my laptop back a few minutes ago, and when I turned it on it just made a few short blip sounds, then shut off. When I sent it in for service it still worked and booted into Windows fine, it's just that a few things didn't work properly. Now it doesn't work at all, nothing shows up on the screen, and it shuts off after a couple seconds. I don't know what they did, but now it's obviously in way worse condition that it was when I sent it in for repair.

 

I want to talk to someone who can actually help me with this. I need this laptop for work; I'm borrowing a friend's right now so I can post. This is way too long for me to wait, especially with a dead laptop.

 

Edit: I just got off the phone with tech support and they're sending me another box to ship it out tomorrow. So far I'm pretty disappointed, but if they actually fix everything this time I'll be satisfied.

 

Edit 2: I was able to get it to boot up by reseating the RAM. However the other problems still exist and am sending it in again.

Punch Card
ChrisK15
Posts: 14
Registered: ‎01-05-2009
Location: Maryland
0

Repair service is absolutely ridiculous

[ Edited ]

I made a topic a couple weeks ago about the depot repair service and them trying to tell me I'd spilled something on it, so they couldn't repair it under warranty. I talked to another representative and told him that it's never gotten wet ever, and that the tech sent my laptop back BROKEN; it was at least booting up and basically functional before I sent it in.

 

About a week ago I sent it back in for proper repair this time, hoping they would actually fix it. I checked my status yesterday evening and it said "hold for customer information" so I called this morning. They said they hadn't actually gotten any specific information and that it was on a billable hold, and they would get back to me "maybe" Monday or Tuesday.

 

In the last thread I made, Mark Hopkins responded saying that he would look into my issue. I figured he might be able to help me out, and I know he's helped a lot of other people with similar issues, but I haven't heard anything since. This is going on three weeks without a functional laptop, and I've not done anything to void the warranty. I need this laptop for college and work, and I can't go much longer without a computer of my own. Telling me there's a problem then waiting another few days to tell me what it is is extremely unprofessional and very frustrating.

 

I paid for the two-year warranty and like I said, the Thinkpad's never gotten any moisture on or in it ever. To keep sending it back more broken than previously, then saying it's my fault is atrocious behavior for a company like this. Even though they might have a second party doing the repairs, it's no excuse for this. If any administrator or manager reads this, I would really appreciate some help on this issue.

 

Christian Kilinski

Case #: 23PF34S

Punch Card
ChrisK15
Posts: 14
Registered: ‎01-05-2009
Location: Maryland
0

Re: Repair service is absolutely ridiculous

[ Edited ]

I just finished speaking to a representative Pat who sent me pictures of my laptop from the depot. They did not have any pictures of any spillage or corrosion on the motherboard, and the only parts that looked to have any spots of anything on them were the cage above the DVD drive, a small area around the heatsink (on the cage) and the bottom of the keyboard.

 

I had ordered a replacement keyboard and there was an area along the border, on the inside of the bottom plastic, that appeared "sticky" due to the adhesive, not water. This was probably about a year ago and hasn't changed since and always worked fine.

 

The area above the DVD drive and below the heatsink on the metal cage was probably due to using gas duster, and a little bit of the spray might've gotten on it. However the tech did not provide any evidence of damage on the motherboard itself, and I had previously inspected it before sending it in and it was completely clean, and there were no areas on the board or contacts that looked corroded in any way.

 

As I've said many times in a previous thread and on the phone, this laptop has NEVER come into contact with any liquid or moisture. These problems, aside from the LCD screen issue, all happened literally overnight. It was working perfectly until I went to bed, and when I got up and turned it on, every problem (wireless card, card reader, graphics card) was immediately apparent. They all appeared at the same time and I had not touched it previous to this. I talked to another representative a little while ago and she said it would take maybe TWO OR THREE weeks to escalate the issue. This is absurd, and there's no way I'm waiting another two weeks (after the depot already having my laptop for around three weeks in total) just so they can try to give me the run-around again. In no way do I see this as my fault, especially since the problems happened all at once without any interaction. The pictures they sent me show no evidence of circuit corrosion or damage, only a few spots of discoloration on the top of the internal cage.

 

I've waited far too long and paid too much to keep getting ignored by everyone and not giving me information. I want to speak to someone higher-up than a service rep, because they aren't very helpful. I understand that it isn't in their power to do much, but I would at least like to talk to a manager or high-level tech support.

 

My case number is 23PF34S. I would appreciate a response. If you would like to see the photos, I can forward the email.

 

Thank you

 

Moderator edit: Masked full name, per the Community Rules.

Punch Card
ChrisK15
Posts: 14
Registered: ‎01-05-2009
Location: Maryland
0

Re: Repair service is absolutely ridiculous

Okay, seriously? I just found the thread on the faulty solder connections on T61 Quadro chips. The problems people experienced with that are exactly what I was dealing with. Obviously this has nothing to do with corrosion or spillage, but a manufacturing defect. The fact that nobody has thought of this or mentioned this is appalling, like they're trying to keep the problem hidden unless someone figures it out on their own. Now I'm upset, and this is getting extremely frustrating. This is clearly not my fault, and now I have every reason to escalate this as far as I can.
Agotthelf
Posts: 3,777
Topics: 137
Kudos: 241
Solutions: 182
Registered: ‎01-05-2008
Location: Münster, Germany GMT +1
0

Re: Repair service is absolutely ridiculous