Support in other languages: 
Reply
Blue Screen Again
ciruliz
Posts: 4
Registered: ‎06-12-2010
Location: Riga, Latvia
0

External VGA stopped working

Hi,

 

Approximately week or more ago my external VGA port stopped working - Catalyst control center detects new monitor attached, but there is no output signal (at least monitor says so). Monitor itself & cable is tested and works fine.

It seems that either it is hardware defect or recent windows update caused it. I am not sure how to test it. (Radeon drivers are dated back in 2009)

 

Config: 

Thinkpad T60 (2007-66G)

WinXP Pro 32bit

ATI Radeon Mobility X1400

lead_org
Posts: 20,376
Topics: 128
Kudos: 1,203
Solutions: 1,278
Registered: ‎12-19-2008
Location: Australia, Melbourne
0

Re: External VGA stopped working

try to reupdate the bios

Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
Blue Screen Again
ciruliz
Posts: 4
Registered: ‎06-12-2010
Location: Riga, Latvia
0

Re: External VGA stopped working

ok, I actually updated BIOS (latest version 2010-Apr) but still no luck.

lead_org
Posts: 20,376
Topics: 128
Kudos: 1,203
Solutions: 1,278
Registered: ‎12-19-2008
Location: Australia, Melbourne
0

Re: External VGA stopped working

how about a downgrade of the bios?

 

Also, try to switch to vga + internal in your bios under display. Boot the laptop with the internal LCD closed, does anything come up on the external LCD?

Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
Blue Screen Again
ciruliz
Posts: 4
Registered: ‎06-12-2010
Location: Riga, Latvia
0

Re: External VGA stopped working

hmm, i didn't try downgrading the bios, but I switched vga+lcd mode in bios settings and tried to boot on. nothing on external display :smileysad: it seems like a hardware fault ? 

lead_org
Posts: 20,376
Topics: 128
Kudos: 1,203
Solutions: 1,278
Registered: ‎12-19-2008
Location: Australia, Melbourne
0

Re: External VGA stopped working

that is a possibility. 

Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
What's DOS?
PLa80
Posts: 1
Registered: ‎08-20-2013
Location: Finland
0

Re: External VGA stopped working

[ Edited ]

To raise the old topic...

 

I have exactly the same problem with my 8744-HCG model (T60 widescreen with ATI Radeon x1400). It seems to be a hardware fault (is not operating system or BIOS version dependent). I was however able to go around it by buying an "Advanced mini dock" docking station and using the DVI port. From DVI, the external display works fine. Therefore, my guess is that the video card has lost its capability to power up the analog VGA signal for the external port due to faulty in the circuits.