Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
RalphWC
Posts: 3
Registered: ‎04-19-2012
Location: Sarasota
0

T-43s giving same "hal.dll missing" error within minutes of each other

Hello!

 

I have two T-43 2668 laptops, and this past week my regularly used one stopped working, and rendered this message when attempting to boot:

"Kernal Stack InPage Error"

"Windows could not start because <Windows Root>\System 32\hal.dll is missing or corrupt"

---

I then took out my backup, booted it, and went online to see how to repair this issue. Within minutes, the second laptop threw up a blue screen, then when I rebooted machine 2 had the same error message as for the first machine.

 

Now for another quirky aspect- when trying a few times to reboot machine number 2, I ended up putting it on its edge and looked at machine 1 for a while. When I reopened #2, it had booted normally to Windows, and was usable for several hours. Then when I closed the lid, it went back to the hal.dll error. I bumped it on its edge a couple of times, and it again booted fine, so I've left the machine on since, without shutting it down or closing the lid (clearly some sort of a physical issue).

 

Thinking it may be something other than the hard drive, I removed the HD from machine 1, put it into an external enclosure, but could not get the two computers I had access to over the weekend to do more than ultimately find that there was an external storage device attached, but could not get in. Also, when attached to the computers, it pretty much locked them up. The laptop's HD made a cyclical, low volume, "growly" noise.

 

A knowledgeable friend said he had good luck on a couple of occasions by freezing problematic HDs to get them to be readable, so I figure I have nothing to lose by trying this to recover the data off of it. (My last good backup is about 4 weeks old, so I really would like the data currently on it).

---

I can get to the BIOS, but when I put in the Recovery Disc I had no luck repairing the issue. I found several suggestions on the pcsupport.about.com forum, and tried many of them on machine 1 (Could not get into Safe Mode, could not repair the boot.ini file, could not repair the hal.dll file, could get into the Recovery Console, but I could not rebuild the bootconfg.

---

I love these machines and need to keep with XP for some time to come. I feel clueless as to how to proceed... replace the HDs? Is there a way to diagnose precisely what the issue is?

 

Thank you for any thoughts and advice!

 

Ralph

 

ajkula66
Posts: 7,628
Kudos: 757
Solutions: 800
Registered: ‎11-23-2007
Location: USA
0

Re: T-43s giving same "hal.dll missing" error within minutes of each other

Test the hard drives with PC Doctor for DOS bootable CD and report back.

 

Good luck..

 

 

Cheers,

George




In daily use: R60F, R500F, T61, T410

Collecting dust: T60

Enjoying retirement: A31p, T42p,

Non-ThinkPads: Panasonic CF-31 & CF-52, HP 8760W




Starting Thursday, 08/14/2014 I'll be away from the forums until further notice. Please do NOT send private messages since I won't be able to read them. Thank you.
.