Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Greps Everything
PoPSiCLe
Posts: 137
Registered: ‎12-08-2010
Location: Bergen, Norway
0

T-61 - spilled liquid problem

I was unfortunate enough to spill liquid over the palmrest (mousepad and fingerprint-reader, mostly) and perhaps a little spilled onto the keyboard as well.

 

I was quick to dry it off, but some may of course gotten into the computer. Unfortunately, I was at a conference, with no access to tools, so I had to wait until I got home to take it apart (approx 12 hours after).

 

I opened it up, disconnected the palmrest and keyboard, cleaned up everything (no real trace of moisture underneath, really, took out the RAM and cleaned both them and the connector - and lo and behold, the computer came to life, without any problems - even the pad and the fingerprintreader worked.

 

There were weird problems, though - for instance, it didn't go to sleep properly - the computer turned off, and the sleep-light lit up, but on waking, it rebooted and started all over again, with the "Windows didn't shut down properly"-message. No big deal, I thought, I can live with that.

 

But today, it won't start at all - no lights, no spinning fan, no nothing. Tried taking it apart again, even tried a second keyboard I've got lying around to see if something was wrong with the power-button, to no awail.The computer is completely dead, and I don't understand why - it worked just fine yesterday, before I closed the lid and put it into sleep.

 

So, I'm wondering (well, assuming) this has something to do with the liquid spill - but I can't for the life of me understand why it took several days before the problem manifested - not to say I've no idea WHERE the problem might be - I mean, most of the motherboard shouldn't have been affected, even if the liquid got into the machine through the palmrest - the only part directly exposed is the ram-enclosure, and as far as I can see, there are no traces of moisture, nor and burnt parts.

 

Tried measuring to see if the computer actually gets power, and it does - the charger works, and when measuring the power-connecter going into the mainboard, it shows correct values.

 

So... is the motherboard fried? Is there a chance it's just the power-button not working properly? (I'm a bit worried, as the charge-light doesn't come on either when the AC is plugged in).

 

And, if it's the last resort, and I have a dead motherboard, anyone have one for sale? T61 4:3 14,1" screen, willing to also buy a parts-machine as long as the motherboard is fine.

--------------------------------------------------------------------------------
IT-technician, running my own company in Bergen, Norway
Thinkpad T61, 8895CTO C2D 2Ghz/4GB/120GB SSD/1400x1050
lead_org
Posts: 20,905
Topics: 128
Kudos: 1,254
Solutions: 1,343
Registered: ‎12-19-2008
Location: Australia, Melbourne
0

Re: T-61 - spilled liquid problem

Sometimes liquid residues would cause corrosion slowly, and the problem may not manifest itself until several days later.

If you are not getting lights when you plug in the power adapter, then the sign is not good.

Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
Greps Everything
PoPSiCLe
Posts: 137
Registered: ‎12-08-2010
Location: Bergen, Norway
0

Re: T-61 - spilled liquid problem

I am aware that corrosion can occur slowly, but I have a hard time believing that a minor spill like this would manifest itself after two days - and not immediately. Corrosion usually takes a little while longer, and I also did make sure there were ample drying of any exposed part before trying to turn it on again.

 

The fact that it's also completely dead makes me think it might be a blown fuse somewhere - is there anywhere I can find a schematic for the mainboard, perhaps a service manual? If it's only a fuse, I can probably fix it, if not I'll have to buy a new mainboard, and that's fairly expensive (mostly it's the shipping costs that's killing the deal, since it costs about the same for the shipping as the mainboard itself).

--------------------------------------------------------------------------------
IT-technician, running my own company in Bergen, Norway
Thinkpad T61, 8895CTO C2D 2Ghz/4GB/120GB SSD/1400x1050
topmahof
Posts: 3,243
Topics: 37
Kudos: 374
Solutions: 241
Registered: ‎01-21-2010
Location: Etters, PA
0

Re: T-61 - spilled liquid problem

http://forum.thinkpads.com/viewtopic.php?f=29&t=97619

 

Here's a thread on a milk spill.

 

Check the fuses around F3 on the motherboard with a meter.  If you find a bad fuse, don't try to unsolder the fuse. Solder the new fuse on top of the old fuse.  

 

Dave

_______________________________________________________
T430u, x301, x200T, x61T, 2-x61s, x32, x41T, x40, U160, ThinkPad Tablet 1838-22R, Z500 touch, Yoga 10, Yoga Tab 2 Windows 8.1
Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
If someone helped you today, pay it forward. Help Someone Else!
English English Community   Deutsche Deutsche Community   Español Comunidad en Español   ru.gif Русскоязычное Сообщество