Support in other languages: 
Reply
Blue Screen Again
kyosti
Posts: 3
Registered: ‎11-28-2010
Location: Estonia
0

T41 slow wireless connection - speed only 5.5 Mbps

I've Win7 Pro installed in my T41. The problem is that the max wireless speed is only 5.5 Mbps, while it should be 11 Mbps (802.11b). The wireless card is the default Intel/pro wireless lan 2100 3B mini. I've the latest driver (version 1.2.5.37 from Microsoft update). Wired network works ok with full speed (11 Mbps). Also, all the other computers in my network work fine with full speed also in wireless. I've ADSL2+ connection with A-Link  RR24AP(i+) router.

I've Win7 Pro installed in my T41. The problem is that the max wireless speed is only 5.5 Mbps, while it should be 11 Mbps (802.11b). The wireless card is the default Intel/pro wireless lan 2100 3B mini. I've the latest driver (version 1.2.5.37 from Microsoft update). Wired network works ok with full speed (11 Mbps). Also, all the other computers in my network work fine with full speed also in wireless. I've ADSL2+ connection with A-Link  RR24AP(i+) router.

 

 

Any suggestions howto fix this?

goretsky
Posts: 1,944
Topics: 19
Kudos: 349
Solutions: 132
Registered: ‎12-01-2007
Location: California, USA
0

Re: T41 slow wireless connection - speed only 5.5 Mbps

[ Edited ]

Hello,

 

It looks like Intel stopped providing driver support for the 2100-series of wireless cards in 2006, but perhaps this device driver on Intel's support web site for Microsoft Windows Vista will work with the ThinkPad T41. 

 

Since I am unsure of what the result of installing this device driver might be, I would suggest backing up the system, just in case the device driver does not work properly with Microsoft Windows 7.

 

Regards,

 

Aryeh Goretsky

 



I am a volunteer and neither a Lenovo nor a Microsoft employee. • Dexter is a good dog • Dexter je dobrý pes
S230u (3347-4HU)X220 (4286-CTO)W510 (4318-CTO)W530 (2441-4R3)X100e (3508-CTO)X120e (0596-CTO)T61p (6459-CTO)T43p (2678-H7U)T42 (2378-R4U)T23 (2648-LU7)
de.gif  Deutsche Community es.gif  Comunidad en Español
Blue Screen Again
kyosti
Posts: 3
Registered: ‎11-28-2010
Location: Estonia
0

Re: T41 slow wireless connection - speed only 5.5 Mbps

Thanks Aryeh. The device driver you suggested installed and works on Win7, but didn't help with the speed. The driver seems to be the same version as the one on Windows Update for Win7.

Any other advice?
goretsky
Posts: 1,944
Topics: 19
Kudos: 349
Solutions: 132
Registered: ‎12-01-2007
Location: California, USA
0

Re: T41 slow wireless connection - speed only 5.5 Mbps

Hello,

 

If moving the ThinkPad T41 closer to the A-Link RR24AP(i+) router does not improve the connection speed, I would suggest looking at either replacing the Intel PRO/Wireless LAN 2100 3B Mini PCI Adapter, which is an 802.11b 11Mbps part, with a wireless adapter that supports 802.11g, the 54Mbps standard.  If you want to replace the Mini PCI adapter with a newer one, you will need to find one that is from a ThinkPad or has an IBM/Lenovo FRU (field replaceable unit) number on it, as non-IBM/Lenovo parts do not work.  Some possible FRUs that might work are:

 

27K9944

27K9948

27K9944

27K9946

27K9999

39T0081

39T0083

39T0355

91P7301

93P4262

 

but please do some additional research to verify compatibility (i.e., check with the seller first to verify compatibility).  Mini PCI cards come in two sizes, 3A (large) and 3B (small), so you will need a 3B version of a card to fit in your ThinkPad.


The other possibility would be to use an external USB adapter, which might give you some addition benefits such as a larger external antenna and 802.11n support, an even faster wireless standard (faster than your existing wireless router).

 

Regards,

 

Aryeh Goretsky

 



I am a volunteer and neither a Lenovo nor a Microsoft employee. • Dexter is a good dog • Dexter je dobrý pes
S230u (3347-4HU)X220 (4286-CTO)W510 (4318-CTO)W530 (2441-4R3)X100e (3508-CTO)X120e (0596-CTO)T61p (6459-CTO)T43p (2678-H7U)T42 (2378-R4U)T23 (2648-LU7)
de.gif  Deutsche Community es.gif  Comunidad en Español
Blue Screen Again
kyosti
Posts: 3
Registered: ‎11-28-2010
Location: Estonia
0

Re: T41 slow wireless connection - speed only 5.5 Mbps

Thanks again, I'll probably get a new adapter.