Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
Robzz
Posts: 5
Registered: ‎10-28-2011
Location: Hungary
0
Accepted Solution

T60 HDD problem (ERROR CODE: 2100)

Hi!

I have IBM Thinkpad T60 notebook with Intel 82801GBM (ICH7-M Family) chipset SATA controller.
The HDD is new. (WD1600BEVS) My problem the next: when i power on the notebook the first boot screen is waiting, while the hdd is try to run.  (i hear rhythmic clack from hdd)
After 20-30s the laptop is goes to error with the next error code: "2100: HDD0 initialization error (3).
I push the power button to the soft restart and the T60 is reboot.
The second try is perfect, the XP SP3 is start. (never second HDD error)
Every cold start shows this method!
After the boot the laptop is run perfect, no any error with something.
What's this problem?
How can i resolve this?
Thanks your help!
Regards:
Robert

802.11n
pagroundhog
Posts: 228
Registered: ‎10-19-2011
Location: PA
0

Re: T60 HDD problem (ERROR CODE: 2100)

[ Edited ]

Here is a Lenovo patch that may actually address your problem; however, it targets windows vista (and earlier operating systems). My guess is that it still has applicability to Win 7 too but I would check with support before applying it.

 

Now, before downloading the patch, check out the readme file where it specifically identifies your HD problem (ERROR CODE: 2100) and your new HD model number (WDxxxxBEVS-08RS) for corrective action.

 

See here:

http://support.lenovo.com/en_US/detail.page?LegacyDocID=MIGR-63685#changes

 

Please bear in mind that the above (potential) fix does not rule out the possibility of an intermittent HD failure; however, it is strange that "only" your WD hard drive model number is on the affected list.

 

Good luck!

Paper Tape
Robzz
Posts: 5
Registered: ‎10-28-2011
Location: Hungary
0

Re: T60 HDD problem (ERROR CODE: 2100)

Ok, thanks!
i'll try it!
goretsky
Posts: 1,976
Topics: 19
Kudos: 352
Solutions: 139
Registered: ‎12-01-2007
Location: California, USA
0

Re: T60 HDD problem (ERROR CODE: 2100)

Hello,

 

I wonder if you might have purchased a failing hard disk drive.  Sometimes hard disk drives fail out of the box, even when they are new.  Do you have another computer you can test it with?

 

Regards,

 

Aryeh Goretsky

 



I am a volunteer and neither a Lenovo nor a Microsoft employee. • Dexter is a good dog • Dexter je dobrý pes
S230u (3347-4HU)X220 (4286-CTO)W510 (4318-CTO)W530 (2441-4R3)X100e (3508-CTO)X120e (0596-CTO)T61p (6459-CTO)T43p (2678-H7U)T42 (2378-R4U)T23 (2648-LU7)
de.gif  Deutsche Community es.gif  Comunidad en Español ru.gif Русскоязычное Сообщество
802.11n
pagroundhog
Posts: 228
Registered: ‎10-19-2011
Location: PA
0

Re: T60 HDD problem (ERROR CODE: 2100)

[ Edited ]

Hello Aryeh,

 

I too would normally lean towards a bad drive out of the box (because of the clicking); however, this only happens on a cold start and the reboot works fine all the time. Moreover, it is very peculiar that the patch I suggested contains an error 2100 fix for his exact hard drive. Anyway, I hope he reports back with his final resolution.

 

Regards,

 

pagroundhog

Paper Tape
Robzz
Posts: 5
Registered: ‎10-28-2011
Location: Hungary
0

Re: T60 HDD problem (ERROR CODE: 2100)

Dear Pagroundhog!

 

Your recommended solution  was fine!

I downloaded the WD patch for this HDD.

The patch was recognize the old version (8.x...) and updated to (11.x...)

I started the T60 3-4x with cold start and was everything fine!

Thanks!

 

Regards:

Rob

802.11n
pagroundhog
Posts: 228
Registered: ‎10-19-2011
Location: PA
0

Re: T60 HDD problem (ERROR CODE: 2100)

Amazing!  Nice job.