Support in other languages: 
Reply
Paper Tape
tron_barbeque
Posts: 1
Registered: ‎06-23-2012
Location: Canada
0

T61 7658-CTO won't start up

I bought a Thinkpad T61 off eBay as non-working and figured I might give it a shot trying to resurrect it.

 

When I plug the battery and AC in, I get a flashing battery LED and a solid power-plug LED.

 

If I try to start the machine, the caps lock and num lock LEDs come on along with the power LED while the battery LED remains blinking. Eventually the caps lock and num lock LEDs turn off and nothing seems to happen on the screen. Only the power LED, battery LED (blinking) and AC LED are on.

 

Removing the battery only makes the battery LED go away, it doesn't make the computer turn on.

 

Plugging it into external VGA didn't seem to produce any external video either (and this is a 7658 so it should have Intel graphics and not the nVidia ones).

 

I popped it open to see if the RAM had been removed, but it has two 1GB sticks of Hynix PC5300. I removed both sticks and tried to power up to see if it would beep, but no beeps were heard. I tried with headphones as a wild guess but nothing came out of there either. Installing the RAM one at a time in either slot doesn't change matters.

 

The fan turns on and spins but then slows and stops shortly after the num lock and caps lock LEDs turn off. The hard drive clicks if I turn the machine off by holding the power button.

 

I removed the hard drive, DVD drive, palm rest cable, and all the RAM but nothing changes.

 

I'm fairly sure the power supply is right (Lenovo 90W 20V).

 

Is there a diagnostic method I've skipped over, or can I go ahead and assume this one is dead?

ajkula66
Posts: 7,600
Kudos: 750
Solutions: 792
Registered: ‎11-23-2007
Location: USA
0

Re: T61 7658-CTO won't start up

Welcome to the forum!

 

Any ThinkPad board that doesn't beep with RAM removed is most likely - as in 99.9% - dead.

Cheers,

George




In daily use: T43pSF, R60F, T61, X220T, X301

Collecting dust: T60, T60p, T61p, R500F

Rebuilding: A31p, T42p,

Non-ThinkPads: Panasonic CF-31 & CF-52, HP 8760W

I build FrankenPads....scary FrankenPads...

S = SATA-mod (on T43/p units only)
F = FrankenPad
L = LED-mod utilizing an UXGA AFFS LED screen


Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
.
Guru
Mornsgrans
Posts: 2,438
Registered: ‎03-19-2009
Location: Idar-Oberstein, Germany
0

Re: T61 7658-CTO won't start up

Your Thinkpad has an Intel Video device - so it is NOT the nVidia-bug :smileywink:

 

Detach battery and power supply and press the power button for approx. 30 seconds. After that attach the power supply and turn laptop on.

 

  • check the USB-ports, whether they are complete and their contacts have no short
  • do you find indications for a liquid damage - also see bottom side of the system board? (white or other colored film on parts of the board or devices)
  • detach all drives, as well as wireless LAN, device and the display cable and try to turn on
--------------------------------
My home-forum: http://www.thinkpad-forum.de
Wiki: Deutsches ThinkPad-Wiki English ThinkWiki
My ThinkPad-Collection