Support in other languages: 
Reply
Serial Port
Bajpai
Posts: 117
Registered: ‎01-02-2008
Location: Pune, India
0

Vista SP1 -- Driver issues with T61

Vista SP1 is now avaibale through automatic downloads. However, it is not available for my T61. A quick search on the net reveals that there appear to be some issues with the drivers -- finger print and Intel integrated video drivers.
 
Are there any workarounds available?
Any idea where one could download the new drivers?
Is anyone else also experiencing these issues?
Sushil
_________________________________________________________________
ThinkPad T61, (7658CTO), T7500, Integrated Graphics, 320 GB HDD, 3 GB RAM, 1 GB Intel Turbo Memory, Vista (32 bit) Business
goretsky
Posts: 1,944
Topics: 19
Kudos: 349
Solutions: 132
Registered: ‎12-01-2007
Location: California, USA
0

Re: Vista SP1 -- Driver issues with T61

[ Edited ]
Hello,
 
I have installed the slipstreamed DVD containing Microsoft Windows Vista with Service Pack 1 from MSDN on my T61p and reinstalling the latest downloadable versions of the Lenovo-provided software without any problems, however, that was with a retail installation of Windows Vista and not the Lenovo-provided OEM version.
 
It could be there is something about your T61's operating environment which prevents the service pack from being displayed on in Windows Update.  Microsoft knowledgebase article #948343, "Windows Vista Service Pack 1 is not available for installation from Windows Update and is not offere..." explains the eight most likely reasons for this, along with steps on how to troubleshoot them.
 
If none of those seem to apply and you are ready to proceed, here are links to the download pages for Microsoft Windows Vista Service Pack 1:
What you might want to do is back up any valuable data, make sure you have any other files available for software you might need to reinstall in case things go badly, and then try applying the service pack.  I wrote a short note in my personal blog here about some steps to take before installing the service pack—nothing that should really surprising, though.
 
Regards,
 
Aryeh Goretsky
 
 


Message Edited by goretsky on 03-20-2008 02:02 AM


I am a volunteer and neither a Lenovo nor a Microsoft employee. • Dexter is a good dog • Dexter je dobrý pes
S230u (3347-4HU)X220 (4286-CTO)W510 (4318-CTO)W530 (2441-4R3)X100e (3508-CTO)X120e (0596-CTO)T61p (6459-CTO)T43p (2678-H7U)T42 (2378-R4U)T23 (2648-LU7)
de.gif  Deutsche Community es.gif  Comunidad en Español
Retired Moderator
vkyr
Posts: 298
Registered: ‎12-12-2007
Location: Germany, near Hamburg
0

Re: Vista SP1 -- Driver issues with T61

Yes, Vista Update doesn't install the SP1 full automatically and in this Blog entry Microsoft describes the procedure. Users can via Windows Update download some lean version of the installation paket, which  only installs the absolut needed parts for Vista system. But the download has to be explicit initiated – even if Windows-Update is configured to automatically download and install security patches.

If the SP1 doesn't appear inside the Update-window, one reason for this might be, that Windows Update detected a driver that doesn't work together with the SP1. In such cases Microsoft advices to install an actual driver as an optional update. - See also the above links goretsky allready pointed to!

ThinkPad T60/X32/600/770 · IBM IntelliStation · 3x IBM SpaceSaver II

Punch Card
emspilot
Posts: 13
Registered: ‎03-19-2008
Location: Cazenovia, NY
0

Re: Vista SP1 -- Driver issues with T61

Windows Update offered SP1 to me last night for my T61. It installed fine and the system seems snappier (purely subjective, I know...). I do not have the fingerprint reader. I have the nVidia 140 graphics card and the DL DVD burner. Beyond that my hardware and drivers are pure vanilla.
Serial Port
Bajpai
Posts: 117
Registered: ‎01-02-2008
Location: Pune, India
0

Re: Vista SP1 -- Driver issues with T61

It appears that the problem is with Intel Video Drivers provided by Lenovo which is Ver 7.14.10.1329. The Vists SP1 upgrade expects a newer driver. The new driver available at Intel site does not instal on T61.
 
Looking at the following link
 
 
The resolution for Cause number 5, is enumerated as under:
 
"Display drivers

Intel Display
  • For x86-based computers: Igdkmd32.sys – versions between and including driver 7.14.10.1322 and 7.14.10.1403
  • For x64-based computers: Igdkmd64.sys – versions between and including driver 7.14.10.1322 and 7.14.10.1403 "
 
This situation therefore appears to be limited to T61 (with integrated video) and not T61 P. It is indeed strange that Lenovo has not been able to work with the Intel Generic Driver.
 
I have downloaded the standalone version of the SP1, but am hesitant to instal it without first installing the appropriate driver.
 
Any ideas?
 
 
Sushil
_________________________________________________________________
ThinkPad T61, (7658CTO), T7500, Integrated Graphics, 320 GB HDD, 3 GB RAM, 1 GB Intel Turbo Memory, Vista (32 bit) Business
What's DOS?
raudo
Posts: 1
Registered: ‎04-02-2008
Location: Sweden
0

Re: Vista SP1 -- Driver issues with T61

The problem is indeed related to the Intel video driver.

Lenovo needs to provide an update to their latest signed driver (7.14.10.1329) since as noted by Bajpai installing the latest driver from Intel's site fails.
Paper Tape
michaelwpd
Posts: 5
Registered: ‎04-03-2008
Location: new york, ny
0

Re: Vista SP1 -- Driver issues with T61

Does anyone know when this updated driver will be available? and will it be through Lenovo or Intel?

Thanks.
billbolton
Posts: 1,839
Topics: 68
Kudos: 167
Solutions: 103
Registered: ‎12-02-2007
Location: Sydney, Australia - Best Address on Earth
0

Re: Vista SP1 -- Driver issues with T61



Bajpai wrote:
Are there any workarounds available?
 

The workaround is to download SP1 from Microsoft and install it manually.  There are no issues with the Intel driver on ThinkPads and SP1 installs and functions fine with it.

Cheers,
 
Bill
------------------------------
I don't work for Lenovo
Serial Port
Bajpai
Posts: 117
Registered: ‎01-02-2008
Location: Pune, India
0

Re: Vista SP1 -- Driver issues with T61

I finally installed Vista SP1 after downloading from microsoft. The upgrade was painless. However, I have lost the Blue ThinkVantage functionality on my T61. Any ideas how could I restore that.
Sushil
_________________________________________________________________
ThinkPad T61, (7658CTO), T7500, Integrated Graphics, 320 GB HDD, 3 GB RAM, 1 GB Intel Turbo Memory, Vista (32 bit) Business
Serial Port
Bajpai
Posts: 117
Registered: ‎01-02-2008
Location: Pune, India
0

Re: Vista SP1 -- Driver issues with T61

I did gather courage and installed Vista SP1 standalone on 9th April. Here are some issues that I noticed
 
  1. I lost the Blue ThinkVantage Button.
  2. Lost several function keys including F5, F7, and F8
  3. Lost Roxio which came pre-installed
  4. The system slowed down considerably
  5. Acting up in numerous other ways

Fortunately, I had made an Acronis Image, which I used to restore to pre-SP1 state. I'll live with the issues previous to applying SP1. This appeared to be clear case of cure being worse than the malady. 

I learned my lesson. Don't use SP1 standalone, unless it shows up on its own. It appears MS knows more than it is willing to publicly acknowledge. At least it is attempting to protect the end-user backlash by not showing SP1 on automatic updates on suspect configurations.

Sushil
_________________________________________________________________
ThinkPad T61, (7658CTO), T7500, Integrated Graphics, 320 GB HDD, 3 GB RAM, 1 GB Intel Turbo Memory, Vista (32 bit) Business