Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Ctrl-Alt-Del
mahima_hada
Posts: 8
Registered: ‎12-02-2010
Location: New York
0
Accepted Solution

Display flickers (goes blank) based on power/battery

Hi,

 

I just received my new Thinkpad Edge 14. Whenever I plug in the laptop to the power cord or plug it out, my screen goes blank for a second, and then comes back up. Very weird. 

 

I've tried making the brightness level the same in both settings (power and battery) and I turned off the graphic display management option for "battery" in graphics properties.

 

I would like to see if this can be rectified soon (within my returnable period), or is this is a harbinger of display problems down the road (so, I should return it?)

 

thanks!

Ctrl-Alt-Del
mahima_hada
Posts: 8
Registered: ‎12-02-2010
Location: New York
0

Re: Display flickers (goes blank) based on power/battery

Forgot to add. I have the i5, 4GB RAM, 64 bit, Intel HD Graphics BR 1004 01Y1, Monitor Thinkpad display 1366X768
Fanfold Paper
jimtristate
Posts: 11
Registered: ‎12-02-2010
Location: ohio valley
0

Re: Display flickers (goes blank) based on power/battery

[ Edited ]

Your description sounds similar to another thread talking about LCDs blanking randomly.  I'm convinced this problem is caused by a faulty LCD lid switch and seems to be quite common in the Edge. The switch is a magnetic sensor and very sensitive.

Ctrl-Alt-Del
mahima_hada
Posts: 8
Registered: ‎12-02-2010
Location: New York
0

Re: Display flickers (goes blank) based on power/battery

Thanks! I did go through that thread. In my case it is not random at all. I remove the power cord - blank and back. I put in the power cord - blank and back. Repeatable patten, very annoying. 

Fanfold Paper
jimtristate
Posts: 11
Registered: ‎12-02-2010
Location: ohio valley
0

Re: Display flickers (goes blank) based on power/battery

Likewise, I'm on the verge of returning it.  Hate to, cause I like it.

What's DOS?
paulbhushan
Posts: 3
Registered: ‎03-11-2011
Location: 75428
0

Screen goes blank when trying to connect Ac adaptor

Hello,

I got my new Lenovo Thinkpad Edge 14" laptop. The probem is when ever i'm trying to coneect or disconnect the AC adaptor the screen goes blank for 2 seconds and comes back to normal again. 

Is this normal with every other Thinkpad Edge?

If not Please suggest me solution to solve this issue.....!

 

Thanks in advance...

Paul

Community SuperMod
bananaman
Posts: 3,650
Registered: ‎04-25-2008
Location: San Francisco
0

Re: Screen goes blank when trying to connect Ac adaptor

Hi paulbhushan, and welcome to the Lenovo User Community!

 

Try binaryspiral's solution:

 

http://forums.lenovo.com/t5/T400-T500-and-newer-T-series/T400-screen-blinks-when-AC-power-is-connect...

 

Hope this helps!

I don't work for Lenovo. I'm a crazy volunteer!
What's DOS?
paulbhushan
Posts: 3
Registered: ‎03-11-2011
Location: 75428
0

Re: Screen goes blank when trying to connect Ac adaptor

Thanks a lot bananaman.... u saved the day.

now the blinking is gone.

But is there any other solution that we can keep the screen refresh rate 60 Hz and do this...?

 

Anyways thanks a lot bro..

Community SuperMod
bananaman
Posts: 3,650
Registered: ‎04-25-2008
Location: San Francisco
0

Re: Screen goes blank when trying to connect Ac adaptor

Hi paulbhushan, Glad that worked!

 

As far as I know that's just how the graphics works, and there is no way to stop the temporary blackout when changing refresh rates.

 

What is it that works for you at 60Hz but not at 50Hz? I have to admit that for everything I do 50Hz or 60Hz makes no difference.

I don't work for Lenovo. I'm a crazy volunteer!