Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
e220srock
Posts: 5
Registered: ‎06-22-2011
Location: internet
0
Accepted Solution

Intel WiFi Link 1000 bgn @ E220s: access point visible but not connecting

[ Edited ]

Hi there,

 

just got my new E220s - love it! Only problem is that I can see the wireless access points but as soon as I try to connect to them it says: "Windows was unable to connect to <network>".

 

My configuration is a Lenovo TinkPad E220s:  Intel Core i5, Intel WiFi Link 1000 bgn, Bluetooth 3.0, 7200 rpm 320 GB HDD, 4GB RAM, Windows7 Home Premium.

 

My system is up-to-date with respect to Windows update, Lenovo update, and BIOS.

 

* Tried connecting to a FritzBox 7141 (b, g, g++ standards)

 ** using WPA-PSK: entered the passphrase -> problem as above

 ** using no encryption -> problem as above

* Tried connection to 'eduroam' (popular, worldwide educational wifi) -> problem as above

 

* Using Lenovo's driver 14.0.1 -> problem as above

* Manually installing Intel's driver 14.1.1.3 -> problem as above

 

Intel's 'Manual Diagnostic tool':

 * hardware test: passed

 * driver test: passed

 * radio test: passed

 * scan test: passed

 * association test: failed

 * remaining tests: not run

 

Some more diagnosis from Windows:

Details about network adapter diagnosis: 

Network adapter Wireless Network Connection driver information:

   Description . . . . . . . . . . : Intel(R) WiFi Link 1000 BGN
   Manufacturer  . . . . . . . . . : Intel Corporation
   Provider  . . . . . . . . . . . : Intel
   Version   . . . . . . . . . . . : 14.0.0.113
   Inf File Name . . . . . . . . . : C:\Windows\INF\oem14.inf
   Inf File Date . . . . . . . . . : Tuesday, November 09, 2010  8:43:32 AM
   Section Name  . . . . . . . . . : Install_MPCIEX_Lenovo_1000_HMC_BGN_WIN7_64
   Hardware ID . . . . . . . . . . : pci\ven_8086&dev_0084&subsys_13158086
   Instance Status Flags . . . . . : 0x180200a
   Device Manager Status Code  . . : 0
   IfType  . . . . . . . . . . . . : 71
   Physical Media Type . . . . . . : 9
Informational
Diagnostics Information (Wireless Connectivity)
Details about wireless connectivity diagnosis: 

Information for connection being diagnosed
 Interface GUID: f5790b82-3633-46d3-833d-df29c55f3b48
 Interface name: Intel(R) WiFi Link 1000 BGN
 Interface type: Native WiFi
 Profile: Discovery connection
 SSID: eduroam
 SSID length: 7
 Connection mode: Infra
 Security: Yes
 Connect even if network is not broadcasting: No

Connection incident diagnosed
 Auto Configuration ID: 1
 Connection ID: 10

Connection status summary
 Connection started at: 2011-06-22 13:33:00-459
 Profile match: Success
 Pre-Association: Success
 Association: Fail
 Security and Authentication: Not started

List of visible access point(s): 4 item(s) total, 4 item(s) displayed
        BSSID		BSS Type PHY	Signal(dB)	Chnl/freq    SSID
-------------------------------------------------------------------------
	Infra	 g	-87		9	 
	Infra	 g	-87		9	 eduroam
	Infra	 g	-89		9	 
	Infra	 g	-88		9	 

Connection History

 Information for Auto Configuration ID 2

  List of visible networks: 4 item(s) total, 4 item(s) displayed
  BSS Type PHY	Security	Signal(RSSI)	Compatible	SSID
  ------------------------------------------------------------------------------
  Infra	 g	Yes		21	Yes		
  Infra	 g	Yes		21	Yes		eduroam
  Infra	 g	Yes		18	Yes		
Infra g No 20 Yes
List of preferred networks: 0 item(s) Information for Auto Configuration ID 1 List of visible networks: 4 item(s) total, 4 item(s) displayed BSS Type PHY Security Signal(RSSI) Compatible SSID ------------------------------------------------------------------------------ Infra g Yes 20 Yes
Infra g No 21 Yes
Infra g Yes 21 Yes Infra g Yes 21 Yes eduroam List of preferred networks: 0 item(s) Information for Connection ID 10 Connection started at: 2011-06-22 13:33:00-459 Auto Configuration ID: 1 Profile: Discovery connection SSID: eduroam SSID length: 7 Connection mode: Infra Security: Yes Pre-Association and Association Connectivity settings provided by hardware manufacturer (IHV): No Security settings provided by hardware manufacturer (IHV): No Profile matches network requirements: Success Pre-association status: Success Association status: Fail 0x00038002 Association reason code: 0x00000002 Information for Connection ID 9 Connection started at: 2011-06-22 13:32:50-444 Auto Configuration ID: 1 Profile: Discovery connection SSID: eduroam SSID length: 7 Connection mode: Infra Security: Yes Pre-Association and Association Connectivity settings provided by hardware manufacturer (IHV): No Security settings provided by hardware manufacturer (IHV): No Profile matches network requirements: Success Pre-association status: Success Association status: Fail 0x00038002 Association reason code: 0x00000001 Information for Connection ID 8 Connection started at: 2011-06-22 13:32:44-501 Auto Configuration ID: 1 Profile: Discovery connection SSID: eduroam SSID length: 7 Connection mode: Infra Security: Yes Pre-Association and Association Connectivity settings provided by hardware manufacturer (IHV): No Security settings provided by hardware manufacturer (IHV): No Profile matches network requirements: Success Pre-association status: Success Association status: Fail 0x00038002 Association reason code: 0x00000002 Information for Connection ID 7 Connection started at: 2011-06-22 13:32:34-485 Auto Configuration ID: 1 Profile: Discovery connection SSID: eduroam SSID length: 7 Connection mode: Infra Security: Yes Pre-Association and Association Connectivity settings provided by hardware manufacturer (IHV): No Security settings provided by hardware manufacturer (IHV): No Profile matches network requirements: Success Pre-association status: Success Association status: Fail 0x00038002 Association reason code: 0x00000000 Information for Connection ID 6 Connection started at: 2011-06-22 13:32:28-526 Auto Configuration ID: 1 Profile: Discovery connection SSID: eduroam SSID length: 7 Connection mode: Infra Security: Yes Pre-Association and Association Connectivity settings provided by hardware manufacturer (IHV): No Security settings provided by hardware manufacturer (IHV): No Profile matches network requirements: Success Pre-association status: Success Association status: Fail 0x00038002 Association reason code: 0x00000002 Information for Connection ID 5 Connection started at: 2011-06-22 13:32:22-582 Auto Configuration ID: 1 Profile: Discovery connection SSID: eduroam SSID length: 7 Connection mode: Infra Security: Yes Pre-Association and Association Connectivity settings provided by hardware manufacturer (IHV): No Security settings provided by hardware manufacturer (IHV): No Profile matches network requirements: Success Pre-association status: Success Association status: Fail 0x00038002 Association reason code: 0x00000002 Information for Connection ID 4 Connection started at: 2011-06-22 13:32:12-566 Auto Configuration ID: 1 Profile: Discovery connection SSID: eduroam SSID length: 7 Connection mode: Infra Security: Yes Pre-Association and Association Connectivity settings provided by hardware manufacturer (IHV): No Security settings provided by hardware manufacturer (IHV): No Profile matches network requirements: Success Pre-association status: Success Association status: Fail 0x00038002 Association reason code: 0x00000001 Information for Connection ID 3 Connection started at: 2011-06-22 13:32:06-607 Auto Configuration ID: 1 Profile: Discovery connection SSID: eduroam SSID length: 7 Connection mode: Infra Security: Yes Pre-Association and Association Connectivity settings provided by hardware manufacturer (IHV): No Security settings provided by hardware manufacturer (IHV): No Profile matches network requirements: Success Pre-association status: Success Association status: Fail 0x00038002 Association reason code: 0x00000002 Information for Connection ID 2 Connection started at: 2011-06-22 13:32:00-664 Auto Configuration ID: 1 Profile: Discovery connection SSID: eduroam SSID length: 7 Connection mode: Infra Security: Yes Pre-Association and Association Connectivity settings provided by hardware manufacturer (IHV): No Security settings provided by hardware manufacturer (IHV): No Profile matches network requirements: Success Pre-association status: Success Association status: Fail 0x00038002 Association reason code: 0x00000002 Information for Connection ID 1 Connection started at: 2011-06-22 13:31:50-633 Auto Configuration ID: 1 Profile: Discovery connection SSID: eduroam SSID length: 7 Connection mode: Infra Security: Yes Pre-Association and Association Connectivity settings provided by hardware manufacturer (IHV): No Security settings provided by hardware manufacturer (IHV): No Profile matches network requirements: Success Pre-association status: Success Association status: Fail 0x00038002 Association reason code: 0x00000001
Informational
Diagnostics Information (Wireless Connectivity)
Details about wireless connectivity diagnosis: 

For complete information about this session see the wireless connectivity information event.

Helper Class: Auto Configuration
 Initialize status: Success

Information for connection being diagnosed
 Interface GUID: f5790b82-3633-46d3-833d-df29c55f3b48
 Interface name: Intel(R) WiFi Link 1000 BGN
 Interface type: Native WiFi
 Profile: Discovery connection
 SSID: eduroam
 SSID length: 7
 Connection mode: Infra
 Security: Yes
 Connect even if network is not broadcasting: No

Result of diagnosis: Problem found
 Issue referred to: RNWF MSM Helper Class

Root cause:
Windows could not connect to "eduroam"
You can try to connect again.

Repair option:
Reset your wireless network adapter
This will disable and then enable the network adapter "Wireless Network Connection" on this computer.

Informational
Diagnostics Information (Wireless Network Adapter)
Details about wireless network adapter diagnosis: 

For complete information about this session see the wireless connectivity information event.

Helper Class: Native WiFi MSM
 Initialize status: Success

Information for connection being diagnosed
 Interface GUID: f5790b82-3633-46d3-833d-df29c55f3b48
 Interface name: Intel(R) WiFi Link 1000 BGN
 Interface type: Native WiFi
 Profile: Discovery connection
 SSID: eduroam
 SSID length: 7
 Connection mode: Infra
 Security: Yes
 Connect even if network is not broadcasting: No

Result of diagnosis: Problem found

Root cause:
Wireless association to "eduroam" failed
A response was not received from the router or access point.

Detailed root cause:
Wireless association to this network failed. Windows did not receive any response from the wireless router or accesspoint.

Repair option:
Look for causes of low wireless signal quality
The signal is weak due to distance or interference.
Windows Help and Support can provide more information about this problem.



 

I even tried using Linux openSUSE 11.4 -> same behavior but different error message.

 

Could somebody please, please help me?

Thank you so much in advance!

e220srock

 

Guru
ColonelONeill
Posts: 6,845
Registered: ‎12-26-2009
Location: Toronto
0

Re: Intel WiFi Link 1000 bgn @ E220s: access point visible but not connecting

[ Edited ]

I'd consider checking whether or not the antennae leads are attached properly...

 

It's also possible that the wireless card is defective, in which case you'd need to send it in for warranty.

W520: i7-2720QM, Q2000M at 1080/670/1340, 21GB RAM, 500GB HDD, FHD screen
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Paper Tape
e220srock
Posts: 5
Registered: ‎06-22-2011
Location: internet
0

Re: Intel WiFi Link 1000 bgn @ E220s: access point visible but not connecting

[ Edited ]

Hi ColonelONeill,

thank you for your input. How would I check the leads? The system is brand new. Therefore, I would not like to open it :-)

 

Why would it find the access points, if it was defective?

 

e220srock

Guru
ColonelONeill
Posts: 6,845
Registered: ‎12-26-2009
Location: Toronto
0

Re: Intel WiFi Link 1000 bgn @ E220s: access point visible but not connecting

Checking the antennae leads would indeed involve opening it up...

Sometimes stuff happens. Wifi cards are pretty complicated, so you never know what part of it might fail.

Also, am I right in assuming it doesn't connect to your personal router?
W520: i7-2720QM, Q2000M at 1080/670/1340, 21GB RAM, 500GB HDD, FHD screen
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Paper Tape
e220srock
Posts: 5
Registered: ‎06-22-2011
Location: internet
0

Re: Intel WiFi Link 1000 bgn @ E220s: access point visible but not connecting

I understand, you never known what makes it fail. Yes, you are right: it doesn't connect to my personal router no matter what configuration I try.

 

The problem is: I bought the machine in USA but now I am living in Europe. I do not think the standard support allows me to contact Lenovo Europe, right?

Maliha
Posts: 3,224
Registered: ‎07-31-2008
Location: Pakistan
0

Re: Intel WiFi Link 1000 bgn @ E220s: access point visible but not connecting

Hi e220srock and welcome to the forum!

 

As long as your Edge is covered in Europe through IWS you should be able to get support there.

------------------------------------------------------------

Maliha (I don't work for lenovo)
ThinkPads:- T400[Win 7], T60[Win 7], IBM 240[Win XP]

IdeaPad: U350

Apple:- Macbook Air [Snow Leopard]
Did someone help you today? Compliment them with a
Kudos!
Was your question answered today? Mark it as an Accepted Solution
de.gif  Lenovo Deutsche Community   es.gif  Lenovo Comunidad en Español 
Visit my YouTube Channel

What's DOS?
joonsuk
Posts: 1
Registered: ‎06-27-2011
Location: Brunswick, ME, USA
0

Re: Intel WiFi Link 1000 bgn @ E220s: access point visible but not connecting

My wife had much the same problems with the E220s. After much searching on the internet (and trying all sorts of other things that failed), the following two things worked for us:

 


#1:

"If you go into Control Panel -> Power Options and click "Change plan settings" for your current power plan.

On the next screen click on "Change advanced power settings"

On the next screen expand "Wireless Adapter Settings" and then "Power Saving Mode"

Make sure it is set to Maximum Performance.

 

#2:

Click on bottom-left corner "Windows" button

Type into search box "network connections"

Select "view network connections"

Right-click on "Local Area Connection"

Select "Disable"

 

Hope this will work for you too.

 

Best of luck

Paper Tape
e220srock
Posts: 5
Registered: ‎06-22-2011
Location: internet
0

Re: Intel WiFi Link 1000 bgn @ E220s: access point visible but not connecting

@Maliha: checking my warranty status I was provided with the following information:

This product has a one year limited warranty and is entitled to IBM EZServ service. Customers may call their local service center for more information. Dealers may provide carry-in repair for this product.

 

@joosuk: Thank you for your proposals. Unfortunately, they didn't work for me.

 

@all:

Yesterday, I contacted the Lenovo support here in Europe. A friendly guy logged into my system and said it was a hardware problem. Calling them back today, a woman gave me two options: either I send it in or I get the part to install it by myself. I chose the second option keeping the fingers crossed ;-)

 

Stay tuned for upcoming news...

Maliha
Posts: 3,224
Registered: ‎07-31-2008
Location: Pakistan
0

Re: Intel WiFi Link 1000 bgn @ E220s: access point visible but not connecting

Since they were able to offer support to you so that means your ThinkPad is indeed covered under IWS in Europe.

------------------------------------------------------------

Maliha (I don't work for lenovo)
ThinkPads:- T400[Win 7], T60[Win 7], IBM 240[Win XP]

IdeaPad: U350

Apple:- Macbook Air [Snow Leopard]
Did someone help you today? Compliment them with a
Kudos!
Was your question answered today? Mark it as an Accepted Solution
de.gif  Lenovo Deutsche Community   es.gif  Lenovo Comunidad en Español 
Visit my YouTube Channel

Paper Tape
e220srock
Posts: 5
Registered: ‎06-22-2011
Location: internet

Re: Intel WiFi Link 1000 bgn @ E220s: access point visible but not connecting

[ Edited ]

Hi there,

 

Problem solved. One of the antenna leads was not attached to the card at all and the other one had some contact by chance. It took me 3/4 of an hour to disable the battery, remove the keyboard, attach the leads to the network card (quite tricky because of lack of space) and put everything together again. Afterwards everything worked fine.

 

Thanks for helping, forum!

 

E220s rocks!!