Support in other languages: 
Reply
802.11n
is1981
Posts: 330
Registered: ‎03-29-2008
Location: New York, NY
0
Accepted Solution

10% battery on cell standby?

[ Edited ]
Hello.

I have a ThinkPad slate tablet (model 1838-2DG with an Ericsson F5521gw inside, no SIM card installed). Battery only lasts six hours on Wi-Fi (no CPU intensive tasks running on it, mid display brightness). It is not a lot of time for a (mostly) new unit that had a complete first charge before using.

One of the reasons for this poor battery performance, in my humble opinion, is that a 10% battery is wasted on "Cell standby" (with a 100% time without a signal). I would say that it is a consequence of an old udev enabling WWAN even if there is no SIM card installed, but I am far from being an Android (or Linux) expert.

Can someone confirm if this problem exists on ICS? (I would say this question is addressed to Lenovo staff, as there are no official ICS images available for public use.)

Thanks!
802.11n
slpin
Posts: 179
Registered: ‎06-02-2009
Location: California
0

Re: 10% battery on cell standby?

you have a very very old update on yours
just update it - that issue have been fixed almost half a year ago
802.11n
is1981
Posts: 330
Registered: ‎03-29-2008
Location: New York, NY
0

Re: 10% battery on cell standby?

[ Edited ]
This slate is fully updated, it is running ThinkPadTablet_A310_02_0039_0089_WE since the day it arrived two weeks ago.

Edit: slpin, I found one of the threads on the power issue you were talking about. People on that thread had a different problem, as their slates had a 20% up to 40% battery drain in cell standby on Wi-Fi only models. Mine has a 10% drain, but it should be 0% as there is no SIM card installed on my tablet. When there is no SIM installed, udev should disable the WWAN card. This is the reason I asked about udev behaviour on ICS 4.0.3 with relation to the Ericsson WWAN card.
802.11n
slpin
Posts: 179
Registered: ‎06-02-2009
Location: California

Re: 10% battery on cell standby?

if you look through the market - there are apps which allows manual enable/disable of the wann network

does the problem persist if you enable airplane mode and only use wifi from there?

edit: just reread your post - since you have a wann card installed, it will always take power when it is in there. mine does that too even if it is not connected to any network - because the card is always initialized. manually turning off mobile data does nothing as it still search for signal in its "sleep state". currently, the only option is physically removing the card - or use airplane mode + wifi on
802.11n
ameridian
Posts: 431
Registered: ‎01-30-2012
Location: USA

Re: 10% battery on cell standby?

[ Edited ]

I came across these lines in the init.rc file while looking for a way to permanently change the TPT hostname from localhost;

 

# TURN OFF 3G AUTOSUSPEND UNTIL IT ACTUALLY WORKS FINE!!!!!!!

on property:sku.board=3g

write /sys/devices/platform/tegra-ehci.1/usb1/1-0:1.0/power/control on

setprop gsm.operator.isactivating false

 

Someone with a 3G card may want to use getprop and confirm that the property is indeed set to false. An adventurous rooted fiddler could try setting it to true at the command line and see what happens. But beware, a little knowledge can be dangerous.:smileywink:

Punch Card
balancing
Posts: 86
Registered: ‎11-27-2011
Location: AZ
0

Re: 10% battery on cell standby?

I have the latest update, and now it's saying that "tablet idle" is using 24%. Is that normal?

802.11n
is1981
Posts: 330
Registered: ‎03-29-2008
Location: New York, NY
0

Re: 10% battery on cell standby?

[ Edited ]
@slpin: you are right, enabling airplane mode plus Wi-Fi has improved this issue a lot. I see no obvious battery drain from the WWAN card now. That is odd, I would say I tried setting Wi-Fi from airplane mode a few days ago and it didn't worked. Thanks a lot for the tip, it will be really helpful.

@ameridian: from the comment on the rc file I would say that there are problems with power management on, at least, some WWAN cards. It makes sense not fully-disabling power on them at least on Honeycomb. Hope these issues will be fixed for Ice Cream Sandwidch. Thanks for the advice, perhaps someone with root access will try changing this setting but if there are known issues on this OS release it is logical to expect a bad behavior on the WWAN side of the tablet if done.

Edit: marked slpin's suggestion about setting airplane mode plus Wi-Fi as solution as it seems a valid workaround (thanks for the tip!). It would be nice, however, getting a real fix on ICS. As ameridian found on a run-commands file comment, there are issues affecting power management on at least some WWAN cards, so autosuspend is disabled for them on Honeycomb.