Support in other languages: 
Reply
Punch Card
solverone
Posts: 3
Registered: ‎07-02-2012
Location: Nigeria
0

3g and wifi issues on ICS

I have noticed that once I switch off my wlan radio and use only 3g radio on, the device keeps restarting all by itself. when I switch back the wlan radio it stops restarting. I thought it must have been a former setting issue during the upgrade conflicting but I did a factory reset and its still the same. anyone experienced this?
Blue Screen Again
tobyg
Posts: 29
Registered: ‎09-01-2009
Location: IL
0

Re: 3g and wifi issues on ICS

Did you add your own Gobi 3000 card or did yours come with the WWAN card?  I added my own.

 

I was having this problem too.  Every 1-4 hours it would reboot with 3G (Now shows as 4G though) enabled.  I did a factory reset (I didn't want to, didn't want to risk losing root, but root was maintained) and it did not help.  I left it in the dock overnight with 3G disabled, uptime was 12+ hours.  Enabled 3G, and could never get more than 4 hours before a reboot.

 

I ended up having another Gobi 3000 card laying around and swapped it, and now my tablet is 100% stable.  I'm not sure what the problem was exactly, if it's a bad card, different firmware, etc.  I do know the card I put in that is working is older than the one I had in there.  My guess is some sort of firmware issue, but I haven't gone that far to troubleshoot it now that mine is working well.

Punch Card
spip72
Posts: 40
Registered: ‎11-17-2010
Location: Denmark
0

Re: 3g and wifi issues on ICS

I do not have the frequent restarts that you do, but the tablet does drop the 3G connection a few times a week, and only remedy is to restart. Also, sometimes the tablet just closes down. This often happens when it's idle in my bag on my way to work. Maybe related?

Punch Card
solverone
Posts: 3
Registered: ‎07-02-2012
Location: Nigeria
0

Re: 3g and wifi issues on ICS

I added mine too. I can confirm that the workaround the issue is ensuring that wlan is left on even when I am out of my wifi zone. it never restarts but once the wlan is put to off, the issue starts again.
I can almost be sure that its an issue with 3g connectivity but why wlan keeps it up is a mystery.