Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Blue Screen Again
Arbelac
Posts: 3
Registered: ‎06-22-2012
Location: Vancouver
0

VPNService API Support / IPSec XAUTH not working

I've got a ROW tablet (unrooted) and successfully updated to 4.0.3.

 

However, the biggest feature I was looking forward to, IPSec VPN w/PSK & XAUTH, isn't working. It says it connects, but it actually doesn't work at all, nor do my endpoints even show an attempted connection.

 

Does the Lenovo image actually support the VPNService API that's supposed to give apps the ability to create tunnels without root? There are a couple of apps in the market, but they're coming up with 'incompatible' and I haven't heard back from the developers yet.

 

Thanks.

Blue Screen Again
Arbelac
Posts: 3
Registered: ‎06-22-2012
Location: Vancouver
0

Re: VPNService API Support / IPSec XAUTH not working

No one else having this issue? I know the IPSec termination points work, as they function correctly when used with a desktop/laptop client.

Fanfold Paper
dudione
Posts: 10
Registered: ‎06-04-2012
Location: Belgium
0

Re: VPNService API Support / IPSec XAUTH not working

It doesn't due to the tunnel.ko not being installed in the image.
It does seem a problem with ICS than it this to be with Lenovo. After search for tunnel.ko for TPT and don't finding it, I installed VPNcilla, great app. So I would advice to use that.
Blue Screen Again
Arbelac
Posts: 3
Registered: ‎06-22-2012
Location: Vancouver
0

Re: VPNService API Support / IPSec XAUTH not working

Thanks. So at least the VPNService API is available.

 

Poor form for Lenovo to upgrade to ICS and give these options without putting in a tunnel module. Especially on a 'business tablet'.

Fanfold Paper
dudione
Posts: 10
Registered: ‎06-04-2012
Location: Belgium
0

Re: VPNService API Support / IPSec XAUTH not working

Still it is ICS that is the problem so you should blame Google first. Although I agree Lenovo should have been aware and add a solution to it.