Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Blue Screen Again
DaOm
Posts: 2
Registered: ‎03-14-2012
Location: Swiss
0
Accepted Solution

Lenovo D20 and Revodrive3 PCI

Hello,

I installed a Revodrive3 OCZ on my D20

At boot time I get an message error "Expansion ROM not initialized".

Then the machine boots but on the SATA primary disk, not the Revodrive.

If I go into the BIOS to disable SATA ROM check, then the error message disappears, The machine boots onto the Revodrive, but then all SATA drives ar not visible and not usable in Windows 7.

If anyone has a solution, I would be very glad to know.

I tried virtually all possible configuration in the BIOS with always same result.

Thank you very much in advance!

Olivier

psuturtle
Posts: 862
Topics: 9
Kudos: 150
Solutions: 102
Registered: ‎02-22-2010
Location: NC

Re: Lenovo D20 and Revodrive3 PCI

Well if you disable the SATA ROM, then no oprom loads to handle SATA so the OS won't be able to see those devices....that's expected.  It sounds like you're running into a ROM space issue.  You have the right idea in trying to turn off items that eat up space that aren't needed...you just picked the wrong one I think :smileyhappy:

 

If you're not using any of the blue SATA ports, then you could try to turn off the Marvell controller.  Another option would be to disable PXE boot and see if that opens up some additional space for you.  Could also disable the 2nd LAN completely if you're not using it in an attempt to save space.

Blue Screen Again
DaOm
Posts: 2
Registered: ‎03-14-2012
Location: Swiss
0

Re: Lenovo D20 and Revodrive3 PCI

Thank you for your advice !

I connected all my HDD on the black SATA connectors and fully disabled the Marvell controler.

And now I can see both my PCI RevoDrive3 and SATA drives.

 

Best regards

 

Olivier

:smileyhappy: