Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Blue Screen Again
brentosw
Posts: 3
Registered: ‎02-03-2013
Location: Toronto, Canada

UEFI Mode installation of Linux distributions on Thinkstation S30

[ Edited ]

This is a post to save other people some time and pain. What follows may apply to other systems using a similar Lenovo BIOS.

 

Symptom


If a user selects Optimal or Default BIOS options, wipes the pre-installed existing operating systems and partitions, and then installs a Linux distribution in UEFI mode on an SCU device, the ThinkStation S30 may return the following error and refuse to boot after successful installation.

 

Error 1962: No operating system found.

 

 

Description

 

It appears that, prior to to following the BootOrder specified in the UEFI Boot Manager, the Lenovo BIOS first checks the UEFI Boot Manager configuration for an entry labelled "Windows Boot Manager".[1] 

 

If this entry is not found, an error is presented to the user and the boot sequence terminates. The Lenovo BIOS does not require that the entry labelled "Windows Boot Manager" be used, only that it be present.

 

This may be related to the behaviour observed here.

 

It would be good if someone from Lenovo could confirm the observations about the behaviour of the Lenovo UEFI BIOS.

 

 

Solution

 

  1. Ensure that the SCU device is the set up as the first boot device in the BIOS Setup Primary Boot Sequence.
    Lenovo has documented this issue here.

  2. Ensure that there is an entry in the UEFI Boot Manager labeled "Windows Boot Manager"

 

Add an Entry to the UEFI Boot Manager labeled "Windows Boot Manager"


The following can be performed after installation of the operating system. The instructions assume that the user has access to "Live" installation media, is able to boot from that media and issue commands at the shell. It is also assumed that the user has a basic understanding of Linux devices references. The operating system must have been installed in UEFI mode and GRUB2 (or another bootloader) must have created at least one valid EFI boot file on the EFI system partition.

 

  1. Insert the Live installation media, shutdown and power off the system.
  2. Power on the system.
  3. Interrupt the boot sequence with Enter or F12 and select the live installation media for boot.
  4. Open a shell.
  5. Establish whether or not the Live installation provides the efibootmgr tool, if it does not, install the package that provides efibootmgr.
  6. As root, inspect the current configuration of the UEFI Boot Manager:

    sudo efibootmgr -v

  7. If there is already an entry labelled "Windows Boot Manager", the remainder of these instructions do not apply.
  8. If there is no entry, add one. For example:

    sudo efibootmgr -c -d /dev/sda -p 1 -l '\EFI\ubuntu\grubx64.efi' -L "Windows Boot Manager"

    Please note that the option provided to the -l option can be any valid EFI boot loader.
  9. Verify that the entry was added to the UEFI Boot Manager:

    sudo efibootmgr -v

  10. Set the desired boot order of the UEFI Boot Manager, for example if the boot loader for Ubuntu is 0000 and, Windows Boot Loader dummy is 0001, and remaining boot devices are 000A-000C:

    sudo efibootmgr -o 0000,0001,000A,000B,000C

  11. Veryify that the BootOrder variable has been set correctly:

    sudo efibootmgr -v

  12. Optionally, adjust the value of the Timeout option to provide the user with more time to interrupt the boot process, for example, to extend the timeout to 10 seconds:

    sudo efibootmgr -t 10

  13. Shutdown the system, remove the live installation media and reboot.
  14. After booting into the installed operating system, confirm that the BootCurrent variable has selected the correct loader and is behaving as expected. Please note, you may have to install efibootmgr in the installed operating system.

    sudo efiboogmgr -v

  15. If the above fails, consult the documentation of your boot loader and ensure that it is configured correctly. Also ensure that your EFI system partition is laid out correctly and formatted as FAT32.

 

 

Notes:

[1] It is possible that the BIOS checks for the presence of either "Windows Boot Manager' or "Red Hat Enterprise Linux", however I have not tested this: "Windows Boot Manager" worked and that suits me. Others may prefer a different aesthetic.

psuturtle
Posts: 862
Topics: 9
Kudos: 150
Solutions: 102
Registered: ‎02-22-2010
Location: NC
0

Re: UEFI Mode installation of Linux distributions on Thinkstation S30

This is slightly preemptive.  UEFI is not fully implemented on 30 series...yet.

Blue Screen Again
brentosw
Posts: 3
Registered: ‎02-03-2013
Location: Toronto, Canada
0

Re: UEFI Mode installation of Linux distributions on Thinkstation S30

That's an interesting tidbit of information.

 

I won't comment as to why the BIOS provides an option of UEFI if it's not yet supported.

 

Any chance that Lenovo might be able to confirm how the current UEFI implementation is actually working at this point in time? It'd also be useful to know whether the above applies to the rest of the ThinkStation *30 family. I think most people would be okay if a "dummy" entry is needed. It'd also be useful intelligence for distribution packagers.

 

I ask because, out of the box (that is, with the BIOS UEFI setting as "Auto"), the S30 will boot media in EFI mode first (ie, if a CD, DVD, or USB key contains an EFI system partition, that's the mode that will be booted). This makes most Linux installations attempt to install the boot loader as an EFI application.

 

For my money, the above solution was actually easier to get working than any any other solution (my boot media was created on a Mac, and the userland tools default to EFI assumptions).

psuturtle
Posts: 862
Topics: 9
Kudos: 150
Solutions: 102
Registered: ‎02-22-2010
Location: NC
0

Re: UEFI Mode installation of Linux distributions on Thinkstation S30

As I understand it (and I'm by no means a BIOS guy), when auto mode is enabled, ithe system will try to boot EFI (GPT) media first if it finds it....and if not it falls back to legacy (MBR).  I believe that's the main function of that option.

 

UEFI is a much bigger animal though than just boot partitions.  It encompasses much more such as OPROMs, etc.  It's been an ugly transition to say the least, so we're still working kinks out as far as UEFI is concerned.

 

I would say if your solution above seems to work, then great.  I'm even less of a linux expert than a BIOS expert, so I'm not going to dispute it :smileyhappy:

 

Also, it's not safe to assume that Lenovo BIOS across platforms (i.e. desktops, laptops, workstations, etc.) are all on the same level at any given time regarding UEFI.  Different platforms and brands (think vs. idea) could very easily have different core vendors as well as different methods of implementation based on their expected user base.

What's DOS?
pvollmar
Posts: 1
Registered: ‎08-16-2013
Location: Camp Hill, PA
0

Re: UEFI Mode installation of Linux distributions on Thinkstation S30

I am having the same problem with an H520. After running the installation, and then booting from the installation DVD again, I installed efibootmgr as directed. However, when I enter

 

sudo efibootmgr -v

 

I get

 

Fatal: Couln't open either sysfs or procfs directories for accessing EFI variables. Try 'modprobe efivars' as root.

 

which also fails with a fatal error.

What's DOS?
caryb
Posts: 1
Registered: ‎11-12-2013
Location: Caboolture Qld Australia
0

Re: UEFI Mode installation of Linux distributions on Thinkstation S30

I have a bright & shiney D30 after my D10 I assumed it would have a "real" raid controller but alas it has the Windows fake raid type. Ive installed a new Adaptec 3405 but as it's not EUFI compliant I get the dreaded error 1962. I have the bios in legacy mode but it seems that this is ignored :smileysad: I can boot by putting in a Ubuntu server disk & select boot from 1st drive. BTW am running Kubuntu 13.10 AMD64 O/S

 

Cary