Support in other languages: 
Reply
Token Ring
Svein_Skogen
Posts: 53
Registered: ‎06-01-2009
Location: Norway
0

Re: System Update - An error occurred while gathering user information

egatherer fails here too:

 

Right after it succeds the MTM (8918DNG), the following happens:

Severe    2009-06-01 , 11:17:32
    at Tvsu.Engine.Process.HelloProcess.Start()
    Message: An error ocurred while using the MappingParser
    Exception:
        Message: There is not entry for key Tvt.Mapping.OSeGatherer
        Type: System.NullReferenceException
           at Tvt.Mapping.OSs.get_Item(OSeGatherer k)
   at Tvsu.Engine.Process.HelloProcess.Start()

Severe    2009-06-01 , 11:17:32
    at Tvsu.Engine.Process.HelloProcess.Start()
    Message: A value could not be mapped when using the MappingParser or eGather execution failed
    Exception:
        Message: Error getting MappingParser properties
        Type: Tvsu.Engine.Process.MappingInterfaceException
           at Tvsu.Engine.Process.HelloProcess.Start()

Severe    2009-06-01 , 11:17:32
    at Tvsu.Engine.Task.Task.StartExecution()
    Message: An error occurred while the task: HelloTask executed the process: HelloProcessthe message from exception isA fatal error ocurred while in the HelloProcess
    Exception:
        Message: A fatal error ocurred while in the HelloProcess
        Type: Tvsu.Engine.Process.HelloProcessException
           at Tvsu.Engine.Task.Task.Start()
   at Tvsu.Engine.Task.Task.StartExecution()

Info    2009-06-01 , 11:17:32
    at Tvsu.Gui.CustomComponents.Step.set_Image(StepImage value)
    Message: Setting FAILED status.

 

I'm running 64bit Vista SP2.

 

If I'm reading the logs correctly, it seems that the egatherer has problems reading the OS version.Could this be a 64bit problem?

 

//Svein

W500 (4062) with 8GB ram, Seagate 500GB 7200rpm disk
Token Ring
Svein_Skogen
Posts: 53
Registered: ‎06-01-2009
Location: Norway
0

Re: System Update - An error occurred while gathering user information

Update:

 

 Adding the following to the MappingInterface xml helped:

                <OS>
            <OSTVIA>VS-HOMEULT.SP2</OSTVIA>
            <OSeGatherer>
                <Name>Vista Home Ultimate</Name>
                <ServiceRelease>Service Pack 2</ServiceRelease>
            </OSeGatherer>
            <OSQuest>Windows Vista</OSQuest>
        </OS>

 

//Svein

W500 (4062) with 8GB ram, Seagate 500GB 7200rpm disk
Vacuum Tubes
Galaxer
Posts: 26
Registered: ‎08-09-2008
Location: Germany
0

Re: System Update - An error occurred while gathering user information

Thanks szabie,

 

I corrected the xml file and SU works for me now!

ThinkPad 2912-3AG Win 7 Pro 64/ 4 GB RAM / 128 SSD
14,1" SXGA+ - The Last Possible NOTEBOOK Size :smileyhappy:
Lenovo FTSS - Contributor
Michael_Lenovo
Posts: 60
Registered: ‎06-01-2009
Location: Germany
0

Re: System Update - An error occurred while gathering user information

Hi, worked for my T500 as well, thanks a lot

I will post this to the main Forum as a solution. 

 Regards StarSheep

Thinkpad T410s -- 8GB of RAM -- 128GB SSD as boot drive -- 500GB Seagate Hybrid HDD with 4GB of SSD Memory as data drive
Lenovo FTSS - Contributor
Michael_Lenovo
Posts: 60
Registered: ‎06-01-2009
Location: Germany

New System Update UP AND RUNNING

Hi all,

as of now the new System Update is up and running and so far it works almost flawlessly, same feature set as before the shutdown end of March 2009.
I am updating a T500 right now for testing and so far no problem at all.
Attach you find a short discription what you need to do:

1.) Run System Update and there will be an update available for SU and Message Center Plus
2.) Install both and reboot to be safe.
3.) Run System Update and you will probably get this error message:http://img38.imageshack.us/img38/5074/clipboard02l.png
4.) The problem lies within Vista SP2, which ist also installed on my system and SU doesn't recognize it. Lenovo should fix this soon I hope.
5.) The solution lies in this file: c:\Program Files\Lenovo\System Update\session\system\SSClientCommon\MappingInterface.xml
In the OSs section the entry for SP2 is missing. You need to adapt the file according to YOUR SYSTEM OS. Just add it at the end of the OSs section.
I have Vista Ultimate installed so it looks like this:

<OS>
<OSTVIA>VS-HOMEULT.SP2</OSTVIA>
<OSeGatherer>
<Name>Vista Home Ultimate</Name>
<ServiceRelease>Service Pack 2</ServiceRelease>
</OSeGatherer>
<OSQuest>Windows Vista</OSQuest>
</OS>

For Vista Business it looks like this:
<OS>
<OSTVIA>VS-BUS.SP2</OSTVIA>
<OSeGatherer>
<Name>Vista Business</Name>
<ServiceRelease>Service Pack 2</ServiceRelease>
</OSeGatherer>
<OSQuest>Windows Vista</OSQuest>
</OS>

The easiest way is just to copy the according section and add it at the end of the OSs section with the change to SP2.
After adding the lines above the error was gone and SU found the updates with no problem.
I'd like to that szabie form the Lenovo forums for this hint: Source: http://forums.lenovo.com/lnv/board/mess ... ng&page=19

However the thread is already over 20 pages long so I though it is easier that way 

Happy Updating

Regards
StarSheep

PS: IMPORTANT: These instructions onyl refer to an UNMODIFIED SU. If you changed your registry setting to a local database you need to change it back to SUPPORTCENTER for SU to work !!!!!!!
Thinkpad T410s -- 8GB of RAM -- 128GB SSD as boot drive -- 500GB Seagate Hybrid HDD with 4GB of SSD Memory as data drive
Paper Tape
Arrow101
Posts: 3
Registered: ‎09-05-2008
Location: South Africa
0

ThinkVantage Systems Update - An error occured while gathering user information

I have just installed the Message Centre Plus Application as the previous version was not working due to Lenovo upgrades to their server. I get the message "An error occured while gathering user information" and it doesnt matter whether i remove the app and reinstall i get the sane error.

 

Can  anyone help?

 

thanks

Punch Card
woofy1
Posts: 13
Registered: ‎08-04-2008
Location: Switzerland
0

T500/Vista Business - ThinkVantage System Update 3 "error collecting user info"

Hi,

I guess this is due to installation of SP2 for Vista; What do I need to know/do in order to make System Update work?

Thanks for your help.

woofy1

Blue Screen Again
shuo3dao4
Posts: 6
Registered: ‎06-01-2009
Location: U.S.A
0

problem with thinkvantage system update

[ Edited ]

As Lenovo brought back system update recently, i use system update to check the new drivers or hotfixs, but the software said an error occured when gathering user information. I never had this problem before when i used the system update. Does anyone know the solution for this problem?

 

Thinkpad t61p

Vista SP2 Business 32bit

 

 

Moderator Note; post moved here from another board in order to prevent multiple threads

Message Edited by andyP on 06-01-2009 11:31 PM
Punch Card
mrbjr
Posts: 3
Registered: ‎04-29-2009
Location: Central Cali
0

Re: T500/Vista Business - ThinkVantage System Update 3 "error collecting user info"

Can't help.....having the same issue.. T400 Vista  SP2
What's DOS?
bianxi
Posts: 1
Registered: ‎06-01-2009
Location: Singapore
0

Re: System Update - An error occurred while gathering user information

This solution works for me. Thanks.