Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Punch Card
nicbex
Posts: 41
Registered: ‎06-28-2011
Location: Sweden
0
Accepted Solution

System update not working X220

According to the log this is where things go wrong:

 

 

Severe2011-08-29 , 11:20:31at Tvsu.Engine.Task.Task.StartExecution()Message: An error occurred while the task: ApplicableUpdatesTask executed the process: HelpCenterQuestProcessthe message from exception isQuest is denied for non-Lenovo systems.Exception:Message: Quest is denied for non-Lenovo systems.Type: Tvsu.Engine.Process.HelpCenterServiceDisableException   at Tvsu.Engine.Task.Task.Start()   at Tvsu.Engine.Task.Task.StartExecution()
Info2011-08-29 , 11:20:31at Tvsu.Gui.CustomComponents.Step.set_Image(StepImage value)Message: Setting FAILED status.
Info2011-08-29 , 11:20:31at Tvsu.Gui.GUIController.ShowErrorMessage(Exception e)Message: Contact Quest is disabled.Exception:Message: Quest is denied for non-Lenovo systems.Type: Tvsu.Engine.Process.HelpCenterServiceDisableException   at Tvsu.Engine.Task.Task.StartExecution()   at Tvsu.Sdk.SuSdk.GetApplicableUpdates(searchingFolderDelegate spd, showErrMsgDelegate sed)   at Tvsu.Gui.Util.ProgressThread.InitSearch()
Info2011-08-29 , 11:20:31at Tvsu.Gui.FlowScreens.Messages.ShowMessage(String message, String title, String mastheadtext, MessageType t, Boolean check, IWin32Window owner)Message: Showing ERROR Message: < The System Update Server is currently unavailable. Please try again later. >

 

 

 

 

 

"Quest is denied for non-Lenovo systems." Obviously, for some reason, it doesn't recognize my system as a Lenovo system. Why, and what can I do to change this? :/

Lenovo Staff
parkerjnc
Posts: 547
Registered: ‎01-16-2010
Location: USA
0

Re: System update not working X220

What version of TVSU are you running?  If it is not v4.01, I would suggest downloading it from here and installing it manaully.

http://support.lenovo.com/en_US/detail.page?LegacyDocID=TVSU-UPDATE

Punch Card
nicbex
Posts: 41
Registered: ‎06-28-2011
Location: Sweden
0

Re: System update not working X220

I am using the 4.01-version. I've tried to reinstall it multiple times, aswell as doing a registry clean in between. Besides Power manager and Communications utility, I don't have any other Thinkvantage technology installed. Is there anything else I need for System update to work?

Paper Tape
Herbo
Posts: 9
Registered: ‎09-02-2011
Location: Hertfordshire
0

Re: System update not working X220

Ah.. glad someone else has posted this.. although I am sorry it's broken for you also..

 

I'm running Windows 7 Enterprise 32bit on a T420. After setting compatibility to XP SystemUpdate runs but then fails with the same error... Apparently my laptop was not made by Lenovo either !

 

Can we have a fix please ?

 

Info 2011-09-02 , 06:07:51
 at Tvsu.Engine.Task.Task.Start()
 Message: Executing the PreProcess HelpCenterQuestProcess

 

Severe 2011-09-02 , 06:07:51
 at Tvsu.Engine.Task.Task.StartExecution()
 Message: An error occurred while the task: ApplicableUpdatesTask executed the process: HelpCenterQuestProcessthe message from exception isQuest is denied for non-Lenovo systems.
 Exception:
  Message: Quest is denied for non-Lenovo systems.
  Type: Tvsu.Engine.Process.HelpCenterServiceDisableException
     at Tvsu.Engine.Task.Task.Start()
   at Tvsu.Engine.Task.Task.StartExecution()

 

Info 2011-09-02 , 06:07:51
 at Tvsu.Gui.CustomComponents.Step.set_Image(StepImage value)
 Message: Setting FAILED status.

 

Info 2011-09-02 , 06:07:51
 at Tvsu.Gui.GUIController.ShowErrorMessage(Exception e)
 Message: Contact Quest is disabled.
 Exception:
  Message: Quest is denied for non-Lenovo systems.
  Type: Tvsu.Engine.Process.HelpCenterServiceDisableException
     at Tvsu.Engine.Task.Task.StartExecution()
   at Tvsu.Sdk.SuSdk.GetApplicableUpdates(searchingFolderDelegate spd, showErrMsgDelegate sed)
   at Tvsu.Gui.Util.ProgressThread.InitSearch()

 

Info 2011-09-02 , 06:07:51
 at Tvsu.Gui.FlowScreens.Messages.ShowMessage(String message, String title, String mastheadtext, MessageType t, Boolean check, IWin32Window owner)
 Message: Showing ERROR Message: < The System Update Server is currently unavailable. Please try again later. >

 

 

Paper Tape
Herbo
Posts: 9
Registered: ‎09-02-2011
Location: Hertfordshire
0

Re: System update not working X220

Looks to me like one of the IA queries is failing.

IA.EXE runs fine by itself with rc=0 but I suspect a specific query is being passed to IA that's coming back invalid.

 

i.e. C:\Program Files\Lenovo\System Update\egather\IA.EXE -query ??

 

I see IA flash up quickly in the process list just before TVSU fails.

 

Just a thought...

 

Paul.

Lenovo Staff
parkerjnc
Posts: 547
Registered: ‎01-16-2010
Location: USA
0

Re: System update not working X220


nicbex wrote:

I am using the 4.01-version. I've tried to reinstall it multiple times, aswell as doing a registry clean in between. Besides Power manager and Communications utility, I don't have any other Thinkvantage technology installed. Is there anything else I need for System update to work?


The only other dependency I can think of is .Net.  What version of .Net do you have?

Punch Card
nicbex
Posts: 41
Registered: ‎06-28-2011
Location: Sweden
0

Re: System update not working X220

I have .NET framework 4 Client Profile. I tried installing the extended .NET 4 but that didn't change anything.

Paper Tape
Herbo
Posts: 9
Registered: ‎09-02-2011
Location: Hertfordshire
0

Re: System update not working X220

[ Edited ]

Can someone, i.e. Lenovo support please help with this thread ?

 

So IA.EXE is running with the following command syntax. It is gathering Local and System Summary and placing it into the file sysrecomin.xml. This all appears valid and shows a valid Lenovo system. I'm assuming this is sent to the TVSU Server which then comes back as invalid/disallowed. Can someone please look into this. This is occurring on more than one systemtype.

 

Logs Attached :-

 

Info 2011-09-06 , 09:38:07
 at Tvsu.Service.Common.CommandExecutor.Executor.ExecuteCommand(String dir, String cmd, String args, String _installType, Int64 timeOut, Boolean hide)
 Message: C:\Program Files\Lenovo\System Update\egather\ ia.exe -filename"C:\Program Files\Lenovo\System Update\egather\sysrecomin" -probes REGIONAL_SETTINGS GATHERER_INFORMATION SYSTEM_SUMMARY -local COMMAND 300000

 

Info 2011-09-06 , 09:38:07
 at Tvsu.Service.Common.CommandExecutor.Executor.ExecuteCommand(String dir, String cmd, String args, String _installType, Int64 timeOut, Boolean hide)
 Message: Hidden

 

Info 2011-09-06 , 09:38:09
 at Tvsu.Service.Common.CommandExecutor.Executor.ExecuteCommand(String dir, String cmd, String args, String _installType, Int64 timeOut, Boolean hide)
 Message: 0

 

Info 2011-09-06 , 09:38:09
 at Tvsu.Service.Client.CommandLauncher.ExecuteCommandLine(String command)
 Message: Command execution duration was: 820 Miliseconds

Lenovo Staff
parkerjnc
Posts: 547
Registered: ‎01-16-2010
Location: USA
0

Re: System update not working X220

This run of IA.exe is not the way TVSU detects if the system is a Lenovo system.  We read a special location within SMBIOS data structures.  Are you using an X220 like the OP? 

Paper Tape
Herbo
Posts: 9
Registered: ‎09-02-2011
Location: Hertfordshire
0

Re: System update not working X220

Hi,

Thanks for the reply. I'm running on the following :-

 

Lenovo T420

Windows 7 32bit

4GB RAM

.NET 3.0, .NET 3.5 & .NET 4.0