Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
redsquirrel
Posts: 6
Registered: ‎03-07-2009
Location: UK
0

L220X - BIOS on DVI

Hi, just bought an L220X and can only get my BIOS and boot messages when using the VGA input on the monitor.  I have an ATI Radeon HD 2600XT which has two DVI ports on it so would like to use DVI input on the monitor.   The first thing I see is the Vista sign in screen.   If I connect the digital output to the VGA connector on the monitor (using an adapter) then I get the boot messages.    The graphics card is clearly outputting the messages but I just cannot see them on the DVI input.

 

Anyone got any ideas

community supermod
erik
Posts: 5,018
Registered: ‎11-23-2007
Location: United States
0

Re: L220X - BIOS on DVI

welcome to the forum!

 

the L220x auto-senses the input source so it sounds like the issue is possibly with your radeon card or your system's BIOS settings.

 

what brand/model of computer are you using?   are there settings in the BIOS to push primary video to DVI or VGA?   if so, make sure it's set on "digital" or "DVI", depending on how it's listed.

 

are you connecting the DVI cable to the primary (most likely labeled "#1") DVI socket on the ATI card?

 

lastly, are you using a DVI-I or DVI-D cable and not a DVI-A cable?   better yet, are you testing using the cable included with the L220x?

ThinkStation C20Microsoft MVP
ThinkPad X1C · X220 · X60T · s30

Punch Card
Diego72
Posts: 46
Registered: ‎02-28-2008
Location: Italy
0

Re: L220X - BIOS on DVI

[ Edited ]

If you see the vista logon screen it seem to be a windows resolution screen issue, altuoght it seem strange to me, because the monitor accept more ore less all the resolutions, but could be a problems of refresh rate.

By the way what monitor did you have befor the l220x?

In any way try load vista in safe mode and then changing the resolution and refresh rate from the safe mode (press f8 during the boot procedure).

Then let us know if this resolve the issue.

                                                                         Diego

 

Perhaps I havn't understood perfectly the issue.

After you see the vista logon screen then do you see the autentichation screen or do you see a black screen?

If you don't see the autentichation screen try unistalling video board software and monitor driver in safe mode.

Then restart the PC and install again video card driver and new monitor driver from lenovo.

Let us know if it works.

 

Message Edited by Diego72 on 03-11-2009 08:31 AM
Fanfold Paper
redsquirrel
Posts: 6
Registered: ‎03-07-2009
Location: UK
0

Re: L220X - BIOS on DVI

Thanks for your reply.   The computer is a Dell XPS 420 using the supplied ATI card.  I was using the DVI cable as supplied with the monitor. 

 

After a load of Googling last night I found the problem is actually a Video BIOS problem and is apparently seen on a lot of different ATI cards.  I have open a problem ticket with ATI - hopefully they have a new BIOS I can push to the card.

 

Here is the relevent article I eventually found on their knowledge base

 

*---------------------------------------------

 

  No Display Through DVI-Port in DOS (BIOS screens, POST, inital startup screens) With Some TFT Monitors:

If there is no display available during boot-up process on the monitor connected digitally to the DVI port and display appears when Windows is loaded, then this issue refers to a Video BIOS problem. Display should be available if an analog monitor is connected directly to VGA port or to DVI using DVI-VGA adapter.

Some users have reported that the display is available through DVI connection if a secondary VGA monitor is connected simultaneously.

    * If you have a partner product (Sapphire, Club 3D, VisionTek, Connect 3d, ASUS, PowerColor, etc.), please contact your board manufacturer.

    * If you have a Built-By-ATI card, please contact AMD Customer Care and one of our qualified support representatives will assist you.

Please see below the KB articles for more information:

737-24059    

ATI FireGL™ V3300: No display with Apple Cinema Display 23" through DVI connection
       

737-24060
   

All-In-Wonder X800 series: No display with Apple Cinema Display 23" through DVI connection
       

737-24062
   

ATI Radeon™ X1900: No Display With TFT Monitors Through DVI Connection
       

737-24684
   

ATI Radeon™ X1600: No display with TARGA Visionary 19-3 TFT monitor through DVI connection
       

737-24924
   

ATI Radeon™ X1950: No Display With Some TFT Monitors Through DVI Connection
       

737-25465
   

ATI Radeon™ X700 Series: No Display with some TFT Monitors Using DVI Cable
       

737-25679
   

ATI Radeon™ X800: No Display With Some TFT Monitors Through DVI Connection
       

737-25681
   

ATI Radeon™ X1300: No Display With Some TFT Monitors Through DVI Connection
       

737-25682
   

ATI Radeon™ 9600: No Display With Some TFT Monitors Through DVI Connection