Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
Fanfoot
Posts: 13
Registered: ‎12-28-2009
Location: Petaluma, CA
0

Can't get the W530 to NOT sleep in ~60 seconds

I'd be happy with a reasonable default of maybe 5 minutes or something, but as it is the laptop is dimming the display in around a minute and then very shortly thereafter requiring a password to unlock the screen.  Sharing my screen during a meeting is simply a pain.

 

I've tried what I think is everything--Control Panel Windows Power Options (maximum performance, advanced options to disable things, or Presentation), the Lenovo Power Manager, the nVidia tray icon, some Intel tray icon thingy, anything I could find that might cause the thing to dim the display.  Clearly haven't found the right place to disable it yet.

 

Obviously as things stand the "Presentation" profile simply doesn't do its job.

 

Tried uninstalling the Lenovo Power Manager.  No change.

 

I've got a W530 2438-2KU with the pre-installed Windows 7 64-bit OS.  I've got the 1920x1080 screen option, an nVidia Quadro 1100M and the Intel HD Graphics 4000.

 

Anybody got an idea?

Guru
ExJamJus
Posts: 1,014
Registered: ‎12-19-2011
Location: Malaysia
0

Re: Can't get the W530 to NOT sleep in ~60 seconds

Try upgrading the Power Management driver and Power Manager. Change settings in Power Manager only. Also try updating the BIOS and see if that helps.
*Non Lenovo employee*

I have a Y2P (i5) ... Feel free to ping me if you want me to test some applications with your Y2P if you have the same model. I don't mind keep doing recovery on it if needed .... =)
Paper Tape
Fanfoot
Posts: 13
Registered: ‎12-28-2009
Location: Petaluma, CA
0

Re: Can't get the W530 to NOT sleep in ~60 seconds

Okay I:

 

Ran ThinkVantage System Update multiple times until nothing came up any more.  Updated BIOS, Power Manager, Power Mangement Driver, all kinds of stuff.  Multiple reboots.  Once when I think it was updating the graphics driver for the NVidia the screen went black and never came back (desktop was black, you could still get the task manager to come up).  Gave up and rebooted, reran System Update and continued from there.

 

No devices show as problems in device manager.  System update says there is nothing to update.

 

Run Lenovo Power Manager.  Switch profile to Presentation.  Hit Apply.  Start timer on phone--45 seconds and the display dims and I have to login again.  Switch to Max Power which has a dim at 5 minutes, 53 seconds or so.

 

Not fixed.

Guru
ExJamJus
Posts: 1,014
Registered: ‎12-19-2011
Location: Malaysia
0

Re: Can't get the W530 to NOT sleep in ~60 seconds

Try this.

http://forums.lenovo.com/t5/W-Series-ThinkPad-Laptops/Disabling-Auto-Screen-brightness-on-Intel-HD-G...

In Power Manager, click advance then check Idle Timers then dim display if is set to "Never".
*Non Lenovo employee*

I have a Y2P (i5) ... Feel free to ping me if you want me to test some applications with your Y2P if you have the same model. I don't mind keep doing recovery on it if needed .... =)
Paper Tape
Fanfoot
Posts: 13
Registered: ‎12-28-2009
Location: Petaluma, CA
0

Re: Can't get the W530 to NOT sleep in ~60 seconds

In Power Manager, Advanced, Idle timers...  Dim display is set to 30 minutes.  Dimmed Display brightness is High (max).  Lower display refresh rate is Never.  Turn off display is set to 60 Minutes.

 

In the Intel Graphics and Media Control Panel, Advanced Mode, Power Panel, On battery (it happens even when its plugged into power), Power Conservation Features I unchecked both Display Refresh Rate Switching and Display Power Saving Technology.

 

No change.  Still blacks out the screen in under a minute.

Guru
ExJamJus
Posts: 1,014
Registered: ‎12-19-2011
Location: Malaysia

Re: Can't get the W530 to NOT sleep in ~60 seconds

mega mega weird ...

Try booting into BIOS and see if it dims after a minute ...

If it doesn't try doing a OS restore using Rescue & Recovery.
*Non Lenovo employee*

I have a Y2P (i5) ... Feel free to ping me if you want me to test some applications with your Y2P if you have the same model. I don't mind keep doing recovery on it if needed .... =)
Community SuperMod
sarbin
Posts: 2,608
Registered: ‎06-26-2008
Location: USA
0

Re: Can't get the W530 to NOT sleep in ~60 seconds

might also be worth trying a Linux Live CD boot to see if this is Windows, or deeper.


English English Community   Deutsche Deutsche Community   Español Comunidad en Español   Русскоязычное Русскоязычное Сообщество
Community Resources: Participation RulesImages in postsSearch (Advanced)Private Messaging
PM requests for individual support are not answered. If a post solves your issue, please mark it so.
Helix X220 X301 X200T T61p T60p Yoga2ProT420 T510 T400 R400 T61 Yoga13
 
I am not a Lenovo employee.
Paper Tape
Fanfoot
Posts: 13
Registered: ‎12-28-2009
Location: Petaluma, CA
0

Re: Can't get the W530 to NOT sleep in ~60 seconds

Booting into BIOS it does *not* DIM after a minute.  Let it go a couple of minutes and nothing.

 

I'm not willing to restore the OS and lose all my program installs.  That's probably on the order of two days of work lost, which I consider to be unacceptable.  You don't have any better answer than that?  I'm only a couple of weeks into using this new laptop.  Its not like we're two years into a Windows install with lots and lots of changes over time...

 

I might be willing to clone the system to another drive and then restore from that.  Just to see if it fixes things as an experiment.  That would only take a few hours.

Paper Tape
Fanfoot
Posts: 13
Registered: ‎12-28-2009
Location: Petaluma, CA
0

Re: Can't get the W530 to NOT sleep in ~60 seconds

I created a USB boot drive using unetbootin and Ubuntu 12.04.1 and booted it.  Let it run a few minutes.  The screen did *not* black out, so its not a hardware problem.  Something in Windows. 

Paper Tape
Fanfoot
Posts: 13
Registered: ‎12-28-2009
Location: Petaluma, CA
0

Re: Can't get the W530 to NOT sleep in ~60 seconds

Disabled the Intel Graphics Adapter (in the BIOS switched to Discrete, disabled NVida Optimus, in Windows disabled the Intel device) and rebooted.  No change.  Since I've now tried disabling both the Intel and NVidia devices on separate boots and it continues regardless I'd say its a common problem, e.g. Windows or Lenovo not something in the individual power management panels for the individual devices.