Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Ctrl-Alt-Del
JonathanChan
Posts: 10
Registered: ‎01-09-2012
Location: Beijing
0
Accepted Solution

Cannot boot w520 when on battery after removing power

Ok, so my w520 boots up when the adapter is connected. if i remove the adapter and keep the battery on, it boots. but if i remove the adapter and battery and then put the battery back on, it wont boot. but after that, if i add the adapter, it revives itself.

 

what is the problem? because i find it annoying if i remove the the battery, the machine wont work anymore and then i  have to get my adapter to revive it

 

heres some information. i spilt water on the keyboard and then wiped it clean but made a mistake and turn it back on thinking it was fine and left the battery in. (there was no adapter at the time) the machine shutdown after a while so i left it off. but i left the battery inside. i spent a day drying it and it ran normal. this is the first probelm ive encountered since

also, ive dropped my laptop a few times, i was wondering if it was the cause of it randomly shutting down (before water incident) when i picked up the laptop, it would just turn off. sometimes if i put it to sleep and carry it around, it wont resume again. all this happens even when adapter is connected

also

when i connect the adapter after the machine isnt able to boot, the battery light flashes a few times before the light turns off. what does that mean

 

so is the motherboard damaged? and about the battery boot problem, is it something inside that damaged or is it the battery?

Serial Port
Al_M
Posts: 26
Registered: ‎02-23-2012
Location: Jacksonville FL

Re: Cannot boot w520 when on battery after removing power

From my experience with W series machines, I would say something must have shorted out when you spilled water on the machine. Although a drop is also capable of destroying an internal component. Honestly this seems like a hardware issue and very difficult to debug online, I would just file a warranty claim. From my experience with Lenovo Warranty they are very prompt and they will probably end up swapping your board if anything.

 

Also, if you have the finger print reader enabled, try to power-on the machine using the finger print reader (Option is in BIOS and Windows) and see if that works, it could just be when you spilled water on the keyboard you ruined the power button and its no longer working properly?. Could just require a keyboard swap. (Takes 2 minutes to do it).

 

Let us know.

Ctrl-Alt-Del
JonathanChan
Posts: 10
Registered: ‎01-09-2012
Location: Beijing
0

Re: Cannot boot w520 when on battery after removing power

3 words for you "you're a genius"

 

i read ur post and checked my power button which i rarely ever use unless im cold booting. it doesnt seem is work although theres the light and everything. and i do remember specifically water going in the power button or it may be the keyboard wire loose. i think i might go get a keyboard replacement.

 

i mean, this is why i post my answers online, i cant think of everything. thanks, ima check if i can fix it

Serial Port
Al_M
Posts: 26
Registered: ‎02-23-2012
Location: Jacksonville FL
0

Re: Cannot boot w520 when on battery after removing power

I'm glad my answer helped you! Yes the LED on the power button would still light up but the contact could very well be shorted causing the button not to work. If you call Lenovo they will send you a keyboard under warranty! Make sure you mark the post as answered so others can find it useful in the community.

 

Al.