Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
fieldhb
Posts: 21
Registered: ‎03-21-2009
Location: Ohio
0

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

Updating the driver seems to have done the trick.

Thank you very much.

The rub is that when one of the help desk techs gave me instructions to download a new driver, he specifically told me not to get the one from intel.

He told me to get the one from lenovo and unload and reload the driver.

This one from intel I just installed over the one that was there.

So I am real disappointed with lenovo help techs.

Thanks again for the link to the driver.

Paper Tape
AlphaGeek
Posts: 3
Registered: ‎05-07-2009
Location: Wyoming
0

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

 I have a bit of a data point that may help this discussion.  Our corporate infrastructure has older Watchguard SOHO access points, most of them are 802.11b.  We use 128 WEP along with static IPs and MAC filtering for security.  I have a whole stack of new T400s here right now that have the Intel cards in them that don't seem to work with our access points.  Symptoms are as follows:

 

1) Laptop connects to access point, but will not pass traffic correctly. 

2) Ping functions, as does tracert.

3) FTP and telnet does not connect to IP that is pingable

4) HTTP does not work in IE nor in Firefox, by either name or number

5) DNS server is pingable, but will not resolve addresses

6) Machines function very well on other access points with the same security configuration

7) Machines work on our company access points with Cisco PCMCIA WiFi cards, as well as LinkSys USB adaptors

 

We had the same issue a while back with Intel ProSet cards.  That issue was "resolved" by sending me twenty some odd WiFi cards that I swapped out.  My productivity and workflow tanked while I did their testing for them and had to open every machine to swap parts.  I see the same thing coming again as I am just now taking these new machines out of the shrink wrap and seeing the same issue as before, only now with the 5100 cards.

 

If anyone has an answer, or a magic bullet, I'm all ears. . .

 

TALON  §

Fanfold Paper
fieldhb
Posts: 21
Registered: ‎03-21-2009
Location: Ohio
0

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

Going to the link below and loading this driver over the current one worked for me:

 

 

 

I have just upgraded the WiFi drivers to version  12.2.0.11 in an attempt to solve the problem.  It's too soon to see if it has solved the problem. 

 

I got the driver from Intel at:

  downloadcenter.intel.com/Product_Filter.aspx?ProductID=3062〈=eng_1";return this.s_oc?this.s_oc(e):true">http://downloadcenter.intel.com/Product_Filter.aspx?ProductID=3062&lang=eng

Paper Tape
AlphaGeek
Posts: 3
Registered: ‎05-07-2009
Location: Wyoming
0

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

Checking for updated drivers is one of the first things I do when a problem presents.  I have tried now with the newest driver from both Lenovo and Intel, Intel's version was 12.4.x.  No joy. 

 

I also have a few diagnostic tools from the previous issue which I ran against these cards.  The data frame size from the cards vary from the 802.11b standard.  This will improve throughput on access points that are compatible, but kill the Rx/Tx on some 802.11b only access points that use a strict adherence to the standard.  It kinda stinks to be on the tail end of the bell curve in technology when vendors are pushing the other end at the expense of the tail.  Ow well, maybe we will get new access points out of this. . .

 

TALON  §

What's DOS?
raghunathi
Posts: 1
Registered: ‎07-23-2009
Location: Pune, India
0

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

This thread saved me.Thanks to accurate documentation by Paul Knight that mentioned every single detail of his experiments.

 

A week back I bought a Sony Vaio SR46GD/B (asia pacific has different numbers) with Intel 5100 wifi chipsets. After the first day of use having completed the painful installation and recovery disk preparation, I found the wireless connectivity was not reliable.

 

I went through the exact same experiences as documented by Paul Knight in this thread. After 3 days of experimentation I was at my wits end having no theory to explain why a wireless interface would drop many HTTP and SMB packets but allow ICMP, SMTP, POP. It was even more baffling since the HTTP packet drops were not consistent. Using wireshark I could see Http syn, syn-ack, syn-ack. But the very next HTTP GET would not receive any response. Many retransmits later the fin/fin-ack/fin-ack sequence would complete. In frustration I concluded I would have to go through a reinstall and see at what step of the initial installation and windows/vaio/norton updates this problem would surface. In my experimentation I also found the problem would temporarily vanish if I made any change to the wifi adapter configuration. That seemed to say there was chance that the driver could also have a bug.

 

I did not expect to get help from unexpected quarters. I googled for "intel wireless 5100 driver http packet drops" and surprisingly hit this thread. The Intel 5100 driver on my Vaio was vers 12.1.0.14. Since Paul had success with 12.2.0.11 driver I decided to upgrade and got the latest driver from the Intel site - which turns out to be 12.4.0.21.

 

For the past two days not since I upgraded the driver, my Vaio works perfectly over the wireless interface. Whew. Thanks Paul.

Paper Tape
AlphaGeek
Posts: 3
Registered: ‎05-07-2009
Location: Wyoming
0

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

I'm glad it worked for you. 

 

Just as an update, I'm still working with this issue.  It has gone from the re-seller, to Lenovo, and now to Intel.  I keep getting test requests and sending logs and getting different requests and sending different logs. . .

 

 I am quite frankly fed up with it.  I am currently using a debug driver to send fin/ack and debug logs showing the problem in bright neon colors to them.  

 

AlphaGeek  §

What's DOS?
Waterboy66
Posts: 1
Registered: ‎08-07-2009
Location: United States
0

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

I just wanted to chime in, especially for those looking for help like I was just a few days ago.  Thanks to this forum, I was able to fix my Intel(R) WiFi Link 5100 AGN Adapter/ Linksys Router WRT54G (Version 8) issue. 

 

I recently purchased a Sony Vaio laptop floor model with the 5100 adapter.  They dropped the price 10%, so I took it.  When I got it home, I powered it up, flipped on the Wireless button but nothing.  In fact it freaked my Linksys WRT54G (Version 8) router out and prevented my wireless G desktop and another wired desktop from connecting to the internet .  I unplugged/replugged the router, all computers could access the internet for about a minute, then the router freaked again.  Well long story short, i found this forum through Google and received some valuable tips to resolve my issue.

 

1. Upgraded to the latest driver on the 5100 adapter.

2. Upgraded to the latest firmware on the WRT54G router. 

3. Changed some setting values on the adapter's configuration Advanced tab.  (I am typing this message from a different computer, so if anyone wants to know what those settings are I can post them if requested)

 

Wala!  I powered up for 4 computer's (3 wireless, 1 wired)  and a Wii.  No lost connectivity.  Momma now sleeps better at night!

Core Memory
SpacemanSpiff
Posts: 14
Registered: ‎11-15-2009
Location: Soo Foo
0

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

[ Edited ]

I have the same problem connecting a new T410 to a BEFW11S4.  Don't tell me to upgrade routers--I already did, and gave the BEFW11S4 to a friend, at whose house I am trying to connect.

 

Since I know my six year old T41 works with both the BEFW11S4 and the new router, and the T410 works with the new router, I know all the equipment is good.

 

The BEFW11S4 uses WPA, no MAC filtering, and DOES broadcast the SSID.  The T410 detects the SSID with 90% strength, but cannot connect.

Paper Tape
steve19569
Posts: 5
Registered: ‎07-10-2014
Location: Seattle, Washington
0

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

[ Edited ]

Could you please provide me with the link to obtain the Intel driver for the Link 5100 AGN?  You can e-mail me at ******@mail.com.  Thank you!!!  Steve

 

Moderator note:  email address removed to keep away from the spambots.

Bit Torrent
Anastasios
Posts: 242
Registered: ‎12-15-2012
Location: United States
0

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router


steve19569 wrote:

Could you please provide me with the link to obtain the Intel driver for the Link 5100 AGN? ... Thank you!!!  Steve


Hi Steve,

 

you haven't told us what type/model laptop you have (there is a 7-digit number on the back of your laptop, to the left of the S/N serial number. Do NOT post the S/N, just the 7-digit "type/model" number.  For example, "4061-B13"). You can supply us with your type/model, but most of these models using Intel wifi link 5100 card (T400, T410, T500, W500, T410, X200, X201) use the same Intel wifi driver.

 

I will point you to the T410 Drivers and Software pagehttp://support.lenovo.com/en_US/research/hints-or-tips/detail.page?LegacyDocID=MIGR-74582.  Scroll down to the "Networking: Wireless LAN" section, and just download the latest Intel driver for your Operating System (Windows XP, VISTA, 7, or 8).

 

Also make sure wireless LAN is enabled in BIOS menu, wireless switch on front or side of laptop is ON, and <FN> + <F5> software control has wireless radio turned ON.

_________________________________________________________
Have a great day. (I do not work for Lenovo)