Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
garycal
Posts: 6
Registered: ‎08-28-2010
Location: Fresno, California
0

Multi-touch screen not recognized

I have a  brand new W510 configured with Windows Ultimate x64.  

 

Within a few hours of running the machine, the touch screen stopped responding.  A reboot fixed that.  This happened several more times, and then rebooting stopped working.

 

Disabling then re-enabling the USB devices was the next step, and that worked for a while (in computer management/device manager/Universal Serial Bus controllers, right-click and select "disable" then right-click and select "enable").  That stopped working last night.  I upped the response to uninstalling ALL of the usb devices under the "Universal Serial Bus controllers", rebooting, and letting Windows 7 x64 re-install them on boot.  Worked a few times, and now that isn't working.

 

I'm starting to think that there is a loose connection internally between the multi-touch device controller for the screen and the USB connector, but all of the other device drivers for the W510/Windows 7 x64 combination seem buggy enough that I can't rule out a really buggy driver.

 

The problem device seems to be listed as an "unknown device" enumerated under the "Universal Serial Bus Controllers" entry in device manager.  Here is a dump of some of the data about that device:

 

{36fc9e60-c465-11cf-8056-444553540000}
{36fc9e60-c465-11cf-8056-444553540000}\0009
Port_#0008.Hub_#0004
\Device\USBPDO-7
{9d7debbc-c85d-11d1-9eb4-006008c3a19a} (bus type guid)
00000008 - address
PCIROOT(0)#PCI(1D00)#USBROOT(0)#USB(1)#USB(8) - location paths
USB\VID_0000&PID_0000\6&94BCF13&0&8 - device instance path
USB\VID_8087&PID_0020\5&43cf376&0&1 - parent
USB\VID_17EF&PID_1003\6&94bcf13&0&5 - siblings
usb.inf:Generic.Section.NTamd64:BADDEVICE.Dev:6.1.7600.20589:usb\unknown - driver node strong name

 


{36fc9e60-c465-11cf-8056-444553540000}{36fc9e60-c465-11cf-8056-444553540000}\0009Port_#0008.Hub_#0004\Device\USBPDO-7{9d7debbc-c85d-11d1-9eb4-006008c3a19a} (bus type guid)00000008 - addressPCIROOT(0)#PCI(1D00)#USBROOT(0)#USB(1)#USB(8) - location pathsUSB\VID_0000&PID_0000\6&94BCF13&0&8 - device instance pathUSB\VID_8087&PID_0020\5&43cf376&0&1 - parentUSB\VID_17EF&PID_1003\6&94bcf13&0&5 - siblingsusb.inf:Generic.Section.NTamd64:BADDEVICE.Dev:6.1.7600.20589:usb\unknown - driver node strong name

Early on I had a problem earlier with the NEC USB 3.0 Host Controller driver, but the Windows 7 troubleshooter fixed that.  Looking at its log, it looks like it also temporarily fixed the problem with the touch screen USB connection, and that was before I took the steps I outlined above.  Here is the output from that:

 

 

 

Intel(R) 5 Series/3400 Series Chipset Family USB Enhanced Host Controller - 3B34 has a driver problem Fixed  

 

There is a problem with the driver for Intel(R) 5 Series/3400 Series Chipset Family USB Enhanced Host Controller - 3B34. The driver needs to be reinstalled. 

Device information 

Name: Intel(R) 5 Series/3400 Series Chipset Family USB Enhanced Host Controller - 3B34 

ID: PCI\VEN_8086&DEV_3B34&SUBSYS_216317AA&REV_06\3&E89B380&0&E8 

Error code: 10 

 

Reinstall device driver Completed 

 

There is a problem with the driver for Intel(R) 5 Series/3400 Series Chipset Family USB Enhanced Host Controller - 3B34. Reinstalling the driver might fix this problem. 

 

 

 

Has anybody else had this problem?  I really don't want to have paid a lot extra for a touch-screen that doesn't have drivers capable of making it work reliably.

Signature goes here.
Fanfold Paper
garycal
Posts: 6
Registered: ‎08-28-2010
Location: Fresno, California
0

Re: Multi-touch screen not recognized

A (very quick) update:  After I posted, I "removed" the device 3B34 and told Windows to uninstall the device driver (all from within Device Manager).  Upon reboot, the touch screen is working again.  I expect it will again fail after an hour or so.  I'm hoping that the "uninstall and remove drivers for 3B34" trick continues to work, but that really isn't the way a new and very expensive laptop should have to be used.  It feels like either buggy drivers or software that wasn't designed exactly the way the drivers expected.

Signature goes here.
Fanfold Paper
garycal
Posts: 6
Registered: ‎08-28-2010
Location: Fresno, California
0

Re: Multi-touch screen not recognized

[ Edited ]

Gets stranger.  The solution I tried only lasted a few minutes.  I just disabled bluetooth (in the "Bluetooth Radios" in Computer management), and the touch screen came back to life.  Might be a coincidence, but another data point.  If (hopefully not when) the touch screen stops working again even with Bluetooth disabled, I'll post.

 

-- EDIT:  That lasted like a minute.  Touch screen again disabled.  

Signature goes here.
Fanfold Paper
garycal
Posts: 6
Registered: ‎08-28-2010
Location: Fresno, California
0

Re: Multi-touch screen not recognized

And the laptop just died.  Won't get past the splash screen.  "ThinkVantage" button won't take it into recovery mode.  F1 won't get it into bios, etc.  Looks like a defective motherboard.  More trouble than its worth.  I'm returning it for a refund.

Signature goes here.
Punch Card
petercf
Posts: 6
Registered: ‎02-21-2010
Location: Washington
0

Re: Multi-touch screen not recognized

I had a very similar experience. After updating all drivers, multi-touch would work and then stop.

 

Here are a couple of observations. The USB issue that you are describing turned out to be a defective internal camera. I am not sure whether it is related to the screen or not.  Lenovo support had me run the full diagnostic and that is when I saw the camera was not being recognized.  I have "on-site next day" so Lenovo replaced both the camera and the multi-touch panel (fyi, they initially shipped the wrong panel so make sure they ship you the correct one.)

 

Take heart. After replacement, the machine works better than it did when it first shipped. The replacement screen seem much better than my first one. I also suspected that it was a cabling problem but you have to open up the entire machine to get at it and I would just let Lenovo deal with it.

 

There is a posting problem if certain devices are connected to the left side (blue) USB ports. Laptop will not post to get to ThinkVantage diagnostics. In my case it was a logitech mouse USB receiver that will only work on startup if placed in the back USB port (with NEC driver update installed from support website.)

Fanfold Paper
garycal
Posts: 6
Registered: ‎08-28-2010
Location: Fresno, California
0

Re: Multi-touch screen not recognized

Thanks for this information.

 

I purchased 3 years of next day on-site support, but when I called in today, they had no record of it, and could only offer to send a box to me so I could send it in for depot service.  Not the kind of thing that inspires confidence.  I called in with the intent of getting it repaired, but the problem with not giving me the on-site warranty service that I paid for has me planning to just return the unit rather than jump through a bunch of hoops trying to get them to update my file so that I get the repair service I paid for.

 

I was unable to get it past POST in these configurations:

Booting with the power supply plugged in and the battery installed, plus hard drive and CD ROM, but with no other devices plugged in;

Booting with the battery only, plus hard drive and CD ROM;

Booting with battery only, plus hard drive and no CD ROM;

Booting with battery only, plus no hard drive and no CD ROM (so seeing if I can get to BIOS)

Booting with all of the above combinations with and without various devices plugged into the USB ports.

Swapping out the RAM modules to see if it was bad RAM.

I couldn't get it to POST in any of the combinations I tried.  Just the flash screen and nothing more.

 

I never tried the camera, although I ran the diagnostics (I must have missed the portion where the camera is tested).  I would like to use the laptop, but I'm not willing to ship it off for a week in the hopes that they'll fix it (that was kind of the reason why I paid for the on-site next day service that seems to have been lost in their system).  So I'm sending it back Monday unless something surprising happens, like Lenovo apologizes for this very annoying warranty mistake and gets somebody onsite ASAP to fix it.

 

In any event, thank you for the feedback.  Based on what you wrote, if I could get it to boot, I think I could fix it (or at least isolate the cause).  But its just plain not booting.

 

Signature goes here.
Punch Card
petercf
Posts: 6
Registered: ‎02-21-2010
Location: Washington
0

Re: Multi-touch screen not recognized

[ Edited ]

Lenovo did not initially show that I had 4 yr. on-site either. It magically appeared on their website about two weeks after the system arrived. Sorry about your cr@! experience! I have had a love/hate relationship with this W510. Now that it is working, we seem to have reconciled and are no longer sleeping in separate rooms.

 

PS Fn + F6 will show a dialoge that lists the camera settings at the top. If you do not see them then the camera is DOA.

Fanfold Paper
garycal
Posts: 6
Registered: ‎08-28-2010
Location: Fresno, California

Re: Multi-touch screen not recognized

I would have loved to try the Fn + F6 test, but the machine stopped getting past POST, so I can't even get to the BIOS.  The machine just gives the feel that the bios and a lot of the drivers were pushed to production too early, and still behave a bit like beta-phase software.  My plan is to return the W510 (which I really liked for the few moments it was working) and wait probably six months, then order it again.  By then I hope they will have the drivers and bios issues corrected.  There may also be hardware issues (they had trouble with long ship dates, so I wouldn't be surprised if some of the hardware was also not ready for mass production).  Either way, six months is plenty of time for Lenovo to get it all together.

 

You would think that this experience would sour me on Lenovo, but (absent some surprise in the refund process), I have to say that Lenovo handled this very well.  They apologized, acknowledged that in my position they might well feel the same way, took responsibility for the problem (including paying for return shipping and arranging UPS pickup) and promised a full refund.  They treated me like they view customers as assets, not annoyances.  Despite my bad experience with the hardware, my experience with the company was sufficiently positive that overall, my chances of order from them again are higher now than they were before this incident.

 

So bad copy of the hardware, or possibly unstable drivers and bios, plus good customer service and taking responsibility for their mistake = increased customer loyalty.  I'm glad Lenovo understands the formula.  Now I just hope my aging T61 holds out long enough for me to order a W510 *after* they work the bugs out.

Signature goes here.