Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
grantallenbrown
Posts: 9
Registered: ‎04-11-2011
Location: US
0

Restart Quirky with W520 and Intel 510 SSD

[ Edited ]
I just received my new W520 and installed a new Intel 510 SSD. I did a clean reinstall of windows 7 64 bit and everything appeared to be working flawlessly until I attempted to "restart". Restarting will hang indefinitely but, strangely, if I do a complete shutdown an then power it up from a shutdown state, it boots fine. If I attempt a restart, and wait for it for a long period of time, it appears to hang on one of two issues, thinkpad active protection diagnostics or an intel boot agent error. I have reseated the new drive 3 times and reinstalled windows twice to no avail. Smells like a bios issue to me?!? Maybe. Firmware update on it's way to solve this? My thoughts were that either there is somethIng in the BIOS that is messed which I can't troubleshoot or that the BIOS is attempting to boot from a LAN or other network source despite the settings telling it otherwise. Anyone else having this issue and if so how did you solve it?!? Thanks, I am at the end of my rope here...
Bit Torrent
ThorsHammer
Posts: 2,400
Registered: ‎04-08-2011
Location: USA
0

Re: Restart Quirky with W520 and Intel 510 SSD

[ Edited ]

Removed link to thread about sandforce controller based SSD's since they are unrelated.  My bad.

Fanfold Paper
grantallenbrown
Posts: 9
Registered: ‎04-11-2011
Location: US
0

Re: Restart Quirky with W520 and Intel 510 SSD

Thank you, looks like I need to do a bit more waiting. I am going to try another drive, hopefully it is just a bad ssd, I am bummed because I would have figured that an intel drive would be compatable.
802.11n
Volker1
Posts: 334
Registered: ‎03-02-2010
Location: Dublin
0

Re: Restart Quirky with W520 and Intel 510 SSD

 


ThorsHammer wrote:

This is starting to sound familiar.  See http://forum.notebookreview.com/lenovo-ibm/568718-sf-1222-ssd-dont-play-nice-t420.html


 

The Intel 510 ssd uses the Marvell 88SS9174 controller, so any SandForce-controller issues are completely unrelated.

Token Ring
Q-Ball
Posts: 208
Registered: ‎11-08-2010
Location: BC, Canada
0

Re: Restart Quirky with W520 and Intel 510 SSD

You have another computer to test the SSD on?
Fanfold Paper
grantallenbrown
Posts: 9
Registered: ‎04-11-2011
Location: US
0

Re: Restart Quirky with W520 and Intel 510 SSD

I do and will give it shot before I RMA the drive but it seems strange that the Intel SSD toolbox says the drive is functioning properly. I could be wrong here, as happens more often than not, but I think that there is something wrong with the drive and a new one will magicially solve the problem or, more likely, there is an issue with the bios or motherboard that is preventing the laptop from seeing the drive on restart. It seemed to be a well known issue on the sandforce based drives but I didn't think that the intel ssd's were seeing the same issue. There are some reviews with me exact configuration so I would guess it is compatible.
Bit Torrent
ThorsHammer
Posts: 2,400
Registered: ‎04-08-2011
Location: USA
0

Re: Restart Quirky with W520 and Intel 510 SSD

Is this just on restarts?  Does it behave properly on shutdowns?

802.11n
Volker1
Posts: 334
Registered: ‎03-02-2010
Location: Dublin
0

Re: Restart Quirky with W520 and Intel 510 SSD

 


grantallenbrown wrote: [...] an intel boot agent error.

FWIW, if you disable booting over LAN in the bios (not just change the boot order), then the intel boot agent message does not show up.

 

Fanfold Paper
grantallenbrown
Posts: 9
Registered: ‎04-11-2011
Location: US
0

Re: Restart Quirky with W520 and Intel 510 SSD

It only happens on a restart, shutdown and cold start up works fine. As for the bios setting, good call Volker, I removed all the boot sources except cd and hard drive and the boot agent warning went away, or at least it no longer shows up, just the thinkpad diagnostics error and a never-ending hang. I also disabled/unprovosioned intel AMT since I don't need it but that didn't change things.
Fanfold Paper
grantallenbrown
Posts: 9
Registered: ‎04-11-2011
Location: US
0

Re: Restart Quirky with W520 and Intel 510 SSD

Okay, same issue on a brand new Intel 510 SSD (toolbox says it is running fine too). Anyone else having the same issue? is there anyway to submit this directly to Lenovo? I have tried about every possible config setting in the BIOS to no avail. The only bread crumb I have is that if the boot is set to UEFI only the system can't find the SSD at all. If I set it to UEFI/Legacy or just Legacy at least I can do a cold boot. PLEASE HELP!!!!