Support in other languages: 
Reply
RAID Mirror
PanEuropean
Posts: 488
Registered: ‎02-17-2009
Location: Vancouver Island
0

Re: Temporary but DAILY mouse / system freezing (W500 w/ Vista Business 32)

Three days later, and I have observed something very interesting:  the mouse freezes now directly correlate with opening and closing new windows - either opening or closing applications, or opening or closing non-modal windows within applications.

 

This leads me to believe that perhaps the solution might have something to do with the display driver.  For what it is worth, I have my BIOS settings set at "default" with the single exception being the display, which I have set to the discrete graphics (speedy graphics) card only.  I am using the version 8.520.4.5000 ATI driver.  I note that this driver has a different version number than the ATI display driver available from Lenovo at the DDFM, which is 8.52.4.5-081002a-070479C.  Whether this difference in numbering means anything or not I do not know.

 

I am going to fool around with the ATI display settings - beginning by trying to set them back to default in every way - and see if that makes any difference.

 

Michael

W520 (4270 CTO), which replaced a W500 (4062-27U), which replaced a T42P, which replaced an A21P...
RAID Mirror
PanEuropean
Posts: 488
Registered: ‎02-17-2009
Location: Vancouver Island
0

Re: Temporary but DAILY mouse / system freezing (W500 w/ Vista Business 32)

I installed Adobe's 8.1.4 update to Acrobat (I have the full version, Acrobat Pro) yesterday morning, and surprise - surprise, have not had a single mouse freeze during the past two days (about 20 hours) of work.

 

Looking back on this, it kind of makes sense - the mouse often was freezing up when Acrobat was running.

 

This particular update came to me by 'push' (Adobe's resident updater), but you can get it at the Adobe Updates site.

 

Let me know if this does the job for you guys.  In particular, let me know what version of Acrobat you have had installed in the past, when you have encountered all the freezes.

 

Michael

W520 (4270 CTO), which replaced a W500 (4062-27U), which replaced a T42P, which replaced an A21P...
RAID Mirror
PanEuropean
Posts: 488
Registered: ‎02-17-2009
Location: Vancouver Island
0

Re: Temporary but DAILY mouse / system freezing (W500 w/ Vista Business 32)

I think I finally figured out the mouse freeze business.  I had thought that the Adobe Update solved it, but the freeze came back.

 

Now, I think that my problem was caused by using the wrong version of the Intel Turbo Memory driver and the Intel Matrix storage manager driver.  I had installed drivers I got directly from Intel that were a higher version than the drivers available from the Lenovo DDFM.  I removed the Intel drivers and re-installed the Lenovo distributed drivers, and now the freezes have been gone for 2 full days.

 

There is a post elaborating about the correct Intel Matrix drivers to use at this link: Turbo Memory, Matrix Driver

 

Let me know if this works for you.

W520 (4270 CTO), which replaced a W500 (4062-27U), which replaced a T42P, which replaced an A21P...
Punch Card
TechMarketer
Posts: 27
Registered: ‎12-20-2008
Location: Montreal, Canada
0

Re: Temporary but DAILY mouse / system freezing (W500 w/ Vista Business 32)


PanEuropean wrote:

I think I finally figured out the mouse freeze business.  I had thought that the Adobe Update solved it, but the freeze came back.

 

Now, I think that my problem was caused by using the wrong version of the Intel Turbo Memory driver and the Intel Matrix storage manager driver.  I had installed drivers I got directly from Intel that were a higher version than the drivers available from the Lenovo DDFM.  I removed the Intel drivers and re-installed the Lenovo distributed drivers, and now the freezes have been gone for 2 full days.

 

There is a post elaborating about the correct Intel Matrix drivers to use at this link: Turbo Memory, Matrix Driver

 

Let me know if this works for you.


 

PanEuropean, I just checked my driver version in Device Manager and I see that all along I've been using the recommended 8.6.3.1004 version on my W500.  So I sure hope this driver stops your freezes, but unfortunately for me it hasn't stopped my freeze ups.

 

Also, my Adobe software is up to date as well...

 

I appreciate your continuing efforts to figure out what's causing our very strange and seemingly unexplainable system freeze ups.  I'm also closely monitoring the situation at my end for any changes, so if I come up with anything new at all to report, I'll be sure to post back here.

 

Keep up the good work, I know we'll get to the bottom of this eventually! :smileyhappy:

___________________________________________________
ThinkPad W500, Intel Core 2 Duo T9400, Vista Business SP2 , ATI FireGL V5700, ATI CCC (2009.0401.1328.22301), Switchable Graphics (8.563.2.1-090401a-079160C-Lenovo)
RAID Mirror
PanEuropean
Posts: 488
Registered: ‎02-17-2009
Location: Vancouver Island
0

Re: Temporary but DAILY mouse / system freezing (W500 w/ Vista Business 32)

TechMarketer:

 

Please check your Power Manager software and see what version you are running.  You can do this by clicking on the battery icon in the taskbar, then clicking the small green question marl / down arrow in the upper right of the Power Manager screen.

 

I just upgraded from 2.38 to 2.4.2 (available here ), and so far, no freezes.  It is still a bit early to tell, I don't want to claim victory yet, but the initial signs are encouraging...

 

Michael

W520 (4270 CTO), which replaced a W500 (4062-27U), which replaced a T42P, which replaced an A21P...
Punch Card
TechMarketer
Posts: 27
Registered: ‎12-20-2008
Location: Montreal, Canada
0

Re: Temporary but DAILY mouse / system freezing (W500 w/ Vista Business 32)

Michael, I also have the updated Power Manager 2.42 installed, which I remember upgrading to last week, just like you did.  And guess what -- no freeze ups for me since then.  Now I've only had the chance to use my ThinkPad for just 1 day (yesterday only) since that update, but it still does look promising as I haven't had a single freeze up in 12 hours of continued use.

 

I noticed you posted your last message here on 4/08.  Have you experienced any freeze ups since then?


You know, it'll be music to my ears if you can post back here saying that you've had no freezes in the last 5 days since upgrading to Power Manager's latest version...

 

 

___________________________________________________
ThinkPad W500, Intel Core 2 Duo T9400, Vista Business SP2 , ATI FireGL V5700, ATI CCC (2009.0401.1328.22301), Switchable Graphics (8.563.2.1-090401a-079160C-Lenovo)
RAID Mirror
PanEuropean
Posts: 488
Registered: ‎02-17-2009
Location: Vancouver Island
0

Re: Temporary but DAILY mouse / system freezing (W500 w/ Vista Business 32)

I have not had any mouse freezes for over a week now.

 

However, I did make some changes to my video setup around the same time.  So, if you encounter mouse freezes again, after having changed to that new power driver, let me know and I will post the details of the video changes that I made.

 

Michael

W520 (4270 CTO), which replaced a W500 (4062-27U), which replaced a T42P, which replaced an A21P...
RAID Mirror
PanEuropean
Posts: 488
Registered: ‎02-17-2009
Location: Vancouver Island
0

Re: Temporary but DAILY mouse / system freezing (W500 w/ Vista Business 32)

Tech Marketer:

 

After working for quite a few days now with the current configuration, I have determined that there is a very clear correlation between operating with one external display (via DVI) operating and the laptop in the docking station with the lid closed (I still get the odd mouse freeze), and operating in exactly the same configuration but with the laptop lid open and an extended display running on the laptop panel (never, ever a mouse freeze).

 

Hence, I think the cause of the problem has something to do with the video display portion of the computer.

 

I don't know enough to comment further than this, but I have determined with absolute certainty that if I have the laptop lid open and the extended display operating on the laptop panels, I have no freezes, ever.  If I want freezes, all I have to do is close the laptop panel (which turns off the display on the panel).

 

Michael

W520 (4270 CTO), which replaced a W500 (4062-27U), which replaced a T42P, which replaced an A21P...
Punch Card
TechMarketer
Posts: 27
Registered: ‎12-20-2008
Location: Montreal, Canada
0

Re: Temporary but DAILY mouse / system freezing (W500 w/ Vista Business 32)

Well, 1 week has passed since my last post and I'm pleased to report that I no longer experience any freeze ups whatsoever.

 

Michael, interesting observation you made about getting the occasional freeze when closing the laptop lid. If in fact it is a video display problem, hopefully future ATI driver updates will successfully resolve this issue.

 

By the way, I'm following this thread for any news of a modded ATI V5700 driver to be made available for the W500.  Not exactly sure what to expect from any such release, but I have a feeling this updated driver will resolve several key issues.  It should perform as well (and most likely a lot better) than the current ATI display driver in our laptop.

___________________________________________________
ThinkPad W500, Intel Core 2 Duo T9400, Vista Business SP2 , ATI FireGL V5700, ATI CCC (2009.0401.1328.22301), Switchable Graphics (8.563.2.1-090401a-079160C-Lenovo)
RAID Mirror
PanEuropean
Posts: 488
Registered: ‎02-17-2009
Location: Vancouver Island
0

Re: Temporary but DAILY mouse / system freezing (W500 w/ Vista Business 32)

I have been using the ISV video driver that is available from this link (click here) for the last week, and I am very happy with it.  I no longer have to keep the laptop lid open and the second display running, and I don't have any mouse freezes anymore.

 

When you go to that page, be careful what driver you pick.  The most recent one is at the bottom of the list (a bit of a contravention of normal practice), and there are different versions for various operating systems.  

 

Michael 

W520 (4270 CTO), which replaced a W500 (4062-27U), which replaced a T42P, which replaced an A21P...