Support in other languages: 

ThinkPad W520 microphone troubleshooting

0
Helpful?
Click ►
Started ‎02-12-2012 by
Modified ‎02-12-2012 by
(26,458 Views)

ThinkPad W520 microphone troubleshooting

Question

The mic in W520 is poor for any voice recording. (Skype, etc...).   I went into the Control Panel and was able to find the SmartAudio HD drivers for the built-in mic.  Uninstalled it and rebooted.  Somehow, after the reboot, the Conexant SmartAudio driver is right back.  There are no VOIP settings or anything.   Not sure if the Conexant driver is the default Win7 driver?    How do I fix the bad mic?     

 

Answer

This applies to any ThinkPad E/W/T/X/Xt/L/R/SL#10 or #20 Series with Conexant Sound Card. (# represent screen size, e.g. 5 = 15")

1. Disable Microphone / VoIP optimization

 

Go to Sound > Control Panel > Sound > Manage Audio Devices.

 

Select recording tab, click on Microphone, then Properties.

 

Select Enhancement tab, check Disable all enhancements / sound effects. This will disable all Windows and Conexant optimization in SmartAudio Control Panel.

 

2. Disable Listen to this Device

 

Go to Sound > Control Panel > Sound > Manage Audio Devices.

 

Select recording tab, click on Microphone, then Properties.


Select Listen tab, uncheck Listen to this device. (This option can be checked / enabled if connected with external speakers / headphones, as the internal mic and speakers are too near to each other, causing a lot of feedbacks)

 

3. Increase microphone sample / depth rate


Go to Sound > Control Panel > Sound > Manage Audio Devices.

 

Select recording tab, click on Microphone, then Properties.

 

Select Advanced tab, change to the highest Bits and Hz as possible for default sample rate / bits.

 

4. Fine-tune microphone volume level

 

Go to Sound > Control Panel > Sound > Manage Audio Devices.

 

Select recording tab, click on Microphone, then Properties.

 

Select Levels tab

Recommended Range of settings:

Microphone: 50 - 100

Microphone Boost: +10dB

 

If this does not correct the problem, you might check the Microsoft audio troubleshooter here it includes diagnositics, automated fix it solutions, and proceedural guidance on other common configurations issues.


Comments
by drewwesley on ‎07-09-2012 11:23 PM

Try the Realtek High Defintion Audio Driver for Windows 7 package on the ThinkPad W530 Drivers and Software page, it works well for the W520 too.

 

by xcln on ‎02-15-2014 01:46 PM

Excellent - indeed making sure the Enhancements are turned OFF (unchecked) did the trick.

 

For W500, X200, X200 Tablet .. 

 

More specifically:

 

Maybe uninstall/ reinstall the driver;  make sure that the internal microphone "Enable  audio enhancements" choice is NOT checked n Advanced Properties

General (nothing)
Listen:  Listen to this device NOT checked Playback: Speakers (Conexant 20561 SmartAudio HD) / Device Detection (Checked) Do not prompt when device is plugged in
Levels: set high enough
Advanced: 2 channel, 16 bit 44100 CD quality
Allow apps to take exclusive control YES, checked
Give exclusive mode app priority YES checked
Enable audio enhancements  NO unchecked
 

 

Realtek: not a good idea, if it works, it's probably because it defaults to a generic driver wthout said enhancements.

With the Lenovo downloads for the Conexant driver, I saw it required .Net framework 3.5 and 3.5 SP1 to be installed prior to installing the drivers.  Well, these .Net Framework couldn't install, just as well, they are not the issue (at least not now, Fev 2014). I noticed I had  the .Net client framework 4.0 installed (all this on 64bit Windows 7 Pro)

 

Contributors