Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Ctrl-Alt-Del
apples3991
Posts: 9
Registered: ‎03-22-2011
Location: Rochester, NY
0

W520 Booting directly into ThinkVantage Repair

I am having this problem with one of my W520 series Thinkpad Laptops.  When I start up the computer, instead of booting Windows 7, it boots directly into the ThinkVantage Technologies repair utility.   It scans the computer looking for a start up error, says "Windows cannot repair this computer automatically" and gives the message:

 

"If you have recently attached a device to this comptuer, such as a camera or portable music player, remove it and restart your comptuer.  If you continue to see this message, contact your system administrator, or run Lenovo Product Recovery."

 

There was a mouse attached, however it was removed before the next restart and yet, every time I try to start the computer, it sends me straight back to this, over and over.  I have tried to boot into safe mode and I can't even get to that splash screen, it just boots directly into this recovery mode.  I cannot roll the comptuer back because there is quite a lot of data that has be added to the computer between the current time and the last possible roll-back time and I really cannot lose that data.  I can boot to a CD, however that also does not do me much good because a Windows 7 cd only does the same thing the Lenovo recovery tools can do (command line, startup repair, etc.). 

 

So I am unsure what to do at this point and am hoping somebody has come across this issue and has been able to fix it.  I've tried googling and such but that hasn't reallly turned up anything.

Token Ring
Jimm98y
Posts: 67
Registered: ‎07-25-2008
Location: Czech Republic
0

Re: W520 Booting directly into ThinkVantage Repair

[ Edited ]

I've come across the same issue with a USB 3.0 SAS HDD from WD connected to the computer. I don't have Lenovo Rescue and Recovery, so instead of booting into Lenovo repair tools, it boots into Windows 7 Recovery environment. When I disconnect the HDD, it boots normally into Windows. Link to the issue: http://forums.lenovo.com/t5/W-Series-ThinkPad-Laptops/W520-won-t-boot-when-docked-in-mini-dock/td-p/... (Note: the USB HDD is encrypted using BitLocker2Go)

 

There is no workaround except disconnecting the external HDD before turning the computer on. Maybe your issue is caused by something else, but the symptoms you described here are definitely the same.

Lenovo ThinkPad W520 15.6" 1920x1080, UEFI 1.42, Intel Core i7-2820QM 2.3GHz, Intel HD3000 + nVidia Quadro 2000M 2GB, Kingston PNP 16GB (4x4GB) 1600MHz RAM, Crucial m4 040H 256GB SSD, Lenovo TP Drive Adapter UltraBay 12,7mm + WD Blue 1TB 5400rpm HDD, Intel Centrino Ultimate-N 6300 AGN, Gobi 3000, Lenovo TP Port Mini Dock Plus Series 3, Windows 8.1 Pro 64bit
B82
What's DOS?
B82
Posts: 1
Registered: ‎09-30-2011
Location: Germany
0

Betreff: W520 Booting directly into ThinkVantage Repair

Hi apples3991,

 

I just ran ito the same issue, being unable to boot a regular Windows 7 on my ThinkPad L520. Instead, my laptop always boot into the "Repair Computer" option. Did you find a solution for this problem or at least its origin?

 

Best regards,

Borys

Ctrl-Alt-Del
apples3991
Posts: 9
Registered: ‎03-22-2011
Location: Rochester, NY
0

Betreff: W520 Booting directly into ThinkVantage Repair

Hello Borys,

 

I believe what I ended up doing was just pulling an image down that I took earlier.  My experience was in an environment where there were multiple Thinkpad W520 so on one of them, I made a base image of what I needed and then using an Altiris Deployment Solutions server, I Ghosted an image of that machine so I could drop it onto the other machines.  What I ended up doing was just re-imaging the machine and starting from scratch.