Support in other languages: 
Reply
Punch Card
JazJon
Posts: 58
Registered: ‎08-07-2011
Location: San Francisco
0

W520 (Windows 7 Clean Install) "A required CD/DVD drive device driver is missing. If you have a driv

[ Edited ]

I wanted to do a clean install of Windows 7 Ultimate x64.   I always install windows off my USB drive.  The USB flash drive was created using http://wintoflash.com 

 

I press F12 when I first turn on the W520, and boot off the USB

 

Windows 7 setup loads, I click next, and it says:

 

 "A required CD/DVD drive device driver is missing. If you have a driver floppy disk, CD, DVD, or USB Flash drive, please insert it now"

 

What drive is missing?  Usually Windows 7 let's you install no problem unless some funky non supported drive controller is not supported by default.

 

I checked out Lenovo's page explaing how to install Windows 7 from scratch and it makes no mention of having to manually load a driver.

http://support.lenovo.com/en_US/guides-and-manuals/detail.page?DocID=UM006576

 

Any ideas?   Do I need to burn and use a real DVD to install?  I never had to in the past before on other machines.

Bit Torrent
ThorsHammer
Posts: 2,400
Registered: ‎04-08-2011
Location: USA
0

Re: W520 (Windows 7 Clean Install) "A required CD/DVD drive device driver is missing. If you ha

You might want to try a more official tool like http://www.microsoftstore.com/store/msstore/html/pbPage.Help_Win7_usbdvd_dwnTool

 

There are also tools and techniques in the Windows 7 Deployment Toolkit (MDT) that will will build a proper USB stick.

Punch Card
JazJon
Posts: 58
Registered: ‎08-07-2011
Location: San Francisco
0

Re: W520 (Windows 7 Clean Install) "A required CD/DVD drive device driver is missing. If you ha

I tried my friends USB stick that was manually built with the disk part commands etc.    I get the same results with the required drive device driver is missing.   What's up with that?  I guess I'll try to burn a real DVD and see if it does the same thing.

Bit Torrent
ThorsHammer
Posts: 2,400
Registered: ‎04-08-2011
Location: USA
0

Re: W520 (Windows 7 Clean Install) "A required CD/DVD drive device driver is missing. If you ha

This isn't the first time I've seen this reported.

 

When you go into the BIOS, what do the boot options look like?

Punch Card
JazJon
Posts: 58
Registered: ‎08-07-2011
Location: San Francisco
0

Re: W520 (Windows 7 Clean Install) "A required CD/DVD drive device driver is missing. If you ha


ThorsHammer wrote:

This isn't the first time I've seen this reported.

 

When you go into the BIOS, what do the boot options look like?


 

Here's a video I just uploaded:

http://www.youtube.com/watch?v=Kwy8GEy21e4

Punch Card
kmonchamp
Posts: 30
Registered: ‎07-08-2011
Location: United States
0

Re: W520 (Windows 7 Clean Install) "A required CD/DVD drive device driver is missing. If you ha

I was getting that when I was installing from a usb cd drive. I beleive that it was the USB 3 ports that it didn't like and used one of the two usb 2 ports and it had no problems.

Punch Card
JazJon
Posts: 58
Registered: ‎08-07-2011
Location: San Francisco
0

Re: W520 (Windows 7 Clean Install) "A required CD/DVD drive device driver is missing. If you ha

[ Edited ]

Well I could never get the USB version of Windows 7 x64 Ultiamte to install on the W520.   I tried all usb ports. 

 

The DVD version works, but I'm not sure why the USB version does not.   The USB version worked on 2 other non thinkpad laptops recently as well!

Guru
ColonelONeill
Posts: 6,377
Registered: ‎12-26-2009
Location: Toronto
0

Re: W520 (Windows 7 Clean Install) "A required CD/DVD drive device driver is missing. If you ha

I've seen this happen on a SONY with USB 3.0. No clue why. Tried feeding it all sorts of SATA drivers at that stage too, but never thought to give it USB 3.0 drivers.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Punch Card
JazJon
Posts: 58
Registered: ‎08-07-2011
Location: San Francisco
0

Re: W520 (Windows 7 Clean Install) "A required CD/DVD drive device driver is missing. If you ha

Yeah I was using the USB 2.0 ports, maybe the fact it has USB 3.0 period is confusing the installation?  I should have tried disabling USB 3.0 from BIOS durring install if that is an option.    I'm just curious at this point for the future of what to do for USB installs on Thinkpads with USB 3.0
Guru
ColonelONeill
Posts: 6,377
Registered: ‎12-26-2009
Location: Toronto
0

Re: W520 (Windows 7 Clean Install) "A required CD/DVD drive device driver is missing. If you ha

Maybe try putting the Renesas USB 3.0 driver on a USB drive and giving it to the setup when it asks?

It didn't matter whether I used an USB 2.0 (eSATAp) or USB 3.0 port with the SONY, kept asking for it. I just ended up bootstrapping the install out of the preload system.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase