Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Blue Screen Again
ph-klein
Posts: 4
Registered: ‎05-03-2012
Location: Germany
0
Accepted Solution

W520 webcam not working

Hi everyone,

 

i recently bought my W520 and everything works just fine - except for the internal webcam.

 

I installed the drivers (current version) from the Lenovo web site but the webcam won't turn on. The green just wouldn't turn on and when I press Fn+F6 the communication tool shows up without any webcam video. Same thing for skype or any other webcam tool.

 

Sometimes after booting it works for a few seconds but then the image freezes and it won't start again until after several system restarts.

 

As indicated on google I installed the generic Microsoft driver but that does not seem to solve the problem.

 

Does anyone know what to do? Your help is much appreciated!

 

Regards, Phil

 

System Details:

Thinkpad W520 (4276), Core i7-2760QM

Windows 7 64 Bit Professional

tanujhanda
Posts: 955
Topics: 3
Kudos: 80
Solutions: 65
Registered: ‎01-05-2010
Location: INDIA
0

Re: W520 webcam not working

Hello ph-klein and welcome to community,

 

Kindly uninstall the installed camera driver and software then restart the laptop, update the BIOS

BIOS Update Bootable CD

README for BIOS Update Bootable CD

 

"OR"

Windows BIOS Update Utility

 

 

 

Then install ThinkVantage Communications Utility and after this install Integrated Camera Driver

 

 

Best Regards,

Tanuj


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Blue Screen Again
ph-klein
Posts: 4
Registered: ‎05-03-2012
Location: Germany
0

Re: W520 webcam not working

Tanuj,

 

thank you for the welcome and your reply. I tried to update the BIOS but the Windows tool told me that no update was required. I checked the BIOS screen, installed version is 8BET56WW (1.36) which is the current version on the Lenovo web site. 

 

Attached you find a photo taken during one of the short moments the webcam is actually working. I'm pretty much concerned about the color errors. Might this be a hardware fault?

 

Best regards,

Phil

 

WebcamFault.jpeg

tanujhanda
Posts: 955
Topics: 3
Kudos: 80
Solutions: 65
Registered: ‎01-05-2010
Location: INDIA
0

Re: W520 webcam not working

Hi Phill,

 

Can you reinstall the Windows and check else if the laptop is in warranty then you need to contact the support center.

 

 

Best Regards,

Tanuj


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Guru
ColonelONeill
Posts: 6,784
Registered: ‎12-26-2009
Location: Toronto
0

Re: W520 webcam not working

I'd try a bootable Ubuntu CD. If it has drivers for the webcam, then you can confirm whether or not it's a hardware issue.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Blue Screen Again
ph-klein
Posts: 4
Registered: ‎05-03-2012
Location: Germany

Re: W520 webcam not working

I tried ubuntu live and the webcam didn't work either.

 

Today I had a remote assistance session with the Lenovo support and they confirmed a hardware fault. Until this morning I was still hoping it was a software error but now I have to get the webcam replaced :smileysad: Thank you for all your replies anyway.

 

Regards, Phil

What's DOS?
colerutstein
Posts: 1
Registered: ‎01-30-2013
Location: United States
0

Re: W520 webcam not working

I have tried all of these steps and my computer still refuses to recognize the webcam.