Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Punch Card
yawnmoth
Posts: 36
Registered: ‎12-24-2007
Location: United States
0

unable to access Intel AMT

I go to http://127.0.0.2:16992/ in an attempt to access the Intel AMT interface (127.0.0.1 doesn't work, oddly enough) and although I get a webpage when visiting that address, it's not a webpage I can use.  To quote from it:

 

Web browser access to Intel® Active Management Technology is disabled on this computer, or the page in the address bar is unavailable.

 

In the BIOS, in Config -> Intel(R) AMT, the following options are present:

 

Intel(R) ATM Control: Enabled

RPAT Timeout: 0

Console Type: VT100+

 

So it doesn't look like there's an option to enable (or disable, for that matter) web access.  The fact that it says console type makes me wonder, though...  is there a way to access Intel AMT via telnet or ssh?  If so, how?

Token Ring
Wendel
Posts: 288
Registered: ‎07-03-2009
Location: USA
0

Re: unable to access Intel AMT

Punch Card
yawnmoth
Posts: 36
Registered: ‎12-24-2007
Location: United States
0

Re: unable to access Intel AMT

That does indeed look helpful - thanks!

Punch Card
yawnmoth
Posts: 36
Registered: ‎12-24-2007
Location: United States
0

Re: unable to access Intel AMT

So I'm still unable to get this working.  The PDF says to hit Ctrl + P or F2 to get to the BIOS.  I try both of those and neither work.  Since the F1 BIOS doesn't present the "ENTER AMT BX SETUP" option that the PDF refers to I was thinking that there was maybe some other sort of hotkey to get to an AMT BIOS setup but, alas, there does not appear to be.

 

Any ideas?

Paper Tape
bigmerlin
Posts: 1
Registered: ‎07-04-2010
Location: Germany
0

Re: unable to access Intel AMT

I had the same problem (on my ThinkPad W510) and found out the following:

You can enter the Intel AMT Bios at startup by doing  the following:

 

1) enter the normal Bios at startup by pressing F1

2) go to "Startup" and change the value of "Boot Mode" to "Diagnostics"

3) save changes and exit by F10

4) wait until the Intel boot agent is displayed and then start press Ctrl + P (again and again) until the desired intel Management Engine BIOS Extension is displayed.

 

(hint: the administrator password is 'admin' and the password changing rules are described in the Intel AMT Quick Reference Guide on page 5)

 

I hope these help!

802.11n
christopherlang
Posts: 501
Registered: ‎03-10-2009
Location: Chicago, IL
0

Re: unable to access Intel AMT

[ Edited ]

I have a W520 where Lenovo also decided to not enable BIOS access to the AMT menus (e.g. seeing ctrl-p option for MBE). Changing the laptops startup to diagnostics and hitting ctrl-p worked for getting into the ME setup. Why does Lenovo do this? What are the other differences between a W520 with a motherboard that is AMT vs. non AMT? Is it just BIOS options? Is this another case of a manufacturer crippling hardware for marketing crap? Just like the Ideapad line and the options to enable VT being disabled though some motherboards and CPU were perfectly VT capable.

 

802.11n
christopherlang
Posts: 501
Registered: ‎03-10-2009
Location: Chicago, IL
0

Re: unable to access Intel AMT

[ Edited ]

This is where I am at with AMT on my W520 4270 for anyone else also trying to get AMT working on their W520 that is not supposed to support AMT (yet the w520 has a vPro sticker, AMT software loaded, AMT firmware and hardware and yet no AMT? -I have a MB that does not support AMT according to the W520 HW ref --why didn't Lenovo tell me not all W520 support AMT???? why did I have to order and then find this out? Just like my Ideapad I used to have and VT and idiot stuff like Lenovo not issuing a BIOS for that laptop to support hw VT and I instead had to rely on a bios mod, thanks a lot Lenovo). Everything looks ok but kvm connections do not work nor do connections using the SOL interface?.?.?. I either get socket access denied errors or interface not found errors (I can't rule out OS problems just yet but I am running the tools as administrator). I can connect to the webgui and am able to connect using the managability commander tool from the managability toolkit but when I try remote control or kvm session I get those errors. This is via both wired and wireless connections on the w520. I have not tried connecting from another machine though should make no difference. Looks like perhaps Lenovo has disabled more than just BIOS options to see the AMT boot options?.?. How does Lenovo put the i7 vPro sticker on all these machines then? Isn't AMT, VT-x, processor, chipset etc. fundamental to having that vPro sticker? Shouldn't it just be the i7 sticker then?

 

C:\DRIVERS\WIN\ME>MEInfoWin.exe

Intel(R) MEInfo Version: 7.1.30.1139 Copyright(C) 2005 - 2011, Intel Corporation. All rights reserved.

Intel(R) Manageability and Security Application code versions:

BIOS Version:                           8BET56WW (1.36 ) MEBx Version:                           7.0.0.56 Gbe Version:                            1.3 VendorID:                               8086 PCH Version:                            4 FW Version:                             7.1.30.1142 UNS Version:                            7.1.2.1043 LMS Version:                            7.1.2.1043 MEI Driver Version:                     7.0.0.1144 Wireless Hardware Version:              1.1.85 Wireless Driver Version:                14.3.0.6

FW Capabilities:                        234249317

    Intel(R) Active Management Technology - PRESENT/ENABLED     Intel(R) Anti-Theft Technology - PRESENT/ENABLED     Intel(R) Capability Licensing Service - PRESENT/ENABLED     Protect Audio Video Path - PRESENT/ENABLED     Intel(R) Dynamic Application Loader - PRESENT/ENABLED

Intel(R) AMT State:                     Enabled CPU Upgrade State:                      Upgrade Capable Cryptography Support:                   Enabled Last ME reset reason:                   Global system reset Local FWUpdate:                         Enabled BIOS and GbE Config Lock:               Enabled Host Read Access to ME:                 Disabled Host Write Access to ME:                Disabled SPI Flash ID #1:                        EF4017 SPI Flash ID VSCC #1:                   20052005 SPI Flash BIOS VSCC:                    20052005 BIOS boot State:                        Post Boot OEM Id:                                 4c656e6f-766f-0000-0000-000000000000 Link Status:                            Link up System UUID:                            ad311d81-51ec-11cb-8f6c-c89ca3c470f3 MAC Address:                            f0-de-f1-ce-ae-b4 IPv4 Address:                           192.168.0.120 Wireless MAC Address:                   64-80-99-58-e5-9c Wireless IPv4 Address:                  0.0.0.0 IPv6 Enablement:                        Disabled Wireless IPv6 Enablement:               Disabled Privacy Level:                          Default Configuration state:                    Completed Provisioning Mode:                      PKI Capability Licensing Service:           Enabled Capability Licensing Service Status:    Permit info not available OEM Tag:                                0x00000000

 

This is a machine fully provisioned for AMT, yet it mostly doesn't work. In a machine where 'varying' motherboards for the same machine, do support AMT. Why is this? Can someone from Lenovo explain to me the technical differences between a machine in this series that does support AMT vs. one that does not? I would really appreciate knowing the technical diffrences.

 

 

Broadband 3G
JDay
Posts: 999
Registered: ‎01-06-2011
Location: Sacramento, CA
0

Re: unable to access Intel AMT

Did you initialize AMT in Windows?

802.11n
christopherlang
Posts: 501
Registered: ‎03-10-2009
Location: Chicago, IL
0

Re: unable to access Intel AMT

Yes. The laptop was provisioned. I just could not establish a KVM or SOL/IDER connection though everything appeared I should be able to, I couldn't.