Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
radish
Posts: 3
Registered: ‎04-12-2012
Location: canada
0
Accepted Solution

w520 - color calibration issue

I recently got a w520, it seems to work properly. However i am having some trouble with the color profile in windows on the laptop. In the advanced display settings I keep trying to set a custom ICC profile but ever time the computer goes into power savings or shuts the monitor off the ICC profile gets reset to the default one.

 

I have scoured these forums as well as various sources around the net for a solution with no avail. Can someone point me in the right direction please and thanks in advance.

Token Ring
qwerty42
Posts: 30
Registered: ‎04-12-2012
Location: USA

Re: w520 - color calibration issue

Here's the fix:

 

Click the Windows start button and type "msconfig" in the search bar; press enter. In the window that pops up, click the "Startup" tab at the top. In the list of items below, you should see three entries for "Intel(R) Common User Interface". To the right of those is a column called Command. One of the entries for Intel Common User Interface will have the command "c:\windows\system32\igfxpers.exe". Un-check the box next to that entry, click Apply at the bottom, and then reboot your computer. Your display profile that you set should stay loaded now.

 

Josh

Paper Tape
radish
Posts: 3
Registered: ‎04-12-2012
Location: canada
0

Re: w520 - color calibration issue

thanks kindly that worked rather well. what does that file do? do you know off hand?

Token Ring
qwerty42
Posts: 30
Registered: ‎04-12-2012
Location: USA
0

Re: w520 - color calibration issue

Glad it worked! I've never noticed any effects of it being disabled, but I've read that it has to do with automatically restoring the display to its native resolution after it's been connected to an external display/docking station/projector, or after rebooting or restoring from hibernation.

What's DOS?
gocheer
Posts: 1
Registered: ‎05-03-2013
Location: Cary, NC
0

Re: w520 - color calibration issue

My W520 color calibration worked fine for a few month then it stopped working for no reason at all. It's been like that for a couple months. I went out and researched these posts. The fix was simple. I made sure my screen resolution was set at max 1920x1080 then I clicked on "Make text and other items larger or smaller" and changed the size from 150% to 125%. I rebooted and reran the calibration progam and it is now working again.

 

This fix was found by someone on this forum. No actual help from lenovo support as expected.