Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Blue Screen Again
buckeyefan
Posts: 7
Registered: ‎05-28-2012
Location: SC
0

w520 only seeing USB devices after restart

My w520 has been acting rather strange recently.   It's actually been acting up for some time but i've ignored it (kind of like putting the black tape over the check engine light).

Most of the issue seems to revolve around my USB.  At some random point in time after starting up my machine, it will stop seeing new usb devices that I plug in unless I restart. Once I restart it sees everything fine.  I can even plug new devices in. However after a while if I try to plug something new in, it won't show.  Likewise it also won't see SD cards that I plug in to the SD slot.

I'm also having an issue where if I try to shut down or restart, the computer will never shut down windows.  It just sits there saying 'shutting down windows' forever, until I just hold the power button to kill it.

 

any ideas?

thanks for any help

__

Intel i7 2.3

Windows 7 x64 Pro

8GB RAM

120 Crucial M4 SSD

500GB Second drive

 

 

 

802.11n
christopherlang
Posts: 499
Registered: ‎03-10-2009
Location: Chicago, IL
0

Re: w520 only seeing USB devices after restart

Hahha good one: kind of like putting the black tape over the check engine light).

 

Isn't that the truth. Check engine light is easier to diagnose though than this w520. Heh heh.

 

 

802.11n
christopherlang
Posts: 499
Registered: ‎03-10-2009
Location: Chicago, IL
0

Re: w520 only seeing USB devices after restart

[ Edited ]

Are you sure it's not devices you have already added to the system before where this is happening? I ask because I have seen similar but it was devices that had already been attached to the system at some point and reattaching them (actually it was an external HD in my case --the external adapter was faulty and would only work sometimes and was not always detected by the OS when reinserted either). Interesting about the reader because I think it too is a USB device (and you mentioned it ;-)). Just an fyi I have also seen similar shutdown behavior on my w520 and that was associated with issues with another USB device, in that case it was the drivers (backing back down to the previous drivers resolved the issue and the laptop would then shutdown properly again. You will have to try to narrow it to the specific device causing the hang. What I would do is just get everything USB at a baseline and then start uninstalling and testing things. You seem to have a couple, related things, going on here but perhaps different root issues. Maybe focus first on the SD cardreader. What are the other devices not detected?

(Sorry for the edits, had to think about the similar issues I had).

Blue Screen Again
buckeyefan
Posts: 7
Registered: ‎05-28-2012
Location: SC
0

Re: w520 only seeing USB devices after restart

Thanks. for the response and glad to know I'm not the only facing similar issues.

It is both devices that are plugged in that once unplugged are not recognize when replugged in and it's all devices that weren't plugged in that aren't recognized when plugged in.

I'll try a few things.  I'm really tempted just do a clean install and go back to ground zero.  This is my mobile machine so there's not really anything major on here that I have to worry about time involved in reinstalling.

802.11n
christopherlang
Posts: 499
Registered: ‎03-10-2009
Location: Chicago, IL
0

Re: w520 only seeing USB devices after restart

[ Edited ]

Sorry, I was thinking some other stuff with the attaching/reattaching, the key thing was the intermittently working adapter. Lol so nothing USB works/is recognised? If I read that correctly?

 

PS I went through that as well (install/reinstalls) at one point troubleshooting issues. It is one reason why I am still using the preload image (as part of my baseline trying to ensure all my hardware works what with all the other issues I have had).

802.11n
christopherlang
Posts: 499
Registered: ‎03-10-2009
Location: Chicago, IL
0

Re: w520 only seeing USB devices after restart

One more thing it may be worth your time going to Microsoft and reviewing Win 7 USB related hotfixes. You might find something that helps with your issues.

Cheers