Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
dgelinas
Posts: 10
Registered: ‎07-30-2009
Location: Massachusetts

Win 7: Fixing the sound card power save speaker click on the n100

[ Edited ]

I've got a 15" 3000 n100 with the adi/soundmax sound card.  I noticed right away after installing windows 7 that the sound card goes into a power save mode after a few minutes and when it comes out of it, the speakers click the first time it tries to play a sound.  very annoying.  does the same thing in vista, but in vista you actually get a soundmax control panel where you can disable the power save mode.  no such luck in win7, at least not until they get around to releasing a proper driver for it.

 

Obviously, such an affront cannot be tolerated, so change these three registry settings and reboot to disable it.

 

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\PowerSettings]
"ConservationIdleTime"=hex:00,00,00,00
"PerformanceIdleTime"=hex:00,00,00,00
"IdlePowerState"=hex:00,00,00,00
"PM_EAPD_Mode"=hex:03

 

Make sure that device 0000 is the soundmax card; it'll tell you in the main 0000 key.

What's DOS?
minilopnews
Posts: 1
Registered: ‎03-27-2011
Location: us
0

Re: Win 7: Fixing the sound card power save speaker click on the n100

Signed up to say thanks. This was bugging the heck out of me.
What's DOS?
tobydjones
Posts: 1
Registered: ‎03-29-2012
Location: UK
0

Re: Win 7: Fixing the sound card power save speaker click on the n100

I signed up just to thank you too :smileyhappy:

Different PC, different MoBo (Asus P5VD2-VM) , but it has a SoundMax internal soundcard.

I couldn't find a driver for Win7, so had to use a Vista one (64-bit) from Asus.

This suffered from power up/down clicks and as you said, I didn't get a control panel.

Changed registry, rebooted, and problem resolved.

Thank you!

 

Punch Card
AMPIA
Posts: 14
Registered: ‎02-24-2012
Location: München
0

Re: Win 7: Fixing the sound card power save speaker click on the n100

Just have the same problem with the annoying sound bips.

 

When i tried to change the registry i saw that ConservationIdletime, Performance Idle Time and Idlepowerstate already had the 00 00 00 00 Value.

 

I just added the PM_EAPD_Mode value. But strangely, nothing changed after reboot. :smileysad:

 

Can anyone help?

What's DOS?
nitro2k01
Posts: 1
Registered: ‎05-29-2012
Location: Derpland
0

Re: Win 7: Fixing the sound card power save speaker click on the n100

Another person signing up to say thanks. On my HP Compaq nx7400 (Ghawd, it sounds silly to say "HP Compaq", but that's what they're technically called.) this setting (I'm assuming) was changed after a driver update. The problem is a bit more sinister than simply an audible click. After the chip had been turned off, it got stuck in a "mute" state, even after resuming sound playback. To get out of this state, I needed to open the volume mixer and manually mute/unmute, or adjust the volume. However, up doing so, the Windows mixer application would hang for a couple of seconds, presumably while the driver was restarted. This was using the official Vista/7 sound driver from HP's homepage.

 

All this while experimenting woth trying to get stereo mix recording to work. Since I'm here, here's the answer for that. In the sound control panel, recording tab, right click the list box and choose show disabled devices. If you just enable the stereo mix device, it's "currently unavailable". No good. Disable the other devices, (or set stereo mix as the default) and now the stereo mix device should be woking. Turns out the sound chip only has one input, which is multiplexed to the input devices.