Support in other languages: 
Reply
Ctrl-Alt-Del
miemens
Posts: 13
Registered: ‎03-31-2009
Location: Georgia, USA
0

Y530, A few x64 RC problems.

Hi guys, I just installed the new RC for the 64bit version of 7 and am having a couple problems. First, all my soft keys work except the Dolby one and the equalizer buttons. Also the play button no longer launches WMP, but the controls work once it is running so I'm fine with that. I really use the Dolby button and equalizer alot though because I alternate between headphones, surround sound and the built in speakers quite often.  Second, I have an unknown device in the Device Manager and I can't figure out what it is. It is not my Bluetooth as I got that to install by using Fn+F5. It says "on Intel(R) ICH9M LPC Interface Controller - 2919" for the location. I've installed all of the Vista drivers with no problems aside from the BT mentioned above. Any ideas on how to fix these issues? Anyone else having them?
Ctrl-Alt-Del
miemens
Posts: 13
Registered: ‎03-31-2009
Location: Georgia, USA
0

Re: Y530, A few x64 RC problems.

Just to update, I've gotten rid of the "Unknown Device" problem by reinstalling the ITE driver. Has anyone gotten all of their touch inductive buttons to work?
Ctrl-Alt-Del
miemens
Posts: 13
Registered: ‎03-31-2009
Location: Georgia, USA
0

Re: Y530, A few x64 RC problems.

OK! I've figured out how to get the equalizer buttons working! If you go to the Realtek site and download the newest drivers (Vista_R2.22) and install those instead of the ones provided by Lenovo, you get back the equalizer and Dolby buttons. The Dolby button however, launches the Realtek HD Audio Manager instead of the Dolby controls. This also fixed a problem I had of my speakers being too quiet and biased to the right.
What's DOS?
sourabhcse
Posts: 1
Registered: ‎09-24-2009
Location: India
0

Re: Y530, A few x64 RC problems.

Hey Buddy Try Installing Energy manegement again,but first uninstall it n thn install again....all the best....

What's DOS?
skido700
Posts: 1
Registered: ‎01-07-2010
Location: Utah
0

Re: Y530, A few x64 RC problems.

OK I went to the Realtek site but I can't find those drivers. Where are they?