Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Posts: 1,035
Registered: ‎04-20-2008
Location: Cary, NC
Accepted Solution

Error 720: Dial-Up Networking could not negotiate a compatible set of network protocols (a solution)

[ Edited ]
If you are experiencing this when trying to use Dialup Networking (ThinkPad Modem) or Verizon VZAccess Broadband, the following may be useful. Note, the solution involves modifying the registry on XP so it is not for the faint of heart.

Note that a key symptom of this problem is that the modem connects and then disconnects just after trying to register the computer on the remote network.

Step 1: Uninstall the WAN Miniport (IP) and WAN Miniport (PPTP)

IMPORTANT: This procedure contains information about modifying the registry.

Before you modify the registry, make sure to back it up and make sure that

you understand how to restore the registry if a problem occurs. For

information about how to back up, restore, and edit the registry, click the following

article number to view the article in the Microsoft Knowledge Base: 256986

( Description of the Microsoft Windows Registry


When you try to use a dial-up connection to connect to your Internet Service

Provider (ISP), you may receive the following error message during the

"Registering your computer on the network" portion of the connection


Error 720 - the connection attempt failed because your computer and the

remote computer could not agree on PPP control protocol.

Additionally, when you view the devices in Device Manager, you may notice a

yellow exclamation mark (!) over the icon for the WAN Miniport IP (#2) device.


This issue may occur if the TCP/IP protocol has become unbound from the

dial-up adapter, or if a conflict is created when a second WAN Miniport IP

device driver loads.


To resolve this issue, uninstall the WAN Miniport IP and PPTP devices.

To do so, follow these steps:

1. Right-click My Computer, and then click Properties.

2. Click the Hardware tab, and then click Device Manager.

3. On the View menu, click Show hidden devices.

4. Under Network adapters, you will see WAN Miniport IP

devices. If a WAN Miniport IP device is listed, continue to the

following step. If no WAN Miniport IP device is listed, go directly

to step 16.

5. Click Start, click Run, type regedit in the Open box, and then click OK.

WARNING: If you use Registry Editor incorrectly, you may cause serious

problems that may require you to reinstall your operating system. Microsoft

cannot guarantee that you can solve problems that result from using Registry

Editor incorrectly. Use Registry Editor at your own risk.

6. Locate the following registry subkey:



7. On the Registry menu, click Export Registry File, type backup-key in

the File name box, and then click Save.

Note You can restore the changes that you make to this registry key. To do

so, double-click the backup-key.reg file that you saved.

8. Click each of the registry subkeys under this key, and then view the Data

column of the DriverDesc value to determine which of the subkeys

corresponds to WAN Miniport (IP). For example, the 0005 subkey.

9. Right-click the subkey whose DriverDesc value data is WAN Miniport (IP) or

WAN Minport (PPTP); (for example, right-click 0005), and then click

Delete. Click Yes to confirm that you want to delete the key.

10. Quit Registry Editor.

11. Right-click My Computer, and then click Properties.

12. Click the Hardware tab, and then click Device Manager.

13. On the View menu, click Show hidden devices.

14. Under Network adapters, right-click WAN Miniport (IP) and then click

Uninstall. Click OK to confirm that you want to remove this device.

15. Repeat for the WAN Miniport (PPTP).

Step 2: Reinstall the WAN Miniports

1. Find netrasa.inf in c:\windows\inf

2. Make a copy of the file and name it

3. Open the orignal copy of netrasa.inf and place a semicolon

in front of the line that starts "Excludefromselect=\" and

and continue with all follwing lines and then end with

"MS_NdisWanNbfIn,MS_NdisWanNbfOut" under the [ControlFlags]

section. (all lines between)

Step 3:

1. Start a Add new hardware session (from Control Panel) and choose

that the hardware is already installed. Choose to "Add New Hardware"

and then select "Network Adapters" followed by "Microsoft" and then

both the PPTP and the IP Wan miniport one at a time.

(NO need to reboot between these steps)

2. After you finish both then reboot.

3. Select Start -> Run and type: netsh int ip reset c:\resetlog.txt

(For details, see

4. Reboot and try your connection.

5. Delete the modified netrasa.inf and rename the original (which was saved as back to netrasa.inf

Message Edited by harrisb on 04-20-2008 06:03 PM

Message Edited by harrisb on 04-20-2008 07:21 PM
W520, i7-2820QM, BIOS 1.42, 1920x1080 FHD, 32 GB RAM, 2000M NVIDIA GPU, Samsung 840 Pro 480GB SSD, Crucial M500 mSata 480GB, WD 2TB USB 3.0, eSata Plextor PX-LB950UE BluRay

W520, i7-2760QM, BIOS 1.42 1920x1080 FHD, 32 GB RAM, 1000M NVIDIA GPU, Crucial M500 480GB mSata SSD, Hitachi 500GB HDD, WD 2TB USB 3.0
What's DOS?
Posts: 2
Registered: ‎04-28-2008
Location: Budapest, Hungary

Error 720: Dial-Up Networking could not negotiate a compatible set of network protocols (a solution)

I have tried to find a solution several times, was reading all the forums, trying everything Microsoft offered to do, but no success. Untill I found this!


(Actually I havent even realized it was a Lenovo related problem...)

Thank you!!!
Paper Tape
Posts: 1
Registered: ‎05-06-2008
Location: Slovakia

Re: Error 720: Dial-Up Networking could not negotiate a compatible set of network protocols

Thank you!

Works great for me on ThinkPad R52 with Windows XP SP2 installed, connecting to VPN created using Microsoft Small Business Server 2003 SP1.
Paper Tape
Posts: 1
Registered: ‎05-14-2008
Location: Finland

Re: Error 720: Dial-Up Networking could not negotiate a compatible set of network protocols

[ Edited ]
This is totally awesome!  The problem is finally gone! :smileyvery-happy:

It has been nearly one and half years since I first experienced this problem with my (back then) brand new T60 (Windows XP) & Nokia E50 GPRS handset. I have tried every single solution that could be found from the web, with no success, and I haven't been able to use the dial-up connection at all. I have no idea what broke this in the first place, it just have never ever worked before.

Thanks for sharing your solution, this helped a lot!

Message Edited by okaalto on 05-14-2008 05:36 AM
What's DOS?
Posts: 1
Registered: ‎07-03-2008
Location: Denver, CO, USA

Re: Error 720: Dial-Up Networking could not negotiate a compatible set of network protocols



Thank you for this solution. Wow. Worked perfectly.  Amazing.



What's DOS?
Posts: 1
Registered: ‎07-06-2008
Location: Austria

Re: Error 720

wow, _THAT_ helped.... this was bugging me for AGES! thx :smileyhappy:
What's DOS?
Posts: 1
Registered: ‎07-17-2008
Location: New Jersey

Re: Error 720

A T60 lenovo with both Verizon and Sprint EVDO wirelesss cards.  Repeat steps 4-14 for both miniports. Ignore error "cannot delete network drivers on step 14", go ahead with the rest of the steps.


Verizon support, Sprint, and company support gave up but it worked even with the error message on step 14 ignore and keep going.

Fanfold Paper
Posts: 5
Registered: ‎07-19-2008
Location: I am from NY, but am traveling in the Caribbean, currently in the Dominican Republic

Re: Error 720: Dial-Up Networking could not....

Dear Harrisb,


Brilliant!  Wroked perfectly, first time.  You saved my brand new Lenovo R61i....which I MUST use with a broadband cellular modem as I am in the Caribbean doing humanitarian service work, mostly out of a pickup truck.


This item  should be marked with a BIG sign that says  "THIS is the solution to Error 720s on dial-up modems."  In my search for a solution, I found that many around the world have the same problem and are desperate for this simple procedure.  


Thank you, 


Kip Hansen



What's DOS?
Posts: 1
Registered: ‎07-31-2008
Location: sydney

THIS WORKED!   I installed AT&T and it stuffed up my...



I installed AT&T and it stuffed up my dialup 56.6kb modem. Also due to this I could not dialup Wireless broadband (Huawei E169) with error 720

Paper Tape
Posts: 2
Registered: ‎08-12-2008
Location: Connecticut

Error 720: Dial-Up Networking could not negotiate a compatible set of network protocols (a solution)

NO NO NO.. It did not work.  Access connection started acting up somewhat.  After I uninstalled it, I couldn't access the internet and my wireless nic card does not turn on (although the light on the laptop shows it's blinking and dev. mgr. is fine)


The exclamation is still there.  When I did the steps (which I tried in so many ways) that were mentioned in this article, once I try to install the wan miniport (ip) i would blue screen.. x0000007 & ndis.sys


PLEASE HELP.. I'm over seas, in Egypt, I miss Connecticut, very upset at the fact I can't use my little X41 and have to haul around a big ol' Toshiba. Needless to say, I get a 720 error when using vpn or dun(wireless gsm/mtds usb card)and yes, i have looked into everything.. from winsock repairs to service packing the machine.  I don't think it's driver related, but if needs be, I'll reinstall them.. but can i get some assistance PLEASE ??? 



Thinkpad X41 tablet

XP tablet edition