Support in other languages: 
Reply
sfu
Fanfold Paper
sfu
Posts: 1
Registered: ‎03-28-2010
Location: US
0

ThinkPad7449 X200T poor keyboard layout design

I just got this laptop and immediately having problem with keyboard layout.  It is especially causing trouble while composing emails or board message when there is no alert about leaving a page... I would hit the go back key by accident when I only mean to move left for a minor correction and lost all I have already typed.  The left mouse key which is applied to relocate the cursor position is too far from the TrackPoint pointing stick for my small size hand that I would add space in current cursor location instead of moving to the new location where the mouse is pointing.

 

I picked this laptop because of the weight.  I didn't realize how distrubing it would be when keys of different applications mixed together.  I think I can try to get used to the farther distance for relocating cursor.  However, I doubt I can make it with the Go Back key (the Go Forward key is less troublesome as left key is used more often than the right key.  

Although up-down-left-right keys are also used in browsing.  Go Back and Go Forward are strickly for browsing.  They are supposed to stay close with keys mainly for browsing and should never be located inside where heavy editing keys located (The Go Back and Go Forward keys are located besides the up key, ABOVE left and right keys respectively and BELOW the Shift key!!!)  

 

 Please do not tell me this layout was designed to force people to use a stylus to write. I definitely type faster.

 

I don't know about the others, but I think when pointing stick is used without a touchpad mouse, the left and right mouse keys should stay closer to the pointing stick, Maybe they can sit on the both ends of the space bar while the Go Back and Go Forward buttons can be moved below current left/right mouse keys.

 

Anyway, anyone knows how to disable the Go Back and Go Forward keys?  Please help.  Thank you very much!

What's DOS?
drrg
Posts: 1
Registered: ‎03-29-2010
Location: USA
0

Re: ThinkPad7449 X200T poor keyboard layout design

There is a Keyboard Customizer Utility provided by Lenovo that says it can disable the Browser Back and Browser Forward buttons.  However, it didn't work correctly for me on my X200T, so I can't recommend it.  So I turned to AutoHotKey, an awesome program/language to customize your computer inputs through mouse and keyboard to do pretty much anything.  I simply directed those keys to do nothing.  If I wanted to, I could have them run other programs or do something else more useful than make me lose the email I just typed! 

 

For the code, I just added the following to the AutoHotKey script:

 

Browser_Back::Return
Browser_Forward::Return

 

This might more detailed than you want to go, but it got the job done for me (especially since I use AutoHotKey for a lot of other customizations).