Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Fanfold Paper
kywc
Posts: 6
Registered: ‎10-16-2011
Location: Toronto, Canada
0

USB Power Hub failure?

Hey everyone,

 

I bought an extra power adapter with my X220T when I bought it about 3 months ago, so I can bring the standard X220T power adapter with me during the day and keep the dock plugged in with the 65W USB Power Hub. However, I noticed the following things that suggest to me the USB Power Hub isn't working properly:

 

1. When I dock the computer, on a full charge, the battery indicator flicks on and off even before I turn it on. It normally flicks on, then goes off pretty quickly when the battery is already full

 

2.  I have different screen brightness settings for when I'm on battery and when I'm on AC. I found the screen would randomly change between the 2 brightnesses, regardless of what I do (In the Lenovo Power Manager, the battery is shown to change between "discharging" and "no activity", matching the changes with my screen brightness)

 

 I've tried plugging the USB power adapter to different AC outlets and there is no change. Has anyone had similar issues? I haven't used my laptop much over the past 2-3 weeks as I've been off on holidays, but that shouldn't affect things. I tried the standard power hub and it is working perfectly fine. 

 

Does this mean I have a faulty Power Hub, or is there something I'm doing wrong? 

 

Thanks in advance, any help is much appreciated!

What's DOS?
kgilbert
Posts: 1
Registered: ‎01-14-2012
Location: Berea, KY
0

Re: USB Power Hub failure?

Hi mine started doing the very same thing. I checked it with a volt-meter and the power is cycling all over the place. Apparently the computer beeps because the voltage drops, the tablet thinks the power has gone off, so it drops into power management mode. Then the voltage cycles up again and it beeps to tell you it's plugged in! Highly annoying.

 

And I can't find a number anywhere to call to get a new one. Do we just call the main number and complain? Clearly they got a bad batch of transformers or something.