Support in other languages: 
Reply
Punch Card
psyops
Posts: 40
Registered: ‎04-13-2011
Location: Seattle
0
Accepted Solution

wandering trackpoing in tablet mode

When I place my LCD into tablet mode, sometimes my mouse wanders slowly on the screen and the touch interface seems to be disabled.  After some trial and error I found that the culprit is that my TrackPoint is gently rubbing against the backside of the LCD. I found that I could make the mouse cursor move rapidly back and forth on the screen just by gently putting pressure on sides of the LCD when the laptop in tablet mode. I own two x220t devices, and this happens on both of them. My TrackPoint touch sensitivity is set 2 ticks to the left of the most sensitive setting.

 

I remember reading somewhere that the TrackPad is disabled when the laptop detects that the LCD is swiveled into tablet mode, so that it doesn't accidentally move the mouse.  Could the TrackPoint be similarly disabled so that it doesn't generate these phantom mouse movements?

 

Token Ring
joesixgig
Posts: 171
Registered: ‎07-20-2009
Location: 91125
0

Re: wandering trackpoing in tablet mode

No solutions, I just had the same issue. Since I haven't seen this happen before, could there be some driver problem that has broken the automatic disabling of the trackpoint button in tablet mode? Does anyone know which component or driver handles the detection of tablet mode and changes settings when needed?

Token Ring
joesixgig
Posts: 171
Registered: ‎07-20-2009
Location: 91125
0

Re: wandering trackpoing in tablet mode

Resolved for me. Even though the issue wasn't stated explicitly in the change logs, installing an updated 'tablet shortcut menu' (V6.33) and the 'MultiTouch Driver' (V7.0.2.29) using System Update fixed this problem for me. 

Token Ring
joesixgig
Posts: 171
Registered: ‎07-20-2009
Location: 91125
0

Re: wandering trackpoing in tablet mode

[ Edited ]

This came back for me upon upgrade to Win8 x64. Lenovo System Update 5 doesn't offer the  'tablet shortcut menu' or the 'MultiTouch Driver' yet, but I'll see if I can install them anyway. 

 

Right now I don't have the ultranav driver or utitlity installed. In fact, the only Lenovo software in 'Programs and Features' are 'System Update', 'System Interface Driver', and 'Power Management Driver'. I think I also installed the 'Tablet Button Driver, since I needed it to enable the screen rotation button. 

 

It would be nice if an expert could let me know which exact tool or driver is needed for turning off trackpoint in tablet mode. 

 

---

 

EDIT:  unstalled the Win8 x64 ultranav drivers (not sure why those don't show in the System Update), but these didn't change the 'wandering trackpoint' issue. 

Serial Port
vlangs
Posts: 84
Registered: ‎09-22-2011
Location: Albany, NY
0

Re: wandering trackpoing in tablet mode

just curious, are the little feet on the keyboard that keeps the screen in place broken?

Mine broke a week into owning my x220 (wasn't too pleased about it) but it causes the screen to apply uneven pressure on the keyboard and that can cause the trackpoint to wander.

drove me insane, until I pressed down on the track point REALLY hard so it depressed a bit and now I'm all good
Token Ring
joesixgig
Posts: 171
Registered: ‎07-20-2009
Location: 91125
0

Re: wandering trackpoing in tablet mode

The rubber bumps on the front corners of the palm rest are still there, as are the alignment 'points' along the sides of the keyboard, but it still happens. I guess we're just behind in driver development. That's what you get for being an early adopter..

Punch Card
Mibars
Posts: 17
Registered: ‎08-07-2012
Location: Poland
0

Re: wandering trackpoing in tablet mode

Do you have a TSMResident.exe process runing in background?

I've noticed that suspending/killing it creates that problem. Unfortunatley this thingy is protecting me from using my tablet in "secondary landscape" because of WWAN adapter...

Punch Card
psyops
Posts: 40
Registered: ‎04-13-2011
Location: Seattle
0

Re: wandering trackpoint in tablet mode

I think installing the tablet shortcut menu solved the problem for me in Windows 7, although I'm not sure if anything else was required in my case since I installed a bunch of things when I got this to work.

 

Now that I'm upgrading to Windows 8.1, this issue has struck again.  The wandering trackpoint issue continues to be a problem for me even after installing the tablet shortcut menu.  The Multi-touch driver doesn't install for me in Windows 8, even when I run it in compatibility mode for Windows 7.  I think the problem might be that the program TSMResident.exe keeps crashing on my system after each boot.  From what I see on the web, that program is part of the tablet shortcut menu package, so if that executable is the one responsible for disabling the trackpoint then it would explain why the trackpoint wanders in tablet mode even with the tablet shortcut menu package installed.

 

I also tried installing the latest Synaptics drivers (which claim Windows 8.1 compatibility) per some tips on other threads, but no luck with that either.

 

I read in a different forum that people using the Lenovo Twist/Helix have had the same problem, but it looks like the solution Lenovo came up with there was to change the UEFI BIOS to disable the trackpoint instead of putting that functionality in some driver package as for the x220T, so that won't work here given that the BIOS for the x220 is incompatible with the Twist.

 

Anyone else have better ideas to try?

 

 

Punch Card
psyops
Posts: 40
Registered: ‎04-13-2011
Location: Seattle
0

Re: wandering trackpoint in tablet mode

I was able to figure out a couple of things that will probably be useful to other people who have this problem in the future.  I was sufficiently annoyed by the problem to repeatedly re-image a machine from scratch until I knew exactly what software was required to get the trackpoint to turn off when the device was put into tablet mode.  Here is the sequence:

 

1) Ensure that both your trackpoint and touchpad are enabled in BIOS (even if you are going to disable the touchpad!)

2) Install a fresh copy of Windows (Windows 8.1 in my case)

3) Install the Intel HD Graphics Driver (I'm not sure this is required for disabling the trackpoint, but it is probably required to rotate the display) (this is installed by Windows update in Windows 8.1)

4) Install the Lenovo Power Management Driver (I'm not sure this is required, but I strongly suspect it is) (this is installed by Windows update in Windows 8.1)

5) Install the Synaptics ThinkPad UltraNav Driver (this is definitely required) (this is installed by Windows update in Windows 8.1)

6) Install the Tablet Button Driver 2 (I'm not sure or not if this is required) 

7) Install the Tablet Shortcut Menu (this is definitely required)

 

Additionally, I have a couple of theories as to how this all works.  The Tablet Shortcut Menu software seems to have the software that detects and initially handles the rotation of the hinge event.  It seems to then notify the UltraNav software somehow to instruct it to disable the trackpoint.  The Tablet Shortcut Menu software also instructs the Intel HD Graphics Driver to rotate the screen on the same event. 

 

One painful lesson that I figured out was that the UltraNav software doesn't disable the trackpoint when the TRACKPAD is disabled in BIOS.  If you want the trackpad disabled, you have to do it in the UltraNav software instead of BIOS if you want the trackpoint disabled in tablet mode.

 

If you've read this far you'd probably think I am currently enjoying my x220t tablet mode now.  Unfortunately, you'd be wrong.  Two days after getting all of this to work successfully, it failed suddenly!  The trackpoint and trackpad options were initially grayed out and the trackpoint stopped working.  I was able to get the trackpoint working again by reinstalling drivers, but the trackpoint disabling in tablet mode no longer works for me and no amount of reinstalling the above drivers fixes the problem.  Who wrote this horrible, glitchy, undocumented, multiple not obviously related package requiring software anyways?  It barely works, and I see that people in these forums have been reporting problems with this feature since at least 2011, and probably earlier.  I'm giving up and am going to manually disable it in the future.  Hopefully the information above will prove more useful to you.