Support in other languages: 
Reply
Blue Screen Again
downlink
Posts: 3
Registered: ‎01-12-2012
Location: Pittsburgh PA, USA
0

Cannot enable AMD-V virtualization extensions in BIOS

Hello All,

 

I recently purchased a like-new X120e and discovered via much trial and tribulation that Fedora and Windows 7 Pro in dual boot configuration just aren't going to happen for me right now. 

 

This wasn't a big deal until I discovered that I can't seem to enable the AMD-V virtualization extensions in BIOS under CPU.  I'll repeatedly enable them and reboot (saving changes of course) and it'll go right back to disabled.

 

Any advice?

 

Many thanks,

 - DownLink

Guru
ColonelONeill
Posts: 6,342
Registered: ‎12-26-2009
Location: Toronto
0

Re: Cannot enable AMD-V virtualization extensions in BIOS

Dual-booting should not require virtualization instructions...
W520: i7-2720QM, Q2000M at 1099/688/1377, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Blue Screen Again
downlink
Posts: 3
Registered: ‎01-12-2012
Location: Pittsburgh PA, USA
0

Re: Cannot enable AMD-V virtualization extensions in BIOS

Per the original post since the UEFI on this machine is causing so many issues with dual booting I'm going to have to use virtualization.  

 

So getting back to the original query:

 

On my 0596 Lenovo X120e, I cannot get AMD V to stay on.  Called Lenovo support (which was pretty impressive), no fuss, no muss - they're going to replace the main board.  

 

I've googled around a bit and found others reporting this, and in each case the mainboard had to be replaced, so this may be a semi-widespread manufacturing issue - especially because as soon as I described the issue they immediately offered to replace the board.

 

 

Paper Tape
fnielsen
Posts: 1
Registered: ‎06-04-2012
Location: Netherlands

[SOLVED] Re: Cannot enable AMD-V virtualization extensions in BIOS

I had the same problem on a Thinkpad X121e (3051): When I enabled AMD-V virtualization in bios it would revert to disabled upon saving of the bios settings.

 

It turned out that Memory Protection is causing the setting to be non-sticky.

 
The solution is simple: 

 

  1. disable "Execution Prevention" (under Security -> Memory Protection);
  2. enabled AMD-V;
  3. enable "Execution Prevention" if you want it on;
  4. save bios settings

 

Flemming from Banana hill
Flemming from Banana hill
SCSI Port
krustybaguette
Posts: 73
Registered: ‎03-27-2011
Location: Massachusetts USA
0

Re: Cannot enable AMD-V virtualization extensions in BIOS

dual boot is not virtualization but on my X60 when making that change in BIOS it is necessary to SHUT DOWN not merely reboot and then restart. So if you DO try virtualization this may also apply with your machine.

Thinkpad X-60 (Linux Mint 13_Maya, running VBox WinXP and Win7

Ideapad K-1 Now running Jelly Bean (kudos to Khanning and krook