Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
qnn007
Posts: 8
Registered: ‎07-28-2008
Location: USA
0

Configure wireless for Lenovo X60 on Fedora 8, anyone?

Has anyone had any luck getting the built-in wireless card to work for lenovo x60 on Fedora? 

 

Any tip is appreciated.

 

-tito

buddinggeek
Posts: 2,856
Topics: 105
Kudos: 141
Blog Posts: 0
Solutions: 119
Registered: ‎02-22-2008
Location: Texas A&M University, Commerce
0

Re: Configure wireless for Lenovo X60 on Fedora 8, anyone?

hello!

 

do u have an external wireless router? try this command if you have another internet connection to your system

can you give what model of card you are using for your x60?

 

login as root

 

go to terminal

 


yum -y install madwifi
You also have to add a line to one of the config files...I think it's /etc/modprobe.conf and you need to add the line: 
alias ath0 ath_pci
and restart Network Manager and u should be good to go. 
 





Cheers and regards,
• » νιנαソѕαяα∂нι ѕαмανє∂αм ™ « •
Think : T410,X220T,Thinkpad Yoga
Idea :3000H,Z500,U410,Yoga 11, Yoga tab 10,Horizon
●๋•کáŕádhí'ک díáŕý ツ


I am a volunteer here. I don't work for Lenovo
Paper Tape
qnn007
Posts: 8
Registered: ‎07-28-2008
Location: USA
0

Re: Configure wireless for Lenovo X60 on Fedora 8, anyone?

Hi,

 

thanks for the quick reply. 

 

:smileyhappy:  there is a wireless router at my house where it communicates with my PC via the wireless connection.  so yes, the wireless capability of my router works.  

 

  I have no idea which card is built-in but the Lenovo X60 is of type 1706 and 85U mode.  How can you find out for sure from a command or if that is even possible?

 

you suggested to create and alias in /etc/modprobe.conf for this wireless device once the driver has been installed as follows:

 

"alias ath0 ath_pci"

 

do you mean eth0?  or ath0 is a new device name that i m not aware of.  to my surprise, the ethernet is labeled as eth1.

 

I'll try to yum install the driver tonight when i get home.

 

BTW, I am having a similar problem with an IBM T42 running fedora 7.  i don't normally use wireless on this laptop because the wireless router (at work) can be flaky at times but it would be nice to install/enable wireless card for it in case i need to bring it home to do some work.   I could very well use the wired connection at home with this T42 as well but it would be nice to use the wireless connection instead.  

 

Any hint/tip would be much appreciated.

 

here is the current ifconfig and modprobe.conf of the T42

 

 $ ifconfig 0a
0a: error fetching interface information: Device not found
[qnguyen@qlaptop Download]$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:0D:60:74:3E:0E  
          inet addr:64.89.226.13  Bcast:64.89.226.255  Mask:255.255.255.0
          inet6 addr: fe80::20d:60ff:fe74:3e0e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:89029 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48293 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:57481828 (54.8 MiB)  TX bytes:7708199 (7.3 MiB)
          Base address:0x8000 Memory:c0220000-c0240000

eth1      Link encap:Ethernet  HWaddr 00:0E:35:1A:smileyvery-happy:5:15  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:1331960 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32805 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0x2000 Memory:c0214000-c0214fff

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6299 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6299 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:37966927 (36.2 MiB)  TX bytes:37966927 (36.2 MiB)

 $ more /etc/modprobe.conf
alias eth0 e1000
alias scsi_hostadapter ata_piix
alias eth1 ipw2200
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0  
options snd-intel8x0 index=0  

 

 

 

 

Notice, it seems to me that driver has already been loaded for the wireless eth1 but it doesn't pick up the signal.  eth0 is the hard wire.  perhaps, there is something i need to tweak?