Support in other languages: 
Reply
Blue Screen Again
goose
Posts: 16
Registered: ‎10-21-2011
Location: Toronto
0
Accepted Solution

How to disable touchpad scroll acceleration?

Hi. I'd like to make more use of TouchPad scrolling feature (by swiping near the edges of the trackpad), but UltraNav settings only let you control speed. It's unusable no matter what speed I set it to, because due to acceleration, it's always too slow or too fast. It takes incredibly delicate concentration and control to make pages scroll at the desired speed.

Is there a way to turn off the acceleration somehow? Any 3rd party driver options?

 

Thank you.

Guru
Mornsgrans
Posts: 2,451
Registered: ‎03-19-2009
Location: Idar-Oberstein, Germany
0

Betreff: How to disable touchpad scroll acceleration?

What Thinkpad-model and which Windows do you use?

--------------------------------
My home-forum: http://www.thinkpad-forum.de
Wiki: Deutsches ThinkPad-Wiki English ThinkWiki
My ThinkPad-Collection
Blue Screen Again
goose
Posts: 16
Registered: ‎10-21-2011
Location: Toronto
0

Betreff: How to disable touchpad scroll acceleration?

Hi. I'm using x120e with Windows 7 Pro.

I have the latest UltraNav drivers from Lenovo.

Guru
ColonelONeill
Posts: 6,641
Registered: ‎12-26-2009
Location: Toronto
0

Betreff: How to disable touchpad scroll acceleration?

Strange. I didn't have an issue with the one-finger scrolling on the X100e.

In which program are you trying to scroll that has the issue? Certain browsers handle scrolling events differently.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Blue Screen Again
goose
Posts: 16
Registered: ‎10-21-2011
Location: Toronto
0

Betreff: How to disable touchpad scroll acceleration?

I'm using Chrome, primarily. The scroll behaviour is indeed different from program to program (for example, chrome skips multiple pages at a time with fast swipe, but notepad or other text editors only skip single page), however the acceleration characteristic is the same for all application and I believe it's tied to UltraNav.

 

I simply want 1-to-1 correspondence to the distance I swipe on the touchpad and the amount of page scrolled, without the speed of swipe being a factor (turn off the acceleration, basically). As of now, it requires extremely delicate control because it's so easy to mistakenly flick my finger and UltraNav interprets it as a fast swipe, and I lose my place in the document.

Blue Screen Again
goose
Posts: 16
Registered: ‎10-21-2011
Location: Toronto
0

Betreff: How to disable touchpad scroll acceleration?

I uploaded a youtube video that demonstrates the problem:

 

http://www.youtube.com/watch?v=ZTfwT3HLN9k

Guru
ColonelONeill
Posts: 6,641
Registered: ‎12-26-2009
Location: Toronto
0

Betreff: How to disable touchpad scroll acceleration?

You can consider switching to TwoFingerScroll (off of Google Code) instead of using the standard one/two finger scroll in UltraNav.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Blue Screen Again
goose
Posts: 16
Registered: ‎10-21-2011
Location: Toronto
0

Betreff: How to disable touchpad scroll acceleration?

[ Edited ]

Thank you for the suggestion. I should've mentioned that two fingered scroll has the exact same problem. It's in fact more difficult to scroll at the right speed, because I have to be precise with 2 fingers instead of just one.

 

I'm trying to find any means of contacting people at Lenovo regarding this issue.  I can't find email address or support ticket page anywhere. Does anyone know how to contact them directly?

Guru
ColonelONeill
Posts: 6,641
Registered: ‎12-26-2009
Location: Toronto

Betreff: How to disable touchpad scroll acceleration?

The UltraNav two finger scroll will likely do that.

I was referring to this one:
http://code.google.com/p/two-finger-scroll/downloads/list

It has a slider for acceleration. Works very consistently for me.
W520: i7-2720QM, Q2000M at 1090/695/1390, 22GB RAM, 500GB HDD, FHD screen
TPT1: 1839-23U, stock ICS
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Blue Screen Again
goose
Posts: 16
Registered: ‎10-21-2011
Location: Toronto
0

Betreff: How to disable touchpad scroll acceleration?

[ Edited ]

Oh I see. Sorry - I misread your reply. I'll try TwoFingerScroll.  Thanks.

 

* I just tried TwoFingerScroll and it behaves exactly as I wanted. I wish it had 1 finger scroll options, but it's still miles ahead of UltraNav's scroll behaviour.  I appreciate it.