Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Token Ring
bylund
Posts: 103
Registered: ‎05-13-2008
Location: Columbia, Mo.
0
Accepted Solution

Update wireless driver?

Please help; any suggestions you might have would be greatly appreciated.

 

The wifi on my X61 7675 CTO (which is upgraded to Windows 7 Professional) is the Thinkpad 11a/b/g Wirless LAN Mini PCI Express Adapter and my current driver is version 7.6.1.237, which seems to be the latest from Lenovo (dated 4/9/09). There is a later driver, however, that keeps popping up in Windows Update as "optional" - but it has version 2.<something> while being dated 10/17/09. So it is later but has much lower version number. Should I update?

 

The reason I ask is that I've been having problems with frequently losing my wireless connection. I only get reconnected if I disable and then enable the wireless device, sometimes I have to do it several times. But still I cannot find anything wrong with it (it is not any of the common issues, such as allowing Windows to shut it down to save energy). I've tried reinstalling the device with the driver package supplied by Lenovo, but nothing seems to help. I don't want to screw things up further by installing an older driver (if it is older; I really can't tell), so I would appreciate your advice.

 

This page seems to state that one should use the driver installed "automatically" by Windows 7. I don't understand if this would be the Windows Update version 2 or the Lenovo version 7... 

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-73682

 

 

Per Bylund

Community SuperMod
bananaman
Posts: 3,653
Registered: ‎04-25-2008
Location: San Francisco
0

Re: Update wireless driver?

[ Edited ]

Very interesting. There seem to be no Lenovo Windows 7 drivers for the Thinkpad 11a/b/g Wireless LAN Mini PCI Express Adapter... odd.

 

I can suggest three ways for you to go to get updated drivers, depending on your risk tolerance an patience:

 

1. Fill out a Lenovo support site feedback form (link on the left side of every support page) and wait (they often respond within 24 hours).

 

2. Removed.

 

3. Let Windows update load the driver from the Microsoft update catalog (it is the correct Atheros driver).

 

Do come back and tell us how it goes!

 

Edit: I removed the most risky option while I do some investigation.

I don't work for Lenovo. I'm a crazy volunteer!
Community SuperMod
bananaman
Posts: 3,653
Registered: ‎04-25-2008
Location: San Francisco
0

Re: Update wireless driver?

Try option #3. I have a T42 with the ThinkPad 11a/b/g Wireless LAN Mini PCI Adapter II, running Windows 7, and the wireless connection is stable.

 

The adapter is based on Atheros hardware, and the 2.0.0.74/5 driver which Microsoft Update loads is newer than the Lenovo Vista driver (and Lenovo uses a different numbering scheme).

I don't work for Lenovo. I'm a crazy volunteer!
Token Ring
bylund
Posts: 103
Registered: ‎05-13-2008
Location: Columbia, Mo.
0

Re: Update wireless driver?

bananaman,

 

I've marked your latest message as solution even though I cannot verify it perfectly yet. The reason is that I've updated the driver using the one made available through Windows Update, and it seems to work perfectly. In fact, I get five bars of signal strength now whereas I usually get either three or four. 

 

However, I am still at work and I usually have more problems using my wifi LAN at home. So I won't be able to tell if this is indeed a full scale solution until tonight. If it isn't I'll post my experiences in this thread either tonight (if I manage to get online...) or tomorrow (while back at work). 

 

Meanwhile, thanks for your help.

 

 

Per Bylund

Community SuperMod
bananaman
Posts: 3,653
Registered: ‎04-25-2008
Location: San Francisco
0

Re: Update wireless driver?

[ Edited ]

Good, I'm keeping my fingers crossed. The card I have in the T42 is not EXACTLY the same as yours (different PCI interface), but it uses the same Atheros chips. Irrespective, Windows update downloads the right Windows 7 driver for you.

I don't work for Lenovo. I'm a crazy volunteer!
Token Ring
bylund
Posts: 103
Registered: ‎05-13-2008
Location: Columbia, Mo.

Re: Update wireless driver?

Update: I've now been online at home for about 90 minutes without interruption. Previously, moving the laptop from being connected to my job wifi to home, always meant the connection would die on me within a couple of minutes, and then I would have to disable+enable the adapter several times before getting it to work again. Not now, obviously. (But I'm still afraid what will happen upon restarting the computer.)

 

Funny thing is, these problems started when I by mistake installed the WU driver update, which I then uninstalled and tried to get the Lenovo driver to work.

 

Thanks for your help, bananaman. I wouldn't have dared installing the WU driver again had it not been for you.

 

 

Per Bylund 

Token Ring
bylund
Posts: 103
Registered: ‎05-13-2008
Location: Columbia, Mo.
0

Re: Update wireless driver?

I finally got a response from Lenovo. Obviously, they are not aware of the latest Atheros driver made available through Windows Update for their machines with Windows 7. This is their response:

 

Dear Per Bylund,
Thank you for your feedback. We apologise that currently we do not have the driver for Thinkpad 11a/b/g Wireless LAN Mini PCI
Express Adapter for Windows 7.

For futher assistance regarding the drivers for Thinkpad 11a/b/g Wireless LAN Mini PCI Express Adapter and WinUpdate, please call the nearest Support Center. For the telephone number, please visit the following URL:
http://www.lenovo.com/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-4HWSE3

Sorry for any inconvenience caused.

Thank you for contacting the Lenovo Web Content Team.

I'm glad I did not contact them first - I've now had a working driver for days while waiting for their no-answer. Thanks again for your help, bananaman.

Paper Tape
catkelly13
Posts: 1
Registered: ‎08-03-2010
Location: US
0

Wireless Conflict?

I seem to have a conflict within my computer. I have windows and Access Connections connecting me to wireless. When I connect to my own wireless router, the tower icon is X ed out with a red X even though the wireless radio is on.  My connection is super slow.  When I connect to someone elses network, everything is fine and the connection is faster.  Any suggestions? Windows 7, Also, not sure how to start a new topic so sorry to hijack this one :-/