Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
awkc
Posts: 4
Registered: ‎09-16-2008
Location: U.S.
0
Accepted Solution

Wireless AGN network adapter unable to connect to wireless N Router in 802.11n mode

I have a x61 with built-in wireless Intel WiFi Link 4965AGN network adpater (driver updated to latest version 12.0.0.82).

 

Just converted my wireless 802.11g router (Linksys) to a 802.11n router (D-Link DIR-655).  Wired connection works great, but wireless is not able to connect in 802.11n mode (only connect in 802.11g mode at the slower 54Mbps).

 

ThinkVantage Access Connections (updated to version 5.02) can identify the new router as 802.11n at 100% signal strength but is not able to connect in 802.11n mode.  Tried to edit the wireless mode of the location profile in Access Connections but there is no selection for 802.11n. 

 

I cannot find any more setup I can edit.  Any known issue with ThinkVantage for 802.11n connection or compatibility issue with Intel WiFi Link 4965 AGN network adaptor?

 

 

 

billbolton
Posts: 1,841
Topics: 68
Kudos: 167
Solutions: 103
Registered: ‎12-02-2007
Location: Sydney, Australia - Best Address on Earth
0

Re: Wireless AGN network adapter unable to connect to wireless N Router in 802.11n mode


awkc wrote:

 

802.11n router (D-Link DIR-655).  Wired connection works great, but wireless is not able to connect in 802.11n mode (only connect in 802.11g mode at the slower 54Mbps).

 


The DIR-655 only operates in the 2.4 Ghz WiFi band so you will never get 270 Mpbs connections from a 4965AGN (which is properly 802.11n Draft 2 compliant dual band device) with it.

 

You need a 802.11n dual band router to get full 802.11n speeds with a 4965AGN.

 

Try enabling WPA2/AES encryption on both the 4965AGN card and your DIR-655 router and you may be able to get 130 Mps connections.

 

Better still, ditch the DIR-655 and get a Linksys WRT-610N or similar (that is, a dual band 802.11n Draft 2 compliant router).


Cheers,

 

Bill

 

------------------------------
I don't work for Lenovo
Paper Tape
awkc
Posts: 4
Registered: ‎09-16-2008
Location: U.S.
0

Re: Wireless AGN network adapter unable to connect to wireless N Router in 802.11n mode

Tried WPA2/AES encrytion but does not help.  Thks.
Community SuperMod
bananaman
Posts: 3,655
Registered: ‎04-25-2008
Location: San Francisco
0

Re: Wireless AGN network adapter unable to connect to wireless N Router in 802.11n mode

Running my X61 Vista Business 32 with 4965AGN WPA2/AES and DIR-655 (1.20 firmware) here, latest drivers, no problem since new. The only difference I can see is that I'm not running Access Connections (I always uninstall it).

 

 

I don't work for Lenovo. I'm a crazy volunteer!
Paper Tape
awkc
Posts: 4
Registered: ‎09-16-2008
Location: U.S.
0

Re: Wireless AGN network adapter unable to connect to wireless N Router in 802.11n mode

Have already upgraded firmware for DIR-655 to 1.20.  Tried uninstall Access Connection and use standard Windows wireless to connect.  No change. 

Community SuperMod
bananaman
Posts: 3,655
Registered: ‎04-25-2008
Location: San Francisco
0

Re: Wireless AGN network adapter unable to connect to wireless N Router in 802.11n mode

One other difference I have is that my 4965AGN driver is the latest LENOVO distributed version, 11.5.0.36, whereas you have the latest Intel version. I would be surprised if that makes it work though :smileysad:.

 

Just out of curiosity, how are you checking what wireless mode and speed you are connected at?

 

Have you tried removing the network in Manage wireless networks, and re-creating it?

I don't work for Lenovo. I'm a crazy volunteer!
Paper Tape
awkc
Posts: 4
Registered: ‎09-16-2008
Location: U.S.
0

Re: Wireless AGN network adapter unable to connect to wireless N Router in 802.11n mode

I finally figured out how to connect Intel 4965AGN to DIR-655 router in 802.11n mode ... by accident!

 

After uninstalling ACCESS CONNECTION, I tried WINDOWS setup and DIR-655 setup to configure my wireless.  WINDOWS setup did not help.  When exploring DIR-655 SETUP > WIRELESS SETTINGS > WIRELESS NETWORK SETUP WIZARD, I accidentally picked "automatically assign a network key" this time instead of "manually" (which I selected in my original setup). This selection disconnected my wireless of course but when I return to manually assign my network key, Intel 4965AGN started to connect in 802.11n at 130Mbps.  Looks like the auto assign network key has added some default setup the user cannot control.

 

By the way, I do have to follow the advice from billbolton to set encryption to WPA2/AES to make it to work.  Thks all for the help!

 

Regarding how I check my wireless status, I use the WINDOWS wireless icon at the bottom right notication area but does not indicate wireless mode.  For DIR-655 setup, I use my IP address as URL in I/E to open.  Under STATUS > WIRELESS, DIR-655 setup shows the wireless mode of my active connection.